Fix build on CURRENT
This commit is contained in:
parent
7fb2273057
commit
db739dcfcd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=102485
3 changed files with 33 additions and 7 deletions
|
@ -24,10 +24,6 @@ INSTALLS_SHLIB= yes
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} > 502000
|
||||
BROKEN= "Does not compile"
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} >= 500000
|
||||
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-*
|
||||
|
||||
|
|
18
devel/rudiments/files/patch-genericsocket.h
Normal file
18
devel/rudiments/files/patch-genericsocket.h
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- include/rudiments/genericsocket.h.bak Mon Apr 15 06:21:25 2002
|
||||
+++ include/rudiments/genericsocket.h Sun Feb 29 01:55:13 2004
|
||||
@@ -4,12 +4,14 @@
|
||||
#ifndef GENERICSOCKET_H
|
||||
#define GENERICSOCKET_H
|
||||
|
||||
-#include <strstream.h>
|
||||
+#include <strstream>
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <sys/un.h>
|
||||
#include <netinet/in.h>
|
||||
#include <netdb.h>
|
||||
+
|
||||
+using namespace std;
|
||||
|
||||
// The client class allows you to write programs that can talk to other
|
||||
// programs over TCP connections.
|
|
@ -1,6 +1,15 @@
|
|||
--- src/daemonprocess.C.orig Tue Oct 28 07:43:40 2003
|
||||
+++ src/daemonprocess.C Tue Oct 28 07:43:46 2003
|
||||
@@ -22,10 +22,10 @@
|
||||
--- src/daemonprocess.C.orig Mon Apr 15 06:21:24 2002
|
||||
+++ src/daemonprocess.C Sun Feb 29 01:53:19 2004
|
||||
@@ -5,7 +5,7 @@
|
||||
|
||||
#include <iostream.h>
|
||||
#include <fstream.h>
|
||||
-#include <strstream.h>
|
||||
+#include <strstream>
|
||||
|
||||
#include <sys/types.h>
|
||||
#ifdef HAVE_UNISTD_H
|
||||
@@ -22,11 +22,13 @@
|
||||
#include <rudiments/daemonprocess.h>
|
||||
|
||||
#ifdef __GNUC__
|
||||
|
@ -13,5 +22,8 @@
|
|||
+void (*daemonprocess::shutdownfunc)(int);
|
||||
+signalhandler *daemonprocess::deadchildhandler;
|
||||
#endif
|
||||
+
|
||||
+using namespace std;
|
||||
|
||||
daemonprocess::daemonprocess() {
|
||||
|
||||
|
|
Loading…
Reference in a new issue