- update to 2.9.8
- recursor defaults off, Option POWERDNS_WITH_RECURSOR
This commit is contained in:
parent
bb859c2c14
commit
dbff6f6915
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=80654
21 changed files with 30 additions and 105 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= powerdns
|
||||
PORTVERSION= 2.9.6
|
||||
PORTVERSION= 2.9.8
|
||||
CATEGORIES= net ipv6
|
||||
MASTER_SITES= http://downloads.powerdns.com/releases/
|
||||
DISTNAME= pdns-${PORTVERSION}
|
||||
|
@ -99,7 +99,7 @@ post-patch:
|
|||
${WRKSRC}/pdns/Makefile.in
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} >= 500043 && ${MACHINE_ARCH} == "i386"
|
||||
.if defined(POWERDNS_WITH_RECURSOR)
|
||||
CONFIGURE_ARGS+= --enable-recursor
|
||||
PLIST_SUB+= RECURSOR=""
|
||||
.else
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (pdns-2.9.6.tar.gz) = 5c954197a8918d1701f8fb2e34654ed9
|
||||
MD5 (pdns-2.9.8.tar.gz) = fdd443276f50520efbe2e2b608499a11
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- modules/gmysqlbackend/gmysqlbackend.cc.orig Tue Dec 17 10:56:43 2002
|
||||
+++ modules/gmysqlbackend/gmysqlbackend.cc Tue Dec 17 11:01:33 2002
|
||||
@@ -20,13 +20,14 @@
|
||||
--- modules/gmysqlbackend/gmysqlbackend.cc.orig Thu Feb 27 13:49:37 2003
|
||||
+++ modules/gmysqlbackend/gmysqlbackend.cc Sun May 11 08:49:16 2003
|
||||
@@ -20,14 +20,14 @@
|
||||
|
||||
gMySQLBackend::gMySQLBackend(const string &mode, const string &suffix) : GSQLBackend(mode,suffix)
|
||||
{
|
||||
|
@ -13,6 +13,7 @@
|
|||
try {
|
||||
- setDB(new SMySQL(getArg("dbname"),
|
||||
- getArg("host"),
|
||||
- getArg("port"),
|
||||
- getArg("socket"),
|
||||
- getArg("user"),
|
||||
- getArg("password")));
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
|
||||
#include <map>
|
||||
#include <vector>
|
||||
- #include <crypt.h>
|
||||
- // #include <crypt.h>
|
||||
#include <exception>
|
||||
#include <stdexcept>
|
||||
#include <string>
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
*** modules/ldapbackend/powerldap.hh.orig Thu Mar 13 20:49:33 2003
|
||||
--- modules/ldapbackend/powerldap.hh Thu Mar 13 20:49:50 2003
|
||||
***************
|
||||
*** 2,8 ****
|
||||
#define POWERLDAP_HH
|
||||
#include <map>
|
||||
#include <vector>
|
||||
- #include <crypt.h>
|
||||
#include <exception>
|
||||
#include <stdexcept>
|
||||
#include <string>
|
||||
--- 2,7 ----
|
|
@ -1,15 +0,0 @@
|
|||
--- pdns/common_startup.cc.orig Tue Dec 17 08:18:41 2002
|
||||
+++ pdns/common_startup.cc Tue Dec 17 08:19:58 2002
|
||||
@@ -270,8 +270,10 @@
|
||||
TN->go(); // tcp nameserver launch
|
||||
|
||||
// fork(); (this worked :-))
|
||||
- for(int n=0;n<arg().asNum("receiver-threads");++n) {
|
||||
- DNSDistributor *D= new DNSDistributor(arg().asNum("distributor-threads")); // the big dispatcher!
|
||||
+ int foo1 = arg().asNum("receiver-threads");
|
||||
+ for(int n=0;n<foo1;++n) {
|
||||
+ int foo2 = arg().asNum("distributor-threads");
|
||||
+ DNSDistributor *D= new DNSDistributor(foo2); // the big dispatcher!
|
||||
pthread_create(&qtid,0,qthread,static_cast<void *>(D)); // receives packets
|
||||
}
|
||||
|
|
@ -1,7 +1,8 @@
|
|||
bin/pdns_control
|
||||
bin/zone2ldap
|
||||
bin/zone2sql
|
||||
sbin/pdns_server
|
||||
%%RECURSOR%%bin/pdns_recursor
|
||||
%%RECURSOR%%sbin/pdns_recursor
|
||||
@unexec if cmp -s %D/etc/pdns.conf %D/etc/pdns.conf-dist; then rm -f %D/etc/pdns.conf; fi
|
||||
etc/pdns.conf-dist
|
||||
@exec [ -f %B/pdns.conf ] || cp %B/%f %B/pdns.conf
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= powerdns
|
||||
PORTVERSION= 2.9.6
|
||||
PORTVERSION= 2.9.8
|
||||
CATEGORIES= net ipv6
|
||||
MASTER_SITES= http://downloads.powerdns.com/releases/
|
||||
DISTNAME= pdns-${PORTVERSION}
|
||||
|
@ -99,7 +99,7 @@ post-patch:
|
|||
${WRKSRC}/pdns/Makefile.in
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} >= 500043 && ${MACHINE_ARCH} == "i386"
|
||||
.if defined(POWERDNS_WITH_RECURSOR)
|
||||
CONFIGURE_ARGS+= --enable-recursor
|
||||
PLIST_SUB+= RECURSOR=""
|
||||
.else
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (pdns-2.9.6.tar.gz) = 5c954197a8918d1701f8fb2e34654ed9
|
||||
MD5 (pdns-2.9.8.tar.gz) = fdd443276f50520efbe2e2b608499a11
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- modules/gmysqlbackend/gmysqlbackend.cc.orig Tue Dec 17 10:56:43 2002
|
||||
+++ modules/gmysqlbackend/gmysqlbackend.cc Tue Dec 17 11:01:33 2002
|
||||
@@ -20,13 +20,14 @@
|
||||
--- modules/gmysqlbackend/gmysqlbackend.cc.orig Thu Feb 27 13:49:37 2003
|
||||
+++ modules/gmysqlbackend/gmysqlbackend.cc Sun May 11 08:49:16 2003
|
||||
@@ -20,14 +20,14 @@
|
||||
|
||||
gMySQLBackend::gMySQLBackend(const string &mode, const string &suffix) : GSQLBackend(mode,suffix)
|
||||
{
|
||||
|
@ -13,6 +13,7 @@
|
|||
try {
|
||||
- setDB(new SMySQL(getArg("dbname"),
|
||||
- getArg("host"),
|
||||
- getArg("port"),
|
||||
- getArg("socket"),
|
||||
- getArg("user"),
|
||||
- getArg("password")));
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
|
||||
#include <map>
|
||||
#include <vector>
|
||||
- #include <crypt.h>
|
||||
- // #include <crypt.h>
|
||||
#include <exception>
|
||||
#include <stdexcept>
|
||||
#include <string>
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
*** modules/ldapbackend/powerldap.hh.orig Thu Mar 13 20:49:33 2003
|
||||
--- modules/ldapbackend/powerldap.hh Thu Mar 13 20:49:50 2003
|
||||
***************
|
||||
*** 2,8 ****
|
||||
#define POWERLDAP_HH
|
||||
#include <map>
|
||||
#include <vector>
|
||||
- #include <crypt.h>
|
||||
#include <exception>
|
||||
#include <stdexcept>
|
||||
#include <string>
|
||||
--- 2,7 ----
|
|
@ -1,15 +0,0 @@
|
|||
--- pdns/common_startup.cc.orig Tue Dec 17 08:18:41 2002
|
||||
+++ pdns/common_startup.cc Tue Dec 17 08:19:58 2002
|
||||
@@ -270,8 +270,10 @@
|
||||
TN->go(); // tcp nameserver launch
|
||||
|
||||
// fork(); (this worked :-))
|
||||
- for(int n=0;n<arg().asNum("receiver-threads");++n) {
|
||||
- DNSDistributor *D= new DNSDistributor(arg().asNum("distributor-threads")); // the big dispatcher!
|
||||
+ int foo1 = arg().asNum("receiver-threads");
|
||||
+ for(int n=0;n<foo1;++n) {
|
||||
+ int foo2 = arg().asNum("distributor-threads");
|
||||
+ DNSDistributor *D= new DNSDistributor(foo2); // the big dispatcher!
|
||||
pthread_create(&qtid,0,qthread,static_cast<void *>(D)); // receives packets
|
||||
}
|
||||
|
|
@ -1,7 +1,8 @@
|
|||
bin/pdns_control
|
||||
bin/zone2ldap
|
||||
bin/zone2sql
|
||||
sbin/pdns_server
|
||||
%%RECURSOR%%bin/pdns_recursor
|
||||
%%RECURSOR%%sbin/pdns_recursor
|
||||
@unexec if cmp -s %D/etc/pdns.conf %D/etc/pdns.conf-dist; then rm -f %D/etc/pdns.conf; fi
|
||||
etc/pdns.conf-dist
|
||||
@exec [ -f %B/pdns.conf ] || cp %B/%f %B/pdns.conf
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= powerdns
|
||||
PORTVERSION= 2.9.6
|
||||
PORTVERSION= 2.9.8
|
||||
CATEGORIES= net ipv6
|
||||
MASTER_SITES= http://downloads.powerdns.com/releases/
|
||||
DISTNAME= pdns-${PORTVERSION}
|
||||
|
@ -99,7 +99,7 @@ post-patch:
|
|||
${WRKSRC}/pdns/Makefile.in
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} >= 500043 && ${MACHINE_ARCH} == "i386"
|
||||
.if defined(POWERDNS_WITH_RECURSOR)
|
||||
CONFIGURE_ARGS+= --enable-recursor
|
||||
PLIST_SUB+= RECURSOR=""
|
||||
.else
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (pdns-2.9.6.tar.gz) = 5c954197a8918d1701f8fb2e34654ed9
|
||||
MD5 (pdns-2.9.8.tar.gz) = fdd443276f50520efbe2e2b608499a11
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- modules/gmysqlbackend/gmysqlbackend.cc.orig Tue Dec 17 10:56:43 2002
|
||||
+++ modules/gmysqlbackend/gmysqlbackend.cc Tue Dec 17 11:01:33 2002
|
||||
@@ -20,13 +20,14 @@
|
||||
--- modules/gmysqlbackend/gmysqlbackend.cc.orig Thu Feb 27 13:49:37 2003
|
||||
+++ modules/gmysqlbackend/gmysqlbackend.cc Sun May 11 08:49:16 2003
|
||||
@@ -20,14 +20,14 @@
|
||||
|
||||
gMySQLBackend::gMySQLBackend(const string &mode, const string &suffix) : GSQLBackend(mode,suffix)
|
||||
{
|
||||
|
@ -13,6 +13,7 @@
|
|||
try {
|
||||
- setDB(new SMySQL(getArg("dbname"),
|
||||
- getArg("host"),
|
||||
- getArg("port"),
|
||||
- getArg("socket"),
|
||||
- getArg("user"),
|
||||
- getArg("password")));
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
|
||||
#include <map>
|
||||
#include <vector>
|
||||
- #include <crypt.h>
|
||||
- // #include <crypt.h>
|
||||
#include <exception>
|
||||
#include <stdexcept>
|
||||
#include <string>
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
*** modules/ldapbackend/powerldap.hh.orig Thu Mar 13 20:49:33 2003
|
||||
--- modules/ldapbackend/powerldap.hh Thu Mar 13 20:49:50 2003
|
||||
***************
|
||||
*** 2,8 ****
|
||||
#define POWERLDAP_HH
|
||||
#include <map>
|
||||
#include <vector>
|
||||
- #include <crypt.h>
|
||||
#include <exception>
|
||||
#include <stdexcept>
|
||||
#include <string>
|
||||
--- 2,7 ----
|
|
@ -1,15 +0,0 @@
|
|||
--- pdns/common_startup.cc.orig Tue Dec 17 08:18:41 2002
|
||||
+++ pdns/common_startup.cc Tue Dec 17 08:19:58 2002
|
||||
@@ -270,8 +270,10 @@
|
||||
TN->go(); // tcp nameserver launch
|
||||
|
||||
// fork(); (this worked :-))
|
||||
- for(int n=0;n<arg().asNum("receiver-threads");++n) {
|
||||
- DNSDistributor *D= new DNSDistributor(arg().asNum("distributor-threads")); // the big dispatcher!
|
||||
+ int foo1 = arg().asNum("receiver-threads");
|
||||
+ for(int n=0;n<foo1;++n) {
|
||||
+ int foo2 = arg().asNum("distributor-threads");
|
||||
+ DNSDistributor *D= new DNSDistributor(foo2); // the big dispatcher!
|
||||
pthread_create(&qtid,0,qthread,static_cast<void *>(D)); // receives packets
|
||||
}
|
||||
|
|
@ -1,7 +1,8 @@
|
|||
bin/pdns_control
|
||||
bin/zone2ldap
|
||||
bin/zone2sql
|
||||
sbin/pdns_server
|
||||
%%RECURSOR%%bin/pdns_recursor
|
||||
%%RECURSOR%%sbin/pdns_recursor
|
||||
@unexec if cmp -s %D/etc/pdns.conf %D/etc/pdns.conf-dist; then rm -f %D/etc/pdns.conf; fi
|
||||
etc/pdns.conf-dist
|
||||
@exec [ -f %B/pdns.conf ] || cp %B/%f %B/pdns.conf
|
||||
|
|
Loading…
Reference in a new issue