popa3d is a POP3 server with the following goals:

1. Security (to the extent that is possible with POP3 at all, of course).
2. Reliability (again, as limited by the mailbox format and the protocol).
3. RFC compliance (slightly relaxed to work with real-world POP3 clients).
4. Performance (limited by the more important goals, above).

PR:		16652
Submitted by:	Sergey Samoyloff <techline@hotmail.ru>
This commit is contained in:
Chris D. Faulhaber 2000-02-19 13:21:54 +00:00
parent ebb5a1d803
commit dc2053998b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=26003
9 changed files with 179 additions and 0 deletions

47
mail/popa3d/Makefile Normal file
View file

@ -0,0 +1,47 @@
# New ports collection makefile for: popa3d
# Version required: 0.4
# Date created: Sun Feb 6 12:31:29 MSK 2000
# Whom: Sergey Samoyloff <gonza@techline.ru>
#
# $FreeBSD$
#
DISTNAME= popa3d-0.4
CATEGORIES= mail
MASTER_SITES= ftp://ftp.false.com/pub/security/popa3d/
MAINTAINER= gonza@techline.ru
post-install:
@ ${ECHO} "==========================================================================="
@ ${ECHO} "1. Edit your /etc/inetd.conf to use popa3d. The line should look like this:"
@ ${ECHO} ""
@ ${ECHO} "pop3 stream tcp nowait root /usr/local/libexec/popa3d popa3d"
@ ${ECHO} ""
@ ${ECHO} "Note: when started via an inetd clone, the logging of connections is left"
@ ${ECHO} "up to that inetd clone or TCP wrappers."
@ ${ECHO} ""
@ ${ECHO} "2. Restart inetd by sending it a SIGHUP:"
@ ${ECHO} ""
@ ${ECHO} "# killall -HUP inetd"
@ ${ECHO} "==========================================================================="
do-install:
${INSTALL} ${COPY} -o root -g wheel -m 500 \
${WRKSRC}/popa3d ${PREFIX}/libexec/popa3d
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/popa3d
${INSTALL_MAN} ${WRKSRC}/INSTALL \
${PREFIX}/share/doc/popa3d
${INSTALL_MAN} ${WRKSRC}/DESIGN \
${PREFIX}/share/doc/popa3d
${INSTALL_MAN} ${WRKSRC}/COPYING \
${PREFIX}/share/doc/popa3d
.endif
pre-install:
${SH} ${PKGDIR}/INSTALL ${PKGNAME} PRE-INSTALL
.include <bsd.port.mk>

1
mail/popa3d/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (popa3d-0.4.tar.gz) = 4ce2ed209abeaeaae7724d8d24bb7dbf

View file

@ -0,0 +1,28 @@
--- params.h.orig Tue Feb 1 09:16:24 2000
+++ params.h Sun Feb 6 15:24:46 2000
@@ -62,7 +62,7 @@
* Do we have shadow passwords? (Not for *BSD.)
* Note: password aging is not supported.
*/
-#define AUTH_SHADOW 1
+#define AUTH_SHADOW 0
/*
* A salt used to waste some CPU time on dummy crypt(3) calls and make
@@ -81,14 +81,14 @@
* Your mail spool directory. Note: only local (non-NFS) mode 775 mail
* spools are currently supported.
*/
-#define MAIL_SPOOL_PATH "/var/spool/mail"
+#define MAIL_SPOOL_PATH "/var/mail"
/*
* How do we talk to syslogd? These should be fine for most systems.
*/
#define SYSLOG_IDENT "popa3d"
#define SYSLOG_OPTIONS LOG_PID
-#define SYSLOG_FACILITY LOG_DAEMON
+#define SYSLOG_FACILITY LOG_MAIL
#define SYSLOG_PRIORITY LOG_NOTICE
/*

View file

@ -0,0 +1,24 @@
--- Makefile.orig Tue Feb 1 06:56:46 2000
+++ Makefile Sun Feb 6 13:31:49 2000
@@ -1,9 +1,9 @@
-CC = gcc
+CC?= gcc
LD = gcc
RM = rm -f
CFLAGS = -c -Wall -O2 -fomit-frame-pointer
-LDFLAGS = -s
-#LDFLAGS = -s -lcrypt
+#LDFLAGS = -s
+LDFLAGS = -s -lcrypt
PROJ = popa3d
OBJS = md5/md5.o \
@@ -12,7 +12,7 @@
protocol.o database.o mailbox.o \
misc.o
-popa3d: $(OBJS)
+all: $(OBJS)
$(LD) $(LDFLAGS) $(OBJS) -o popa3d
md5/md5.o: md5/md5.c md5/md5.h

1
mail/popa3d/pkg-comment Normal file
View file

@ -0,0 +1 @@
Tiny, Secure, Performance POP3 daemon.

20
mail/popa3d/pkg-deinstall Normal file
View file

@ -0,0 +1,20 @@
#!/bin/sh
USER=popa3d
GROUP=popa3d
case $2 in
DEINSTALL)
;;
POST-DEINSTALL)
pw groupdel $GROUP
pw userdel $USER
;;
*)
echo "usage: $0 <pkg-name>
{DEINSTALL|POST-DEINSTALL}"
exit 64
esac
exit 0

14
mail/popa3d/pkg-descr Normal file
View file

@ -0,0 +1,14 @@
The popa3d goals
================
Well, the goals themselves are obvious; they"re probably the same for most
other POP3 servers as well. It"s their priority that differs. For popa3d,
the goals are:
1. Security (to the extent that is possible with POP3 at all, of course).
2. Reliability (again, as limited by the mailbox format and the protocol).
3. RFC compliance (slightly relaxed to work with real-world POP3 clients).
4. Performance (limited by the more important goals, above).
-- Sergey Samoyloff
gonza@techline.ru

39
mail/popa3d/pkg-install Normal file
View file

@ -0,0 +1,39 @@
#!/bin/sh
USER=popa3d
UID=89
GID=89
GROUP=popa3d
GECOS="popa3d"
HOME=/nonexistent
SHELL=/sbin/nologin
case $2 in
PRE-INSTALL)
which -s pw || {
cat << EOF
I see that it is missing the "pw" utility. I need this utility.
Please get it and install it, and try again.
EOF
exit 1
}
pw groupshow $GROUP > /dev/null 2>&1 || {
pw groupadd $GROUP -g $GID;
}
pw usershow $USER > /dev/null 2>&1 || {
pw useradd $USER -g $GROUP -u $UID -h - -d $HOME -s $SHELL -c "$GECOS";
}
;;
POST-INSTALL)
;;
*)
echo "usage: $0 <pkg-name> {PRE-INSTALL|POST-INSTALL}"
exit 64
esac
exit 0

5
mail/popa3d/pkg-plist Normal file
View file

@ -0,0 +1,5 @@
libexec/popa3d
share/doc/popa3d/DESIGN
share/doc/popa3d/INSTALL
share/doc/popa3d/COPYING
@dirrm share/doc/popa3d