- Update to 0.14
- Update pkg-descr PR: ports/187002 Submitted by: Kubilay Kocak <koobs.freebsd at gmail.com>
This commit is contained in:
parent
b5067de7d0
commit
dc5b6afed5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=347183
4 changed files with 13 additions and 25 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= openssl
|
||||
PORTVERSION= 0.13
|
||||
PORTVERSION= 0.14
|
||||
CATEGORIES= security python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -12,26 +12,25 @@ MAINTAINER= sbz@FreeBSD.org
|
|||
COMMENT= Python interface to the OpenSSL library
|
||||
|
||||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0.2.1:${PORTSDIR}/security/py-cryptography \
|
||||
${PYTHON_PKGNAMEPREFIX}six>=1.5.2:${PORTSDIR}/devel/py-six
|
||||
|
||||
OPTIONS_DEFINE= EXAMPLES
|
||||
|
||||
USE_PYTHON= yes
|
||||
USE_PYTHON_PREFIX= yes
|
||||
USE_PYDISTUTILS= yes
|
||||
PYDISTUTILS_AUTOPLIST= yes
|
||||
USE_OPENSSL= yes
|
||||
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
|
||||
PORTEXAMPLES= *
|
||||
|
||||
OPTIONS_DEFINE= EXAMPLES
|
||||
|
||||
pre-configure:
|
||||
@${ECHO_CMD} "[build_ext]" >> ${WRKSRC}/setup.cfg
|
||||
@${ECHO_CMD} "include-dirs = ${OPENSSLINC}" >> ${WRKSRC}/setup.cfg
|
||||
@${ECHO_CMD} "library-dirs = ${OPENSSLLIB}" >> ${WRKSRC}/setup.cfg
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
|
||||
|
||||
regression-test: build
|
||||
@(cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test)
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (pyOpenSSL-0.13.tar.gz) = 21e12b03abaa0e04ecc8cd9c251598f71bae11c9f385304234e4ea5618c6163b
|
||||
SIZE (pyOpenSSL-0.13.tar.gz) = 250489
|
||||
SHA256 (pyOpenSSL-0.14.tar.gz) = a99db8e59c120138ad8a72eecedcc24b4510d2eed3ce48213b7e32f22cc4ee6e
|
||||
SIZE (pyOpenSSL-0.14.tar.gz) = 128005
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- ./OpenSSL/ssl/ssl.h.orig 2011-09-02 17:46:13.000000000 +0200
|
||||
+++ ./OpenSSL/ssl/ssl.h 2011-09-12 15:49:37.000000000 +0200
|
||||
@@ -73,4 +73,8 @@
|
||||
|
||||
#endif /* SSL_MODULE */
|
||||
|
||||
+#if !defined(TLSEXT_NAMETYPE_host_name) && defined(__FreeBSD__)
|
||||
+#define TLSEXT_NAMETYPE_host_name 0
|
||||
+#endif
|
||||
+
|
||||
#endif /* PyOpenSSL_SSL_H_ */
|
|
@ -1,3 +1,3 @@
|
|||
pyOpenSSL - A Python wrapper around the OpenSSL library
|
||||
Python interface to the OpenSSL library
|
||||
|
||||
WWW: http://pyopenssl.sourceforge.net/
|
||||
WWW: https://github.com/pyca/pyopenssl
|
||||
|
|
Loading…
Reference in a new issue