- Unbreak build
PR: 177473 Submitted by: maintainer Reported by: pointyhat
This commit is contained in:
parent
8822ceead2
commit
dcce2e2940
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315593
2 changed files with 12 additions and 10 deletions
|
@ -1,7 +1,4 @@
|
|||
# New ports collection makefile for: p5-DBD-cego
|
||||
# Date created: Jul 2, 2010
|
||||
# Whom: Kurt Jaeger <fbsd-ports@opsec.eu>
|
||||
#
|
||||
# Created by: Kurt Jaeger <fbsd-ports@opsec.eu>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= DBD-cego
|
||||
|
@ -24,4 +21,7 @@ CC:= ${CXX}
|
|||
|
||||
MAN3= DBD::Cego.3
|
||||
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e 's|fno-strict-aliasing|fno-strict-aliasing -fpermissive|g' ${WRKSRC}/Makefile
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.PL 2010-09-17 10:14:49.000000000 +0200
|
||||
+++ /tmp/bla/Makefile.PL 2011-04-24 22:00:03.000000000 +0200
|
||||
@@ -25,30 +25,21 @@
|
||||
--- Makefile.PL.orig 2010-09-17 10:14:49.000000000 +0200
|
||||
+++ Makefile.PL 2013-03-29 14:42:20.000000000 +0100
|
||||
@@ -25,30 +25,22 @@
|
||||
Getopt::Long::GetOptions(
|
||||
$opt,
|
||||
"help",
|
||||
|
@ -28,15 +28,17 @@
|
|||
- 'MYEXTLIB' => $opt->{'prefix'} . "/lib/libcego.a "
|
||||
- . $opt->{'prefix'} . "/lib/liblfcxml.a "
|
||||
- . $opt->{'prefix'} . "/lib/liblfc.a",
|
||||
- "CC" => "g++",
|
||||
- "LD" => "g++",
|
||||
+ 'INC' => '-I$(DBI_INSTARCH_DIR) -I/usr/local/include',
|
||||
+ 'MYEXTLIB' => '-lcego -llfcxml -llfc',
|
||||
"CC" => "g++",
|
||||
- "LD" => "g++",
|
||||
+ 'CC' => 'g++',
|
||||
+ 'CCFLAGS' => '-O2 -pipe -fno-strict-aliasing -fpermissive',
|
||||
+ "LD" => "g++ -L/usr/local/lib",
|
||||
"XSPROTOARG" => "-noprototypes",
|
||||
'OPTIMIZE' => '-O6 -DNDEBUG=1',
|
||||
'XSOPT' => '-C++',
|
||||
@@ -59,12 +50,6 @@
|
||||
@@ -59,12 +51,6 @@
|
||||
sub Usage {
|
||||
print STDERR <<"USAGE";
|
||||
Usage: perl $0 [options]
|
||||
|
|
Loading…
Reference in a new issue