devel/elfutils: Update to latest 0.168

Update to latest upstream version, 0.168.

0.168 removes the eu-ld utility and adds the eu-elfcompress utility.

Requested by:	emaste@, kib@
Approved by:	bapt@
Sponsored by:	Dell EMC Isilon
Differential Revision:	https://reviews.freebsd.org/D9240
This commit is contained in:
Conrad Meyer 2017-01-21 00:38:30 +00:00
parent 360612467a
commit dce71a4e6d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=432006
19 changed files with 114 additions and 206 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= elfutils
PORTVERSION= 0.163
PORTREVISION= 7
PORTVERSION= 0.168
CATEGORIES= devel
MASTER_SITES= https://sourceware.org/elfutils/ftp/${PORTVERSION}/

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1468426694
SHA256 (elfutils-0.163.tar.bz2) = 7c774f1eef329309f3b05e730bdac50013155d437518a2ec0e24871d312f2e23
SIZE (elfutils-0.163.tar.bz2) = 6029307
TIMESTAMP = 1484780542
SHA256 (elfutils-0.168.tar.bz2) = b88d07893ba1373c7dd69a7855974706d05377766568a7d9002706d5de72c276
SIZE (elfutils-0.168.tar.bz2) = 6840399

View file

@ -1,11 +1,12 @@
--- lib/Makefile.am.orig 2016-07-13 07:11:15 UTC
--- lib/Makefile.am.orig 2016-12-28 09:32:00 UTC
+++ lib/Makefile.am
@@ -35,7 +35,7 @@ noinst_LIBRARIES = libeu.a
@@ -35,7 +35,8 @@ noinst_LIBRARIES = libeu.a
libeu_a_SOURCES = xstrdup.c xstrndup.c xmalloc.c next_prime.c \
crc32.c crc32_file.c md5.c sha1.c \
- color.c
+ color.c error.c obstack.c obstack_printf.c
- color.c version.c
+ color.c version.c error.c obstack.c \
+ obstack_printf.c
noinst_HEADERS = fixedsizehash.h system.h dynamicsizehash.h list.h md5.h \
sha1.h eu-config.h
noinst_HEADERS = fixedsizehash.h libeu.h system.h dynamicsizehash.h list.h \
md5.h sha1.h eu-config.h

View file

@ -1,4 +1,4 @@
--- lib/features.h.orig 2016-07-13 04:39:31 UTC
--- lib/features.h.orig 2017-01-19 00:02:16 UTC
+++ lib/features.h
@@ -0,0 +1,1 @@
@@ -0,0 +1 @@
+/* Nop. */

View file

@ -1,15 +1,15 @@
--- lib/system.h.orig 2014-02-05 00:21:43 UTC
--- lib/system.h.orig 2016-12-28 09:32:00 UTC
+++ lib/system.h
@@ -29,6 +29,8 @@
#ifndef LIB_SYSTEM_H
#define LIB_SYSTEM_H 1
@@ -33,6 +33,8 @@
# include <config.h>
#endif
+#include <ssp/string.h>
+
#include <argp.h>
#include <errno.h>
#include <stddef.h>
#include <stdint.h>
@@ -36,16 +38,18 @@
@@ -42,16 +44,18 @@
#include <byteswap.h>
#include <unistd.h>

View file

@ -1,4 +1,4 @@
--- libdw/Makefile.am.orig 2015-06-10 19:44:33 UTC
--- libdw/Makefile.am.orig 2016-12-25 13:36:55 UTC
+++ libdw/Makefile.am
@@ -105,14 +105,14 @@ am_libdw_pic_a_OBJECTS = $(libdw_a_SOURC
libdw_so_SOURCES =
@ -8,12 +8,12 @@
+ ../libelf/libelf.so ../lib/libeu.a
# The rpath is necessary for libebl because its $ORIGIN use will
# not fly in a setuid executable that links in libdw.
$(LINK) -shared -o $@ -Wl,--soname,$@.$(VERSION),-z,defs \
$(AM_V_CCLD)$(LINK) -shared -o $@ -Wl,--soname,$@.$(VERSION),-z,defs \
-Wl,--enable-new-dtags,-rpath,$(pkglibdir) \
-Wl,--version-script,$<,--no-undefined \
-Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
- -ldl $(argp_LDADD) $(zip_LIBS)
+ $(argp_LDADD) $(zip_LIBS)
- -ldl -lz $(argp_LDADD) $(zip_LIBS)
+ -lz $(argp_LDADD) $(zip_LIBS)
@$(textrel_check)
ln -fs $@ $@.$(VERSION)
$(AM_V_at)ln -fs $@ $@.$(VERSION)

View file

@ -1,6 +1,6 @@
--- libdw/dwarf_getsrclines.c.orig 2015-06-10 19:44:33 UTC
--- libdw/dwarf_getsrclines.c.orig 2016-12-25 13:36:55 UTC
+++ libdw/dwarf_getsrclines.c
@@ -188,7 +188,7 @@ read_srclines (Dwarf *dbg,
@@ -273,7 +273,7 @@ read_srclines (Dwarf *dbg,
/* Remember array with the standard opcode length (-1 to account for
the opcode with value zero not being mentioned). */
const uint8_t *standard_opcode_lengths = linep - 1;

View file

@ -1,4 +1,4 @@
--- libdwfl/dwfl_error.c.orig 2015-06-10 19:44:33 UTC
--- libdwfl/dwfl_error.c.orig 2016-12-25 13:36:55 UTC
+++ libdwfl/dwfl_error.c
@@ -136,7 +136,7 @@ __libdwfl_seterrno (Dwfl_Error error)
global_error = canonicalize (error);
@ -7,9 +7,9 @@
-
+static __thread char strerr_buf[64];
const char *
dwfl_errmsg (error)
int error;
@@ -155,7 +155,9 @@ dwfl_errmsg (error)
dwfl_errmsg (int error)
{
@@ -154,7 +154,9 @@ dwfl_errmsg (int error)
switch (error &~ 0xffff)
{
case OTHER_ERROR (ERRNO):

View file

@ -1,4 +1,4 @@
--- libelf/elf.h.orig 2015-06-10 19:44:33 UTC
--- libelf/elf.h.orig 2016-12-25 13:36:55 UTC
+++ libelf/elf.h
@@ -54,6 +54,7 @@ typedef uint64_t Elf64_Off;
/* Type for section indices, which are 16-bit quantities. */
@ -8,7 +8,7 @@
/* Type for version symbol information. */
typedef Elf32_Half Elf32_Versym;
@@ -972,6 +973,7 @@ typedef struct
@@ -1109,6 +1110,7 @@ typedef struct
on 64-bit platforms and vice versa. */
} a_un;
} Elf64_auxv_t;

View file

@ -1,4 +1,4 @@
--- libelf/gelf.h.orig 2014-02-05 00:21:44 UTC
--- libelf/gelf.h.orig 2016-12-28 09:32:00 UTC
+++ libelf/gelf.h
@@ -65,6 +65,10 @@ typedef Elf64_Ehdr GElf_Ehdr;
typedef Elf64_Shdr GElf_Shdr;
@ -11,7 +11,7 @@
/* XXX This should probably be a larger type in preparation of times when
regular section indices can be larger. */
typedef Elf64_Section GElf_Section;
@@ -107,6 +111,19 @@ typedef Elf64_Versym GElf_Versym;
@@ -110,6 +114,19 @@ typedef Elf64_Versym GElf_Versym;
/* Auxiliary vector. */

View file

@ -1,54 +0,0 @@
--- libelf/libelf.h.orig 2014-08-18 19:48:26 UTC
+++ libelf/libelf.h
@@ -74,7 +74,7 @@ typedef struct
Elf_Type d_type; /* Type of this piece of data. */
unsigned int d_version; /* ELF version. */
size_t d_size; /* Size in bytes. */
- loff_t d_off; /* Offset into section. */
+ off_t d_off; /* Offset into section. */
size_t d_align; /* Alignment in section. */
} Elf_Data;
@@ -136,7 +136,7 @@ typedef struct
uid_t ar_uid; /* User ID. */
gid_t ar_gid; /* Group ID. */
mode_t ar_mode; /* File mode. */
- loff_t ar_size; /* File size. */
+ off_t ar_size; /* File size. */
char *ar_rawname; /* Original name of archive member. */
} Elf_Arhdr;
@@ -177,13 +177,13 @@ extern Elf_Cmd elf_next (Elf *__elf);
extern int elf_end (Elf *__elf);
/* Update ELF descriptor and write file to disk. */
-extern loff_t elf_update (Elf *__elf, Elf_Cmd __cmd);
+extern off_t elf_update (Elf *__elf, Elf_Cmd __cmd);
/* Determine what kind of file is associated with ELF. */
extern Elf_Kind elf_kind (Elf *__elf) __attribute__ ((__pure__));
/* Get the base offset for an object file. */
-extern loff_t elf_getbase (Elf *__elf);
+extern off_t elf_getbase (Elf *__elf);
/* Retrieve file identification data. */
@@ -301,7 +301,7 @@ extern Elf_Data *elf_newdata (Elf_Scn *_
would be for TYPE. The resulting Elf_Data pointer is valid until
elf_end (ELF) is called. */
extern Elf_Data *elf_getdata_rawchunk (Elf *__elf,
- loff_t __offset, size_t __size,
+ off_t __offset, size_t __size,
Elf_Type __type);
@@ -313,7 +313,7 @@ extern char *elf_strptr (Elf *__elf, siz
extern Elf_Arhdr *elf_getarhdr (Elf *__elf);
/* Return offset in archive for current file ELF. */
-extern loff_t elf_getaroff (Elf *__elf);
+extern off_t elf_getaroff (Elf *__elf);
/* Select archive element at OFFSET. */
extern size_t elf_rand (Elf *__elf, size_t __offset);

View file

@ -1,12 +1,12 @@
--- src/Makefile.am.orig 2015-06-11 11:38:55 UTC
--- src/Makefile.am.orig 2016-12-28 09:32:00 UTC
+++ src/Makefile.am
@@ -72,11 +72,11 @@ CLEANFILES += make-debug-archive
@@ -40,11 +40,11 @@ CLEANFILES += make-debug-archive
if BUILD_STATIC
libasm = ../libasm/libasm.a
-libdw = ../libdw/libdw.a $(zip_LIBS) $(libelf) $(libebl) -ldl
+libdw = ../libdw/libdw.a $(zip_LIBS) $(libelf) $(libebl) $(libeu)
libelf = ../libelf/libelf.a
-libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl
+libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) $(libeu)
libelf = ../libelf/libelf.a -lz
else
libasm = ../libasm/libasm.so
-libdw = ../libdw/libdw.so
@ -14,15 +14,7 @@
libelf = ../libelf/libelf.so
endif
libebl = ../libebl/libebl.a
@@ -89,6 +89,7 @@ endif
# XXX While the file is not finished, don't warn about this
ldgeneric_no_Wunused = yes
ldgeneric_no_Wstack_usage = yes
+ldgeneric_no_Werror = yes
# Bad, bad stack usage...
readelf_no_Wstack_usage = yes
@@ -103,27 +104,27 @@ ranlib_no_Wstack_usage = yes
@@ -67,21 +67,21 @@ ranlib_no_Wstack_usage = yes
ar_no_Wstack_usage = yes
unstrip_no_Wstack_usage = yes
@ -32,21 +24,13 @@
+nm_LDADD = $(libdw) $(libebl) $(libelf) $(libeu) $(argp_LDADD) \
$(demanglelib)
size_LDADD = $(libelf) $(libeu) $(argp_LDADD)
-strip_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
-ld_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
+strip_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD)
+ld_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD)
if NATIVE_LD
-# -ldl is always needed for libebl.
+# is always needed for libebl.
ld_LDADD += libld_elf.a
endif
ld_LDFLAGS = -rdynamic
-strip_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD) -ldl
-elflint_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
+strip_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD)
+elflint_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD)
findtextrel_LDADD = $(libdw) $(libelf) $(argp_LDADD)
addr2line_LDADD = $(libdw) $(libelf) $(argp_LDADD) $(demanglelib)
-elfcmp_LDADD = $(libebl) $(libelf) $(argp_LDADD) -ldl
findtextrel_LDADD = $(libdw) $(libelf) $(libeu) $(argp_LDADD)
addr2line_LDADD = $(libdw) $(libelf) $(libeu) $(argp_LDADD) $(demanglelib)
-elfcmp_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
-objdump_LDADD = $(libasm) $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
+elfcmp_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD)
+objdump_LDADD = $(libasm) $(libebl) $(libelf) $(libeu) $(argp_LDADD)
@ -57,6 +41,6 @@
-stack_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD) -ldl $(demanglelib)
+unstrip_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD)
+stack_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD) $(demanglelib)
elfcompress_LDADD = $(libebl) $(libelf) $(libdw) $(libeu) $(argp_LDADD)
ldlex.o: ldscript.c
ldlex_no_Werror = yes
installcheck-binPROGRAMS: $(bin_PROGRAMS)

View file

@ -0,0 +1,23 @@
--- src/elfcompress.c.orig 2016-12-28 01:32:01.000000000 -0800
+++ src/elfcompress.c 2017-01-18 16:21:03.680565000 -0800
@@ -135,7 +135,10 @@
if (type == T_UNSET)
type = T_COMPRESS_ZLIB;
if (patterns == NULL)
- add_pattern (".?(z)debug*");
+ {
+ add_pattern (".debug*");
+ add_pattern (".zdebug*");
+ }
break;
case ARGP_KEY_NO_ARGS:
@@ -162,7 +165,7 @@
struct section_pattern *pattern = patterns;
while (pattern != NULL)
{
- if (fnmatch (pattern->pattern, name, FNM_EXTMATCH) == 0)
+ if (fnmatch (pattern->pattern, name, 0) == 0)
return true;
pattern = pattern->next;
}

View file

@ -1,23 +0,0 @@
--- src/ldgeneric.c.orig 2014-02-05 00:21:44 UTC
+++ src/ldgeneric.c
@@ -2631,9 +2631,9 @@ ld_generic_generate_sections (struct ld_
/* Callback function registered with on_exit to make sure the temporary
files gets removed if something goes wrong. */
static void
-remove_tempfile (int status, void *arg)
+remove_tempfile (void)
{
- if (status != 0 && ld_state.tempfname != NULL)
+ if (ld_state.tempfname != NULL)
unlink (ld_state.tempfname);
}
@@ -2680,7 +2680,7 @@ ld_generic_open_outfile (struct ld_state
/* Make sure we remove the temporary file in case something goes
wrong. */
- on_exit (remove_tempfile, NULL);
+ atexit (remove_tempfile);
/* Create the ELF file data for the output file. */
Elf *elf = ld_state.outelf = elf_begin (fd,

View file

@ -1,11 +0,0 @@
--- src/ldlex.c.orig 2014-08-26 08:58:02 UTC
+++ src/ldlex.c
@@ -1629,7 +1629,7 @@ YY_RULE_SETUP
#line 149 "/home/mark/src/elfutils/src/ldlex.l"
{ int cnt = 1 ;
ldlval.num = 0;
- while (cnt < ldleng - 1)
+ while (cnt < (int)ldleng - 1)
ldlval.num |= attrib_convert (ldtext[cnt++]);
return kMODE; }
YY_BREAK

View file

@ -1,11 +0,0 @@
--- src/ldlex.l.orig 2014-02-05 00:21:44 UTC
+++ src/ldlex.l
@@ -148,7 +148,7 @@ VERSION { return kVERSION; }
"["([RWX]){0,3}"]" { int cnt = 1 ;
ldlval.num = 0;
- while (cnt < yyleng - 1)
+ while (cnt < (int)yyleng - 1)
ldlval.num |= attrib_convert (yytext[cnt++]);
return kMODE; }

View file

@ -1,8 +1,8 @@
--- src/readelf.c.orig 2015-06-19 11:17:42 UTC
--- src/readelf.c.orig 2016-12-28 09:32:01 UTC
+++ src/readelf.c
@@ -7911,6 +7911,7 @@ print_debug_exception_table (Dwfl_Module
break;
@@ -8037,6 +8037,7 @@ print_debug_exception_table (Dwfl_Module
default:
dsize = 0;
error (1, 0, gettext ("invalid TType encoding"));
+ abort();
}

View file

@ -1,37 +1,37 @@
--- tests/Makefile.am.orig 2015-06-11 11:38:55 UTC
--- tests/Makefile.am.orig 2016-12-25 13:36:55 UTC
+++ tests/Makefile.am
@@ -346,7 +346,7 @@ libasm = -lasm
@@ -382,7 +382,7 @@ libasm = -lasm
libebl = -lebl
else !STANDALONE
if BUILD_STATIC
-libdw = ../libdw/libdw.a $(zip_LIBS) $(libelf) $(libebl) -ldl
+libdw = ../libdw/libdw.a $(zip_LIBS) $(libelf) $(libebl)
libelf = ../libelf/libelf.a
-libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl
+libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl)
libelf = ../libelf/libelf.a -lz
libasm = ../libasm/libasm.a
else
@@ -389,27 +389,27 @@ funcretval_LDADD = $(libdw) $(argp_LDADD
@@ -425,27 +425,27 @@ funcretval_LDADD = $(libdw) $(argp_LDADD
allregs_LDADD = $(libdw) $(argp_LDADD)
find_prologues_LDADD = $(libdw) $(argp_LDADD)
#show_ciefde_LDADD = ../libdwarf/libdwarf.so $(libelf)
-asm_tst1_LDADD = $(libasm) $(libebl) $(libelf) -ldl
-asm_tst2_LDADD = $(libasm) $(libebl) $(libelf) -ldl
-asm_tst3_LDADD = $(libasm) $(libebl) $(libelf) -ldl
-asm_tst4_LDADD = $(libasm) $(libebl) $(libelf) -ldl
-asm_tst5_LDADD = $(libasm) $(libebl) $(libelf) -ldl
-asm_tst6_LDADD = $(libasm) $(libebl) $(libelf) -ldl
-asm_tst7_LDADD = $(libasm) $(libebl) $(libelf) -ldl
-asm_tst8_LDADD = $(libasm) $(libebl) $(libelf) -ldl
-asm_tst9_LDADD = $(libasm) $(libebl) $(libelf) -ldl
-asm_tst1_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
-asm_tst2_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
-asm_tst3_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
-asm_tst4_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
-asm_tst5_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
-asm_tst6_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
-asm_tst7_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
-asm_tst8_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
-asm_tst9_LDADD = $(libasm) $(libebl) $(libelf) $(libdw) -ldl
-dwflmodtest_LDADD = $(libdw) $(libebl) $(libelf) $(argp_LDADD) -ldl
+asm_tst1_LDADD = $(libasm) $(libebl) $(libelf)
+asm_tst2_LDADD = $(libasm) $(libebl) $(libelf)
+asm_tst3_LDADD = $(libasm) $(libebl) $(libelf)
+asm_tst4_LDADD = $(libasm) $(libebl) $(libelf)
+asm_tst5_LDADD = $(libasm) $(libebl) $(libelf)
+asm_tst6_LDADD = $(libasm) $(libebl) $(libelf)
+asm_tst7_LDADD = $(libasm) $(libebl) $(libelf)
+asm_tst8_LDADD = $(libasm) $(libebl) $(libelf)
+asm_tst9_LDADD = $(libasm) $(libebl) $(libelf)
+asm_tst1_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
+asm_tst2_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
+asm_tst3_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
+asm_tst4_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
+asm_tst5_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
+asm_tst6_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
+asm_tst7_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
+asm_tst8_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
+asm_tst9_LDADD = $(libasm) $(libebl) $(libelf) $(libdw)
+dwflmodtest_LDADD = $(libdw) $(libebl) $(libelf) $(argp_LDADD)
rdwrmmap_LDADD = $(libelf)
-dwfl_bug_addr_overflow_LDADD = $(libdw) $(libebl) $(libelf) -ldl
@ -52,4 +52,4 @@
+addrcfi_LDADD = $(libdw) $(libebl) $(libelf) $(argp_LDADD)
test_flag_nobits_LDADD = $(libelf)
rerequest_tag_LDADD = $(libdw)
alldts_LDADD = $(libebl) $(libelf)
alldts_LDADD = $(libdw) $(libelf)

View file

@ -1,9 +1,9 @@
bin/eu-addr2line
bin/eu-ar
bin/eu-elfcmp
bin/eu-elfcompress
bin/eu-elflint
bin/eu-findtextrel
bin/eu-ld
bin/eu-make-debug-archive
bin/eu-nm
bin/eu-objdump
@ -26,40 +26,40 @@ include/elfutils/version.h
include/gelf.h
include/libelf.h
include/nlist.h
lib/elfutils/libebl_aarch64-0.163.so
lib/elfutils/libebl_aarch64-0.168.so
lib/elfutils/libebl_aarch64.so
lib/elfutils/libebl_alpha-0.163.so
lib/elfutils/libebl_alpha-0.168.so
lib/elfutils/libebl_alpha.so
lib/elfutils/libebl_arm-0.163.so
lib/elfutils/libebl_arm-0.168.so
lib/elfutils/libebl_arm.so
lib/elfutils/libebl_i386-0.163.so
lib/elfutils/libebl_i386-0.168.so
lib/elfutils/libebl_i386.so
lib/elfutils/libebl_ia64-0.163.so
lib/elfutils/libebl_ia64-0.168.so
lib/elfutils/libebl_ia64.so
lib/elfutils/libebl_ppc-0.163.so
lib/elfutils/libebl_ppc-0.168.so
lib/elfutils/libebl_ppc.so
lib/elfutils/libebl_ppc64-0.163.so
lib/elfutils/libebl_ppc64-0.168.so
lib/elfutils/libebl_ppc64.so
lib/elfutils/libebl_s390-0.163.so
lib/elfutils/libebl_s390-0.168.so
lib/elfutils/libebl_s390.so
lib/elfutils/libebl_sh-0.163.so
lib/elfutils/libebl_sh-0.168.so
lib/elfutils/libebl_sh.so
lib/elfutils/libebl_sparc-0.163.so
lib/elfutils/libebl_sparc-0.168.so
lib/elfutils/libebl_sparc.so
lib/elfutils/libebl_tilegx-0.163.so
lib/elfutils/libebl_tilegx-0.168.so
lib/elfutils/libebl_tilegx.so
lib/elfutils/libebl_x86_64-0.163.so
lib/elfutils/libebl_x86_64-0.168.so
lib/elfutils/libebl_x86_64.so
lib/libasm-0.163.so
lib/libasm-0.168.so
lib/libasm.a
lib/libasm.so
lib/libasm.so.1
lib/libdw-0.163.so
lib/libdw-0.168.so
lib/libdw.a
lib/libdw.so
lib/libdw.so.1
lib/libebl.a
lib/libelf-0.163.so
lib/libelf-0.168.so
lib/libelf.a
lib/libelf.so
lib/libelf.so.1