Upgrade to version 1.9.13, now maintained on sourceforge.

PR:		ports/38120
Submitted by:	Ying-Chieh Liao <ijliao@freebsd.org>
This commit is contained in:
Joerg Wunsch 2002-08-28 20:23:29 +00:00
parent 533b231eda
commit dd0a47997f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=65190
5 changed files with 107 additions and 82 deletions

View file

@ -6,18 +6,14 @@
#
PORTNAME= latex2rtf
PORTVERSION= 1.8aa
PORTVERSION= 1.9.13
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= support/latex2rtf
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= ${PORTNAME} support/latex2rtf
MAINTAINER= joerg@FreeBSD.org
IGNOREFILES= ${DISTNAME}${EXTRACT_SUFX}
MAN1= latex2rtf.1
do-configure:
rm -f ${WRKSRC}/*.o
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (latex2rtf-1.8aa.tar.gz) = IGNORE
MD5 (latex2rtf-1.9.13.tar.gz) = dedff9b8b17e222384b26c4bb94996d0

View file

@ -1,67 +1,55 @@
--- Makefile.orig Thu Nov 12 19:22:58 1998
+++ Makefile Tue Dec 14 13:12:15 1999
@@ -73,8 +73,6 @@
# The Debian-specific parts of this Makefile are created by
# Erick Branderhorst. Parts are written by Ian Jackson and Ian Murdock.
# TODO: add target "changes".
-CC=gcc # C-Compiler
-CFLAGS=-g $(XCFLAGS) # Use -O here if you want it optimized
COPY=cp
INSTALL=install
DIR_MODE=755
@@ -83,13 +81,13 @@
DIR_USER=root
BIN_USER=root
DAT_USER=root
-DIR_GROUP=root
-BIN_GROUP=root
-DAT_GROUP=root
+DIR_GROUP=wheel
+BIN_GROUP=wheel
+DAT_GROUP=wheel
# If you have the program install, use the following definitions
-INST_DIR=$(INSTALL) -g $(DIR_GROUP) -o $(DIR_USER) -d -m $(BIN_MODE)
-INST_BIN=$(INSTALL) -g $(BIN_GROUP) -o $(BIN_USER) -m $(DIR_MODE)
-INST_DAT=$(INSTALL) -g $(DAT_GROUP) -o $(DAT_USER) -m $(DAT_MODE)
+INST_DIR=$(INSTALL) -c -g $(DIR_GROUP) -o $(DIR_USER) -d -m $(BIN_MODE)
+INST_BIN=$(INSTALL) -c -g $(BIN_GROUP) -o $(BIN_USER) -m $(DIR_MODE)
+INST_DAT=$(INSTALL) -c -g $(DAT_GROUP) -o $(DAT_USER) -m $(DAT_MODE)
CHOWN_DIR=true
CHOWN_BIN=true
CHOWN_DAT=true
@@ -115,8 +113,9 @@
#
# Where support files are searched for by the executable
# prefix defaults to /usr/local, but may be set on the command line
-prefix=/usr/local
-LIBDIR=$(prefix)/lib/latex2rtf
+PREFIX?=/usr/local
+prefix=${PREFIX}
+LIBDIR=$(prefix)/share/latex2rtf
# You can give several Directories separated by ':' for the following
# install targets
#
@@ -160,12 +159,11 @@
# Nothing to change below this line
SOURCES=commands.c commands.h direct.c direct.h encode.c encode.h fonts.c \
fonts.h funct1.c funct1.h funct2.c funct2.h ignore.c ignore.h main.c \
- main.h stack.c stack.h version.h cfg.c cfg.h Makefile README README.DOS\
+ main.h stack.c stack.h version.h cfg.c cfg.h Makefile README \
Copyright mygetopt.c optind.c version debian.README \
debian.control debian.rules util.c util.h ChangeLog parser.c parser.h
SUPPORT=cfg/direct.cfg cfg/fonts.cfg cfg/ignore.cfg \
- cfg/english.cfg cfg/german.cfg cfg/spanish.cfg \
- l2r.bat l2r.exe
+ cfg/english.cfg cfg/german.cfg cfg/spanish.cfg
MANUALS=latex2rtf.1
MSDOS=l2r.bat l2r.exe
DOCS=doc/latex2rtf.info doc/l2r.html doc/l2r.pdf doc/l2r.txt\
@@ -304,7 +302,7 @@
$(CHMOD_BIN) $(BININSTALL)/latex2rtf
$(INST_DAT) $(MANUALS) $(MANINSTALL)
--- Makefile.orig Thu May 16 02:33:02 2002
+++ Makefile Thu May 16 02:38:50 2002
@@ -1,10 +1,9 @@
# $Id: Makefile,v 1.50 2002/04/03 15:44:18 prahl Exp $
-install: complex_install
+install: complex_install install_and_delete_old_cfg
-CC=gcc
MKDIR=mkdir -p
LIBS=
.PHONY: install complex_install simple_install simple_cfg_install \
install.man complex_install install_and_delete_old_cfg dist \
-CFLAGS:=-DUNIX
+CFLAGS+=-DUNIX
#CFLAGS:=-DMSDOS
#CFLAGS:=-DMACINTOSH
@@ -12,10 +11,8 @@
#CFLAGS:=$(CFLAGS) -DHAS_NO_GETOPT
#Comment out if you don't want compiler warnings
-CFLAGS:=$(CFLAGS) -g -Wall -ansi -pedantic
#Base directory
-PREFIX=/usr/local
# Location of binary, man, info, and support files
BIN_INSTALL=$(PREFIX)/bin
@@ -123,13 +120,13 @@
$(MKDIR) $(BIN_INSTALL)
$(MKDIR) $(MAN_INSTALL)
$(MKDIR) $(CFG_INSTALL)
- cp latex2rtf $(BIN_INSTALL)
- cp scripts/latex2png $(BIN_INSTALL)
- cp doc/latex2rtf.1 $(MAN_INSTALL)
- cp $(CFGS) $(CFG_INSTALL)
- cp doc/latex2rtf.html $(SUPPORT_INSTALL)
- cp doc/latex2rtf.pdf $(SUPPORT_INSTALL)
- cp doc/latex2rtf.txt $(SUPPORT_INSTALL)
+ ${BSD_INSTALL_PROGRAM} latex2rtf $(BIN_INSTALL)
+ ${BSD_INSTALL_SCRIPT} scripts/latex2png $(BIN_INSTALL)
+ ${BSD_INSTALL_MAN} doc/latex2rtf.1 $(MAN_INSTALL)
+ ${BSD_INSTALL_DATA} $(CFGS) $(CFG_INSTALL)
+ ${BSD_INSTALL_DATA} doc/latex2rtf.html $(SUPPORT_INSTALL)
+ ${BSD_INSTALL_DATA} doc/latex2rtf.pdf $(SUPPORT_INSTALL)
+ ${BSD_INSTALL_DATA} doc/latex2rtf.txt $(SUPPORT_INSTALL)
@echo "******************************************************************"
@echo "*** latex2rtf successfully installed"
@echo "***"
@@ -145,7 +142,7 @@
install-info: doc/latex2rtf.info
$(MKDIR) $(INFO_INSTALL)
- cp doc/latex2rtf.info $(BIN_INSTALL)
+ ${BSD_INSTALL_DATA} doc/latex2rtf.info $(BIN_INSTALL)
install-info --info-dir=$(INFO_INSTALL) doc/latex2rtf.info
realclean: checkdir clean

View file

@ -5,5 +5,6 @@ Granzer in a one-semester course in our department. It was later
updated in another one-semester course by Friedrich Polzer and Gerhard
Trisko. Ralf Schlatterbeck <ralf@zoo.priv.at> maintained and extended
it until 1998. The current maintainer is Georg Lehner
<glehner@unanleon.edu.ni>. For the Copyright of the Program see the
file Copyright.
<glehner@unanleon.edu.ni>.
WWW: http://latex2rtf.sourceforge.net/

View file

@ -1,8 +1,48 @@
bin/latex2png
bin/latex2rtf
share/latex2rtf/direct.cfg
share/latex2rtf/english.cfg
share/latex2rtf/fonts.cfg
share/latex2rtf/german.cfg
share/latex2rtf/ignore.cfg
share/latex2rtf/spanish.cfg
share/latex2rtf/cfg/afrikaans.cfg
share/latex2rtf/cfg/bahasa.cfg
share/latex2rtf/cfg/basque.cfg
share/latex2rtf/cfg/brazil.cfg
share/latex2rtf/cfg/breton.cfg
share/latex2rtf/cfg/catalan.cfg
share/latex2rtf/cfg/croatian.cfg
share/latex2rtf/cfg/czech.cfg
share/latex2rtf/cfg/danish.cfg
share/latex2rtf/cfg/direct.cfg
share/latex2rtf/cfg/dutch.cfg
share/latex2rtf/cfg/english.cfg
share/latex2rtf/cfg/esperanto.cfg
share/latex2rtf/cfg/estonian.cfg
share/latex2rtf/cfg/finnish.cfg
share/latex2rtf/cfg/fonts.cfg
share/latex2rtf/cfg/french.cfg
share/latex2rtf/cfg/galician.cfg
share/latex2rtf/cfg/german.cfg
share/latex2rtf/cfg/icelandic.cfg
share/latex2rtf/cfg/ignore.cfg
share/latex2rtf/cfg/irish.cfg
share/latex2rtf/cfg/italian.cfg
share/latex2rtf/cfg/latin.cfg
share/latex2rtf/cfg/lsorbian.cfg
share/latex2rtf/cfg/magyar.cfg
share/latex2rtf/cfg/norsk.cfg
share/latex2rtf/cfg/nynorsk.cfg
share/latex2rtf/cfg/polish.cfg
share/latex2rtf/cfg/portuges.cfg
share/latex2rtf/cfg/romanian.cfg
share/latex2rtf/cfg/samin.cfg
share/latex2rtf/cfg/scottish.cfg
share/latex2rtf/cfg/serbian.cfg
share/latex2rtf/cfg/slovak.cfg
share/latex2rtf/cfg/slovene.cfg
share/latex2rtf/cfg/spanish.cfg
share/latex2rtf/cfg/swedish.cfg
share/latex2rtf/cfg/turkish.cfg
share/latex2rtf/cfg/usorbian.cfg
share/latex2rtf/cfg/welsh.cfg
share/latex2rtf/latex2rtf.html
share/latex2rtf/latex2rtf.pdf
share/latex2rtf/latex2rtf.txt
@dirrm share/latex2rtf/cfg
@dirrm share/latex2rtf