Update to upstream version 2.2.0

Detailed log:
- New option to prefer embedded image metadata over video content (command line
  argument: -m)
- Fixed 'Resource temporarily unavailable' errors when using ffmpeg < 3.0
- Restored deinterlace functionality using the libavfilter library (additional
  ffmpeg dependency)
- Additional video mime types added to the thumbnailer file
- Take rotation metadata into account when generating thumbnails

PR:		216648
Submitted by:	stl@ossuary.net
Approved by:	clutton@zoho.com (maintainer)
MFH:		2017Q1
This commit is contained in:
Thomas Zander 2017-03-04 15:06:48 +00:00
parent 45e1506eb2
commit dd44e1cc8e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=435411
4 changed files with 5 additions and 21 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ffmpegthumbnailer
PORTVERSION= 2.1.1
PORTREVISION= 1
PORTVERSION= 2.2.0
CATEGORIES= multimedia graphics
MAINTAINER= clutton@zoho.com

View file

@ -1,2 +1,3 @@
SHA256 (dirkvdb-ffmpegthumbnailer-2.1.1_GH0.tar.gz) = e43d8aae7e80771dc700b3d960a0717d5d28156684a8ddc485572cbcbc4365e9
SIZE (dirkvdb-ffmpegthumbnailer-2.1.1_GH0.tar.gz) = 1531723
TIMESTAMP = 1485821757
SHA256 (dirkvdb-ffmpegthumbnailer-2.2.0_GH0.tar.gz) = 8bc74755aa960531acdea8fa19ad7e1b7c806c28a068306a8c7150d278241a8f
SIZE (dirkvdb-ffmpegthumbnailer-2.2.0_GH0.tar.gz) = 1284692

View file

@ -1,16 +0,0 @@
libdl only exists on Linux. Use CMAKE_DL_LIBS instead.
Submitted upstream: https://github.com/dirkvdb/ffmpegthumbnailer/pull/132
--- CMakeLists.txt.orig 2016-04-16 16:57:31 UTC
+++ CMakeLists.txt
@@ -96,9 +96,8 @@ FIND_LIBRARY(SWSCALE_LIBRARY
IF (ENABLE_GIO)
FIND_PATH(DL_INCLUDES dlfcn.h)
- FIND_LIBRARY(DL_LIBRARY dl)
LIST(APPEND FFMPEGTHUMBNAILER_INCLUDE_DIRS ${DL_INCLUDES})
- LIST(APPEND FFMPEGTHUMBNAILER_LIBRARIES ${DL_LIBRARY})
+ LIST(APPEND FFMPEGTHUMBNAILER_LIBRARIES ${CMAKE_DL_LIBS})
ENDIF ()
LIST(APPEND FFMPEGTHUMBNAILER_INCLUDE_DIRS ${AVFORMAT_INCLUDE_DIR} ${AVCODEC_INCLUDE_DIR} ${AVUTIL_INCLUDE_DIR} ${SWSCALE_INCLUDE_DIR})

View file

@ -8,7 +8,7 @@ include/libffmpegthumbnailer/videothumbnailer.h
include/libffmpegthumbnailer/videothumbnailerc.h
lib/libffmpegthumbnailer.so
lib/libffmpegthumbnailer.so.4
lib/libffmpegthumbnailer.so.4.11.0
lib/libffmpegthumbnailer.so.4.13.1
libdata/pkgconfig/libffmpegthumbnailer.pc
man/man1/ffmpegthumbnailer.1.gz
%%THUMBNAILER%%share/thumbnailers/ffmpegthumbnailer.thumbnailer