add fwlogwatch
A packet filter and firewall log analyzer
This commit is contained in:
parent
ef28dd30a2
commit
dd56201cc7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=50248
8 changed files with 110 additions and 0 deletions
|
@ -46,6 +46,7 @@
|
|||
SUBDIR += fressh
|
||||
SUBDIR += fuzz
|
||||
SUBDIR += fwbuilder
|
||||
SUBDIR += fwlogwatch
|
||||
SUBDIR += fwtk
|
||||
SUBDIR += gag
|
||||
SUBDIR += geheimnis
|
||||
|
|
33
security/fwlogwatch/Makefile
Normal file
33
security/fwlogwatch/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# ex:ts=8
|
||||
# New ports collection makefile for: fwlogwatch
|
||||
# Date created: Nov 20, 2001
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= fwlogwatch
|
||||
PORTVERSION= 0.5.1
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.kyb.uni-stuttgart.de/boris/sw/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= autob5:${PORTSDIR}/chinese/autoconvert
|
||||
LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext
|
||||
|
||||
INSTALL_TARGET= install install-i18n
|
||||
MANCOMPRESSES= no
|
||||
MAN8= fwlogwatch.8
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g ; \
|
||||
s,/etc,${PREFIX}/etc,g ; \
|
||||
s,/usr/local,${PREFIX},g ; \
|
||||
s,/usr/share,${PREFIX}/share,g" ${WRKSRC}/Makefile
|
||||
@${PERL} -pi -e "s,/etc,${PREFIX}/etc,g ; \
|
||||
s,/usr/share,${PREFIX}/share,g ; \
|
||||
s,/usr/local,${PREFIX},g" ${WRKSRC}/main.h
|
||||
@${PERL} -pi -e "s,/etc,${PREFIX}/etc,g" ${WRKSRC}/${MAN8}
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/fwlogwatch/distinfo
Normal file
1
security/fwlogwatch/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (fwlogwatch-0.5.1.tar.gz) = e718416ccd80bb1a2f472601d38b636f
|
39
security/fwlogwatch/files/patch-Makefile
Normal file
39
security/fwlogwatch/files/patch-Makefile
Normal file
|
@ -0,0 +1,39 @@
|
|||
--- Makefile.orig Mon Nov 19 01:12:29 2001
|
||||
+++ Makefile Tue Nov 20 15:00:49 2001
|
||||
@@ -1,10 +1,10 @@
|
||||
# $Id: Makefile,v 1.51 2001/11/18 17:12:29 bw Exp $
|
||||
|
||||
# Linux
|
||||
-CC = gcc
|
||||
-CFLAGS = -pipe -O2 -Wall #-pedantic #-g #-p
|
||||
-LDFLAGS = #-g #-static -p
|
||||
-LIBS = -lcrypt -lz #-lc_p
|
||||
+#CC = gcc
|
||||
+#CFLAGS = -pipe -O2 -Wall #-pedantic #-g #-p
|
||||
+#LDFLAGS = #-g #-static -p
|
||||
+#LIBS = -lcrypt -lz #-lc_p
|
||||
|
||||
# Solaris
|
||||
#LIBS = -lnsl -lsocket -lz -lcrypt
|
||||
@@ -23,8 +23,8 @@
|
||||
|
||||
# FreeBSD
|
||||
#CC = gcc
|
||||
-#CFLAGS = -pipe -O2 -Wall -I/usr/local/include
|
||||
-#LIBS = -L/usr/local/lib -lintl -lcrypt -lz
|
||||
+CFLAGS += -I%%LOCALBASE%%/include
|
||||
+LIBS = -L%%LOCALBASE%%/lib -lintl -lcrypt -lz
|
||||
|
||||
# You might want to add -DSHORT_NAMES to CFLAGS if you only intend to
|
||||
# analyze log formats with short list/chain/branch/interface names like
|
||||
@@ -82,8 +82,8 @@
|
||||
install-i18n:
|
||||
cd po; make
|
||||
$(INSTALL_DATA) po/de.mo /usr/share/locale/de/LC_MESSAGES/fwlogwatch.mo
|
||||
- $(INSTALL_DATA) po/pt_BR.mo /usr/share/locale/pt/LC_MESSAGES/fwlogwatch.mo
|
||||
- $(INSTALL_DATA) po/zh.mo /usr/share/locale/zh/LC_MESSAGES/fwlogwatch.mo
|
||||
+ $(INSTALL_DATA) po/pt_BR.mo /usr/share/locale/pt_BR/LC_MESSAGES/fwlogwatch.mo
|
||||
+ $(INSTALL_DATA) po/zh.mo /usr/share/locale/zh_TW/LC_MESSAGES/fwlogwatch.mo
|
||||
|
||||
uninstall:
|
||||
@rm -f /usr/local/sbin/fwlogwatch \
|
10
security/fwlogwatch/files/patch-po::Makefile
Normal file
10
security/fwlogwatch/files/patch-po::Makefile
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- po/Makefile.orig Tue Nov 20 14:51:50 2001
|
||||
+++ po/Makefile Tue Nov 20 14:53:23 2001
|
||||
@@ -3,6 +3,7 @@
|
||||
all:
|
||||
msgfmt -v -o de.mo de.po
|
||||
msgfmt -v -o pt_BR.mo pt_BR.po
|
||||
+ mv zh.po tmp ; cat tmp | autob5 > zh.po
|
||||
msgfmt -v -o zh.mo zh.po
|
||||
|
||||
strings:
|
1
security/fwlogwatch/pkg-comment
Normal file
1
security/fwlogwatch/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A packet filter and firewall log analyzer
|
19
security/fwlogwatch/pkg-descr
Normal file
19
security/fwlogwatch/pkg-descr
Normal file
|
@ -0,0 +1,19 @@
|
|||
fwlogwatch is a packet filter and firewall log analyzer
|
||||
|
||||
General features:
|
||||
- Can detect and process log entries in the following formats:
|
||||
- Linux ipchains, Linux netfilter/iptables, Solaris/BSD/Irix/HP-UX
|
||||
ipfilter, Cisco IOS and Cisco PIX.
|
||||
- Entries can be parsed in combined log files, the parsers to be used
|
||||
can be selected.
|
||||
- Gzip-compressed logs are supported.
|
||||
- Can separate recent from old entries and detects timewarps in log files.
|
||||
- Can recognize 'last message repeated' entries concerning the firewall.
|
||||
- Integrated resolver for protocols, services and host names.
|
||||
- Can do lookups in the whois database.
|
||||
- Own DNS and whois information cache for faster lookups.
|
||||
- Ports and hosts can be selected or excluded as needed.
|
||||
- Support for internationalization (available in english, german,
|
||||
portuguese and chinese).
|
||||
|
||||
WWW: http://cert.uni-stuttgart.de/projects/fwlogwatch/
|
6
security/fwlogwatch/pkg-plist
Normal file
6
security/fwlogwatch/pkg-plist
Normal file
|
@ -0,0 +1,6 @@
|
|||
sbin/fwlogwatch
|
||||
sbin/fwlw_notify
|
||||
sbin/fwlw_respond
|
||||
share/locale/de/LC_MESSAGES/fwlogwatch.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/fwlogwatch.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/fwlogwatch.mo
|
Loading…
Reference in a new issue