science/py-pysal: Update to 2.4.0
Changes: https://github.com/pysal/pysal/releases
This commit is contained in:
parent
5f187c0bb1
commit
dd6cd778b4
4 changed files with 23 additions and 30 deletions
|
@ -1,7 +1,7 @@
|
|||
# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
||||
|
||||
PORTNAME= pysal
|
||||
PORTVERSION= 2.3.0
|
||||
PORTVERSION= 2.4.0
|
||||
CATEGORIES= science python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -12,24 +12,25 @@ COMMENT= Cross-platform library of spatial analysis functions
|
|||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}access>=1.1.1:science/py-access@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}esda>=2.3.1:science/py-esda@${PY_FLAVOR} \
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}access>=1.1.3:science/py-access@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}esda>=2.3.6:science/py-esda@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}giddy>=2.3.3:graphics/py-giddy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}inequality>=1.0.0:science/py-inequality@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}libpysal>=4.3.0:science/py-libpysal@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}mapclassify>=2.3.0:graphics/py-mapclassify@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}mgwr>=2.1.1:graphics/py-mgwr@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}libpysal>=4.4.0:science/py-libpysal@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}mapclassify>=2.4.2:graphics/py-mapclassify@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}mgwr>=2.1.2:graphics/py-mgwr@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pointpats>=2.2.0:graphics/py-pointpats@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}segregation>=1.3.0:science/py-segregation@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spaghetti>=1.5.0:science/py-spaghetti@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spglm>=1.0.7:math/py-spglm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spint>=1.0.6:math/py-spint@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}segregation>=1.5.0:science/py-segregation@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spaghetti>=1.5.6:science/py-spaghetti@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spglm>=1.0.8:math/py-spglm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spint>=1.0.7:math/py-spint@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}splot>=1.1.3:math/py-splot@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spreg>=1.1.1:math/py-spreg@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spopt>=0.1.1:math/py-spopt@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spreg>=1.2.2:math/py-spreg@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}spvcm>=0.3.0:math/py-spvcm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}tobler>=0.3.1:science/py-tobler@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}urllib3>=0,1:net/py-urllib3@${PY_FLAVOR}
|
||||
${PYTHON_PKGNAMEPREFIX}tobler>=0.6.0:science/py-tobler@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}urllib3>=1.26,1:net/py-urllib3@${PY_FLAVOR}
|
||||
|
||||
USES= python:3.7+
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1612101618
|
||||
SHA256 (pysal-2.3.0.tar.gz) = 6f15a1432ff6805edd53ba6a5444f9af4ba2acd8a78f8f678c8bc09ffb0debe1
|
||||
SIZE (pysal-2.3.0.tar.gz) = 108511
|
||||
TIMESTAMP = 1628103154
|
||||
SHA256 (pysal-2.4.0.tar.gz) = 8994c008a70b607a357d972421feaad88fab95bdf436c07625fe2b62b8b32135
|
||||
SIZE (pysal-2.4.0.tar.gz) = 20254
|
||||
|
|
|
@ -1,19 +1,11 @@
|
|||
--- requirements.txt.orig 2020-07-29 02:30:21 UTC
|
||||
--- requirements.txt.orig 2021-01-31 22:52:55 UTC
|
||||
+++ requirements.txt
|
||||
@@ -10,12 +10,9 @@ mgwr>=2.1.1
|
||||
spglm>=1.0.7
|
||||
spint>=1.0.6
|
||||
spreg>=1.1.1
|
||||
-spvcm==0.3.0
|
||||
+spvcm>=0.3.0
|
||||
tobler>=0.3.1
|
||||
mapclassify>=2.3.0
|
||||
@@ -16,7 +16,4 @@ mapclassify>=2.4.2
|
||||
splot>=1.1.3
|
||||
-urllib3<1.25
|
||||
spopt>=0.1.1
|
||||
urllib3>=1.26
|
||||
-python-dateutil<=2.8.0
|
||||
-pytest
|
||||
-pytest-cov
|
||||
-coverage
|
||||
\ No newline at end of file
|
||||
+urllib3
|
||||
+python-dateutil
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- setup.py.orig 2020-02-01 23:18:07 UTC
|
||||
--- setup.py.orig 2021-01-31 21:39:53 UTC
|
||||
+++ setup.py
|
||||
@@ -54,7 +54,7 @@ def setup_package():
|
||||
@@ -65,7 +65,7 @@ def setup_package():
|
||||
download_url='https://pypi.python.org/pypi/pysal',
|
||||
license='BSD',
|
||||
packages=find_packages(),
|
||||
|
|
Loading…
Reference in a new issue