- Add pipelight, which works with wine to provide windows plugins to browsers
This commit is contained in:
parent
b2c93db5af
commit
dd85d47fd2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=361537
7 changed files with 146 additions and 0 deletions
|
@ -107,6 +107,7 @@
|
|||
SUBDIR += pcemu
|
||||
SUBDIR += pcsxr
|
||||
SUBDIR += pearpc
|
||||
SUBDIR += pipelight
|
||||
SUBDIR += psim-freebsd
|
||||
SUBDIR += q4wine
|
||||
SUBDIR += qemu
|
||||
|
|
51
emulators/pipelight/Makefile
Normal file
51
emulators/pipelight/Makefile
Normal file
|
@ -0,0 +1,51 @@
|
|||
# Created by: Kris Moore <kmoore@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pipelight
|
||||
DISTVERSION= 0.2.7.1
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= https://bitbucket.org/mmueller2012/pipelight/get/
|
||||
DISTNAME= v${DISTVERSION}
|
||||
|
||||
MAINTAINER= kmoore@FreeBSD.org
|
||||
COMMENT= Wrapper for using windows plugins in web browsers
|
||||
|
||||
LICENSE= LGPL21
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/gpg2:${PORTSDIR}/security/gnupg
|
||||
LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
|
||||
RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash \
|
||||
${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget \
|
||||
${LOCALBASE}/bin/zenity:${PORTSDIR}/x11/zenity \
|
||||
${LOCALBASE}/bin/cabextract:${PORTSDIR}/archivers/cabextract \
|
||||
${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/wine-devel \
|
||||
${LOCALBASE}/bin/flock:${PORTSDIR}/sysutils/flock \
|
||||
${LOCALBASE}/bin/gpg2:${PORTSDIR}/security/gnupg
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "i386"
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/wine-devel
|
||||
.elif ${ARCH} == "amd64"
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/bin/wine:${PORTSDIR}/emulators/i386-wine-devel
|
||||
.endif
|
||||
|
||||
WRKSRC= ${WRKDIR}/mmueller2012-pipelight-e2362eb15df6
|
||||
USE_LDCONFIG= yes
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--verbose --wine-path=${LOCALBASE}/bin/wine --win32-prebuilt \
|
||||
--win64-prebuilt --moz-plugin-path=${LOCALBASE}/lib/browser_plugins
|
||||
USES= compiler:c11 gmake
|
||||
MAKE_JOBS_UNSAFE=yes
|
||||
|
||||
MAN1= pipelight-plugin.1
|
||||
|
||||
pre-configure:
|
||||
${REINPLACE_CMD} "s|DISTVERSION|v${DISTVERSION}|g" ${WRKSRC}/src/windows/Makefile
|
||||
${REINPLACE_CMD} "s|DISTVERSION|v${DISTVERSION}|g" ${WRKSRC}/src/winecheck/Makefile
|
||||
${REINPLACE_CMD} "s|/share/man/man1|/man/man1|g" ${WRKSRC}/Makefile
|
||||
|
||||
.include <bsd.port.mk>
|
2
emulators/pipelight/distinfo
Normal file
2
emulators/pipelight/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (v0.2.7.1.tar.gz) = 48d0a245d53e045bc9e45dee0e124b3ec4dd9ebd30b3fbac2f787cbe0a46b9b2
|
||||
SIZE (v0.2.7.1.tar.gz) = 145063
|
18
emulators/pipelight/files/patch-src_windows_Makefile
Normal file
18
emulators/pipelight/files/patch-src_windows_Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- src/windows/Makefile.orig 2014-07-08 12:59:29.874833483 -0400
|
||||
+++ src/windows/Makefile 2014-07-08 12:59:41.826832843 -0400
|
||||
@@ -11,7 +11,7 @@
|
||||
all: pluginloader$(suffix).exe
|
||||
|
||||
ifeq ($(wildcard pluginloader$(suffix).exe),)
|
||||
-commit=$(shell git log --pretty=format:'%H' -n 1 || echo "prebuilt")
|
||||
+commit=DISTVERSION
|
||||
|
||||
../../pluginloader-$(commit).tar.gz:
|
||||
$(downloader) "../../pluginloader-$(commit).tar.gz" "http://repos.fds-team.de/pluginloader/$(commit)/pluginloader.tar.gz"
|
||||
@@ -67,4 +67,4 @@
|
||||
clean:
|
||||
rm -f *.exe *.exe.so *.o
|
||||
|
||||
-endif
|
||||
\ No newline at end of file
|
||||
+endif
|
18
emulators/pipelight/files/patch-src_winecheck_Makefile
Normal file
18
emulators/pipelight/files/patch-src_winecheck_Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- src/winecheck/Makefile.orig 2014-07-08 13:07:29.409800544 -0400
|
||||
+++ src/winecheck/Makefile 2014-07-08 13:07:37.139799764 -0400
|
||||
@@ -10,7 +10,7 @@
|
||||
all: winecheck$(suffix).exe
|
||||
|
||||
ifeq ($(wildcard winecheck$(suffix).exe),)
|
||||
-commit=$(shell git log --pretty=format:'%H' -n 1 || echo "prebuilt")
|
||||
+commit=DISTVERSION
|
||||
|
||||
../../pluginloader-$(commit).tar.gz:
|
||||
$(downloader) "../../pluginloader-$(commit).tar.gz" "http://repos.fds-team.de/pluginloader/$(commit)/pluginloader.tar.gz"
|
||||
@@ -52,4 +52,4 @@
|
||||
clean:
|
||||
rm -f *.exe *.exe.so *.o
|
||||
|
||||
-endif
|
||||
\ No newline at end of file
|
||||
+endif
|
7
emulators/pipelight/pkg-descr
Normal file
7
emulators/pipelight/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
Pipelight is a wrapper for using Windows plugins in FreeBSD browsers
|
||||
and therefore giving you the possibility to access services which
|
||||
are otherwise not available for FreeBSD users.
|
||||
|
||||
WWW: http://www.pipelight.net/
|
||||
|
||||
Kris Moore <kmoore@FreeBSD.org>
|
49
emulators/pipelight/pkg-plist
Normal file
49
emulators/pipelight/pkg-plist
Normal file
|
@ -0,0 +1,49 @@
|
|||
bin/pipelight-plugin
|
||||
lib/pipelight/libpipelight.so
|
||||
man/man1/pipelight-plugin.1.gz
|
||||
%%DATADIR%%/configs/pipelight-adobereader
|
||||
%%DATADIR%%/configs/pipelight-flash
|
||||
%%DATADIR%%/configs/pipelight-foxitpdf
|
||||
%%DATADIR%%/configs/pipelight-grandstream
|
||||
%%DATADIR%%/configs/pipelight-hikvision
|
||||
%%DATADIR%%/configs/pipelight-npactivex
|
||||
%%DATADIR%%/configs/pipelight-roblox
|
||||
%%DATADIR%%/configs/pipelight-shockwave
|
||||
%%DATADIR%%/configs/pipelight-silverlight4
|
||||
%%DATADIR%%/configs/pipelight-silverlight5.0
|
||||
%%DATADIR%%/configs/pipelight-silverlight5.1
|
||||
%%DATADIR%%/configs/pipelight-unity3d
|
||||
%%DATADIR%%/configs/pipelight-viewright-caiway
|
||||
%%DATADIR%%/configs/pipelight-vizzedrgr
|
||||
%%DATADIR%%/configs/pipelight-widevine
|
||||
%%DATADIR%%/configs/pipelight-x64-flash
|
||||
%%DATADIR%%/configs/pipelight-x64-unity3d
|
||||
%%DATADIR%%/install-dependency
|
||||
%%DATADIR%%/licenses/license-adobereader.txt
|
||||
%%DATADIR%%/licenses/license-flash.txt
|
||||
%%DATADIR%%/licenses/license-foxitpdf.txt
|
||||
%%DATADIR%%/licenses/license-grandstream.txt
|
||||
%%DATADIR%%/licenses/license-hikvision.txt
|
||||
%%DATADIR%%/licenses/license-mpg2splt.txt
|
||||
%%DATADIR%%/licenses/license-mspatcha.txt
|
||||
%%DATADIR%%/licenses/license-roblox.txt
|
||||
%%DATADIR%%/licenses/license-shockwave.txt
|
||||
%%DATADIR%%/licenses/license-silverlight4.txt
|
||||
%%DATADIR%%/licenses/license-silverlight5.0.txt
|
||||
%%DATADIR%%/licenses/license-silverlight5.1.txt
|
||||
%%DATADIR%%/licenses/license-unity3d.txt
|
||||
%%DATADIR%%/licenses/license-viewright-caiway.txt
|
||||
%%DATADIR%%/licenses/license-widevine.txt
|
||||
%%DATADIR%%/licenses/license-wininet.txt
|
||||
%%DATADIR%%/pluginloader.exe
|
||||
%%DATADIR%%/scripts/configure-flash
|
||||
%%DATADIR%%/scripts/configure-silverlight
|
||||
%%DATADIR%%/sig-install-dependency.gpg
|
||||
%%DATADIR%%/wine
|
||||
%%DATADIR%%/winecheck.exe
|
||||
@dirrmtry lib/browser_plugins
|
||||
@dirrmtry lib/pipelight
|
||||
@dirrmtry %%DATADIR%%/configs
|
||||
@dirrmtry %%DATADIR%%/licenses
|
||||
@dirrmtry %%DATADIR%%/scripts
|
||||
@dirrmtry %%DATADIR%%
|
Loading…
Reference in a new issue