Upgrade to 0.31_03.
PR: ports/25807 Submitted by: maintainer
This commit is contained in:
parent
223eb07ec7
commit
de4624ea5a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39861
6 changed files with 54 additions and 55 deletions
|
@ -6,10 +6,9 @@
|
|||
#
|
||||
|
||||
PORTNAME= libapreq
|
||||
PORTVERSION= 0.31
|
||||
PORTVERSION= 0.31_03
|
||||
CATEGORIES= www perl5 devel
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= Apache
|
||||
MASTER_SITES= http://www.cpan.org/authors/id/J/JI/JIMW/
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= frank@exit.com
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (libapreq-0.31.tar.gz) = a40cce50e85bf090088f4fdcea3be865
|
||||
MD5 (libapreq-0.31_03.tar.gz) = c23cb069e42643e505d4043f0eef4b9f
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- c/Makefile.PL.orig Sat May 1 14:44:28 1999
|
||||
+++ c/Makefile.PL Sun Apr 23 21:47:27 2000
|
||||
--- c/Makefile.PL.orig Wed Mar 29 22:22:28 2000
|
||||
+++ c/Makefile.PL Wed Mar 14 11:21:17 2001
|
||||
@@ -7,49 +7,23 @@
|
||||
win32_setup();
|
||||
}
|
||||
|
@ -11,7 +11,7 @@
|
|||
|
||||
use Cwd;
|
||||
my $pwd = fastcwd;
|
||||
my @objs = qw(apache_request.o apache_cookie.o multipart_buffer.o);
|
||||
my @objs = qw(apache_request.o apache_cookie.o apache_multipart_buffer.o);
|
||||
- $MY_LD_RUN_PATH = "$Config{installsitearch}/auto/libapreq:$pwd";
|
||||
|
||||
WriteMakefile(
|
||||
|
@ -53,50 +53,3 @@
|
|||
|
||||
sub MY::post_initialize {
|
||||
my $self = shift;
|
||||
--- Cookie/Makefile.PL.orig Sat May 1 14:44:28 1999
|
||||
+++ Cookie/Makefile.PL Sun Apr 23 21:43:43 2000
|
||||
@@ -15,9 +15,9 @@
|
||||
xsubpp("Cookie");
|
||||
}
|
||||
else {
|
||||
- require Apache::src;
|
||||
- my $src = Apache::src->new;
|
||||
use File::Path 'mkpath';
|
||||
+ my $inc1 = `apxs -q INCLUDEDIR`;
|
||||
+ my $inc2 = $inc1."/modules/perl";
|
||||
my $root = "../blib/arch/auto/libapreq";
|
||||
mkpath $root, 1, 0755 unless -d $root;
|
||||
|
||||
@@ -25,8 +25,7 @@
|
||||
system "touch $root/libapreq.a";
|
||||
WriteMakefile(
|
||||
@mm_args,
|
||||
- 'INC' => "-I../c ". $src->inc,
|
||||
- 'TYPEMAPS' => $src->typemaps,
|
||||
+ 'INC' => "-I../c -I$inc1 -I$inc2",
|
||||
'LIBS' => "-L$root -lapreq",
|
||||
);
|
||||
unlink "$root/libapreq.a";
|
||||
--- Request/Makefile.PL.orig Sat May 1 14:44:28 1999
|
||||
+++ Request/Makefile.PL Sun Apr 23 21:43:43 2000
|
||||
@@ -15,8 +15,8 @@
|
||||
xsubpp("Request");
|
||||
}
|
||||
else {
|
||||
- require Apache::src;
|
||||
- my $src = Apache::src->new;
|
||||
+ my $inc1 = `apxs -q INCLUDEDIR`;
|
||||
+ my $inc2 = $inc1 ."/modules/perl";
|
||||
use File::Path 'mkpath';
|
||||
my $root = "../blib/arch/auto/libapreq";
|
||||
mkpath $root, 1, 0755 unless -d $root;
|
||||
@@ -25,8 +25,7 @@
|
||||
system "touch $root/libapreq.a";
|
||||
WriteMakefile(
|
||||
@mm_args,
|
||||
- 'INC' => "-I../c ". $src->inc,
|
||||
- 'TYPEMAPS' => $src->typemaps,
|
||||
+ 'INC' => "-I../c -I$inc1 -I$inc2",
|
||||
'LIBS' => "-L$root -lapreq",
|
||||
);
|
||||
unlink "$root/libapreq.a";
|
||||
|
|
24
www/p5-libapreq/files/patch-ab
Normal file
24
www/p5-libapreq/files/patch-ab
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- Cookie/Makefile.PL.orig Sat May 1 14:44:28 1999
|
||||
+++ Cookie/Makefile.PL Sun Apr 23 21:43:43 2000
|
||||
@@ -15,9 +15,9 @@
|
||||
xsubpp("Cookie");
|
||||
}
|
||||
else {
|
||||
- require Apache::src;
|
||||
- my $src = Apache::src->new;
|
||||
use File::Path 'mkpath';
|
||||
+ my $inc1 = `apxs -q INCLUDEDIR`;
|
||||
+ my $inc2 = $inc1."/modules/perl";
|
||||
my $root = "../blib/arch/auto/libapreq";
|
||||
mkpath $root, 1, 0755 unless -d $root;
|
||||
|
||||
@@ -25,8 +25,7 @@
|
||||
system "touch $root/libapreq.a";
|
||||
WriteMakefile(
|
||||
@mm_args,
|
||||
- 'INC' => "-I../c ". $src->inc,
|
||||
- 'TYPEMAPS' => $src->typemaps,
|
||||
+ 'INC' => "-I../c -I$inc1 -I$inc2",
|
||||
'LIBS' => "-L$root -lapreq",
|
||||
);
|
||||
unlink "$root/libapreq.a";
|
23
www/p5-libapreq/files/patch-ac
Normal file
23
www/p5-libapreq/files/patch-ac
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- Request/Makefile.PL.orig Sat May 1 14:44:28 1999
|
||||
+++ Request/Makefile.PL Sun Apr 23 21:43:43 2000
|
||||
@@ -15,8 +15,8 @@
|
||||
xsubpp("Request");
|
||||
}
|
||||
else {
|
||||
- require Apache::src;
|
||||
- my $src = Apache::src->new;
|
||||
+ my $inc1 = `apxs -q INCLUDEDIR`;
|
||||
+ my $inc2 = $inc1 ."/modules/perl";
|
||||
use File::Path 'mkpath';
|
||||
my $root = "../blib/arch/auto/libapreq";
|
||||
mkpath $root, 1, 0755 unless -d $root;
|
||||
@@ -25,8 +25,7 @@
|
||||
system "touch $root/libapreq.a";
|
||||
WriteMakefile(
|
||||
@mm_args,
|
||||
- 'INC' => "-I../c ". $src->inc,
|
||||
- 'TYPEMAPS' => $src->typemaps,
|
||||
+ 'INC' => "-I../c -I$inc1 -I$inc2",
|
||||
'LIBS' => "-L$root -lapreq",
|
||||
);
|
||||
unlink "$root/libapreq.a";
|
|
@ -1,7 +1,7 @@
|
|||
lib/libapreq.so
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/libapreq/include/apache_request.h
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/libapreq/include/apache_cookie.h
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/libapreq/include/multipart_buffer.h
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/libapreq/include/apache_multipart_buffer.h
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/libapreq/libapreq.bs
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/libapreq/libapreq.so
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Request/Request.so
|
||||
|
|
Loading…
Reference in a new issue