net/nsscache: Update to 0.39
The big change here is a move to Python 3 upstream and in the port. Approved by: krion (mentor) Sponsored by: BBOX.io Differential Revision: https://reviews.freebsd.org/D23269
This commit is contained in:
parent
21d0ccb34b
commit
df01c97835
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=523592
4 changed files with 26 additions and 20 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= nsscache
|
||||
PORTVERSION= 0.37
|
||||
PORTVERSION= 0.39
|
||||
DISTVERSIONPREFIX= version/
|
||||
CATEGORIES= net python
|
||||
|
||||
|
@ -12,12 +12,16 @@ COMMENT= Python utility to create a local cache of directory services
|
|||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:databases/py-bsddb@${PY_FLAVOR} \
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto3>0:www/py-boto3@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}bsddb3>0:databases/py-bsddb3@${PY_FLAVOR} \
|
||||
${PYTHON_SITELIBDIR}/pycurl.so:ftp/py-pycurl@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}ldap>0:net/py-ldap@${PY_FLAVOR}
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mox>0:devel/py-mox@${PY_FLAVOR}
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}mox3>0:devel/py-mox3@${PY_FLAVOR}
|
||||
|
||||
USES= python:2.7
|
||||
USES= python:3.4+
|
||||
USE_PYTHON= autoplist distutils
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= google
|
||||
|
@ -39,6 +43,7 @@ post-install:
|
|||
@${MKDIR} ${STAGEDIR}/var/db/nsscache
|
||||
|
||||
do-test:
|
||||
${PYTHON_CMD} ${WRKSRC}/runtests.py
|
||||
cd ${WRKSRC} && ${PYTHON_CMD} setup.py test
|
||||
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1545713850
|
||||
SHA256 (google-nsscache-version-0.37_GH0.tar.gz) = fab735cabb6ea6e46ce2c52e2c9ea9c2938057fa9e3992b3509f31cf5948fff4
|
||||
SIZE (google-nsscache-version-0.37_GH0.tar.gz) = 122932
|
||||
TIMESTAMP = 1579460924
|
||||
SHA256 (google-nsscache-version-0.39_GH0.tar.gz) = 3eb0b2a4c163d2c2fd3748e23fc6296f253d9be0a74a1fe9c0fe3191f4c2638d
|
||||
SIZE (google-nsscache-version-0.39_GH0.tar.gz) = 127896
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- nsscache.conf.orig 2016-01-16 19:03:07.000000000 -0700
|
||||
+++ nsscache.conf 2016-02-28 23:28:01.441959000 -0700
|
||||
--- nsscache.conf.orig 2019-11-11 16:27:27 UTC
|
||||
+++ nsscache.conf
|
||||
@@ -2,7 +2,7 @@
|
||||
#
|
||||
# nsscache loads a config file from the environment variable NSSCACHE_CONFIG
|
||||
|
@ -9,7 +9,7 @@
|
|||
#
|
||||
# Commented values are overrideable defaults, uncommented values
|
||||
# require you to set them.
|
||||
@@ -21,7 +21,7 @@
|
||||
@@ -21,7 +21,7 @@ cache = files
|
||||
maps = passwd, group, shadow, netgroup, automount
|
||||
|
||||
# Directory to store our update/modify timestamps
|
||||
|
@ -18,7 +18,7 @@
|
|||
|
||||
# Lockfile to use for update/repair operations
|
||||
#lockfile = /var/run/nsscache
|
||||
@@ -113,7 +113,7 @@
|
||||
@@ -139,7 +139,7 @@ ldap_filter = (objectclass=posixAccount)
|
||||
|
||||
# Directory to store nssdb databases. Current libnss_db code requires
|
||||
# the path below
|
||||
|
|
|
@ -1,9 +1,10 @@
|
|||
--- setup.py.orig 2014-10-21 10:32:31 UTC
|
||||
--- setup.py.orig 2019-11-11 16:27:27 UTC
|
||||
+++ setup.py
|
||||
@@ -48,5 +48,4 @@ as LDAP.''',
|
||||
'nss_cache.util',
|
||||
'nss_cache.update',
|
||||
'nss_cache.sources'],
|
||||
- scripts=['nsscache'],
|
||||
- data_files=[('/etc', ['nsscache.conf'])])
|
||||
+ scripts=['nsscache'])
|
||||
@@ -46,7 +46,6 @@ as LDAP.""",
|
||||
'nss_cache.update', 'nss_cache.sources'
|
||||
],
|
||||
scripts=['nsscache'],
|
||||
- data_files=[('/etc', ['nsscache.conf'])],
|
||||
python_requires='~=3.4',
|
||||
setup_requires=['pytest-runner'],
|
||||
tests_require=['pytest', 'mox3', 'pytest-cov', 'python-coveralls'],
|
||||
|
|
Loading…
Reference in a new issue