- Mark unbroken.

- Fix build on non-i386.
- Fix build with gcc-4.2.

PR:		ports/117054
Submitted by:	Li-Lun Wang <llwang@infor.org> (maintainer)
Approved by:	portmgr (erwin), itetcu (mentor, implicit)
This commit is contained in:
Marcelo Araujo 2007-11-02 17:55:22 +00:00
parent 7ae64abc40
commit df1b9d2bde
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=202486
3 changed files with 24 additions and 14 deletions

View file

@ -56,14 +56,4 @@ MAKE_ENV+= PORTDOCS=true
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/configure
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
.if ${ARCH} != "i386"
BROKEN= fails to install
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,5 +1,5 @@
--- configure.orig Tue Apr 5 14:28:53 2005
+++ configure Fri May 19 02:02:42 2006
--- configure.orig 2005-04-05 14:28:53.000000000 -0500
+++ configure 2007-10-09 21:55:43.000000000 -0500
@@ -3256,7 +3256,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@ -27,7 +27,16 @@
then
@@ -8675,7 +8675,36 @@
@@ -8657,7 +8659,7 @@
fi
;;
- i386-FreeBSD)
+ *-FreeBSD)
echo "FreeBSD build enabled"
HUGO_TARGET_MACHINE="FREEBSD"
@@ -8675,6 +8677,35 @@
SDL_FREEBSD_FALSE=
fi

View file

@ -0,0 +1,11 @@
--- pce.c.orig 2005-03-28 08:17:45.000000000 -0600
+++ pce.c 2007-10-09 21:32:50.000000000 -0500
@@ -358,7 +358,7 @@
int UPeriod = 0;
// Number of frame to skip
-static int BaseClock;
+int BaseClock;
UChar video_driver = 0;
/* 0 => Normal driver, normal display