- Get rid of the bogus pkg-message already (noticed by: many)

- Depend on kdelibs instead of kdebase (submitted by: Pav Lucistnik
  <pav@oook.cz>)
- Add a patch submitted by: Joris Vandalon <joris@vandalon.nl>
- Bump PORTREVISION

PR:		48791
Submitted by:	maintainer
CVS ----------------------------------------------------------------------
This commit is contained in:
Tilman Keskinoz 2003-03-04 19:55:11 +00:00
parent 3dfbc30c76
commit df41664aea
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=76870
3 changed files with 45 additions and 9 deletions

View file

@ -7,7 +7,7 @@
PORTNAME= cdbakeoven
PORTVERSION= 1.8.9
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= sysutils kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -21,7 +21,7 @@ RUN_DEPENDS= cdrecord:${PORTSDIR}/sysutils/cdrtools \
ogg123:${PORTSDIR}/audio/vorbis-tools
USE_BZIP2= yes
USE_KDEBASE_VER=3
USE_KDELIBS_VER=3
USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
@ -31,7 +31,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|-O2||' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View file

@ -0,0 +1,43 @@
--- cdbakeoven/dialogs/CdboDialogActionFactory.cpp Tue Jan 21 11:11:55 2003
+++ cdbakeoven/dialogs/CdboDialogActionFactory.cpp.orig Tue Jan 21 11:11:58 2003
@@ -385,9 +385,12 @@
user->status(i18n("Reading CDROM..."));
*out += ".iso";
cdboProc = new KProcess();
- *cdboProc << "dd";
- *cdboProc << "if=" + in;
- *cdboProc << "of=" + *out + "";
+ *cdboProc << "readcd";
+ *cdboProc << "dev=" + user->getScsiDevice();
+ *cdboProc << "-q";
+ *cdboProc << "retries=32";
+ *cdboProc << "-s";
+ *cdboProc << "f=" + *out;
}
//---------------------------------------------------------------------------------------------
void CdboDialogActionFactory::initBurnProcess(QString image, bool audio ){
@@ -517,6 +520,7 @@
strBuff.prepend("'" + tmpLbl->text());
strBuff.append("'");
*cdboShellProc << strBuff;*/
+ image.replace(QRegExp("'"),"");
if(image == "-")
*cdboShellProc << " - ";
@@ -1132,7 +1136,7 @@
KRun::shellQuote( file );
KRun::shellQuote(outName);
if(mType.find("x-mp3") != -1){
- *cdboShellProc << "mpg123 -v -s " + file + " > " + outName;
+ *cdboShellProc << "mpg123 -v -w " + outName + " " + file;
tmpList->append(outName);
tracksList->append(outName);
return true;
@@ -1519,6 +1523,7 @@
void CdboDialogActionFactory::removeOneFile(QString fileName){
if(!fileName) return;
+ fileName.replace(QRegExp("'"),"");
if(!QFile::remove(fileName))
user->output(CdboDialogBase::ErrorMessage, i18n("Failed to remove ") + fileName + "!");
}

View file

@ -1,4 +0,0 @@
*******************************************************************************
PLEASE NOTE: This port will go away with the release of KDE 3.1, which will
include cdbakeoven.
*******************************************************************************