- Update to 7.5.1.

- Depend on tcl/tk 8.3
- Update WWW + mastersite
- Change maintainer to ports@freebsd.org

PR:		23954
Submitted by:	Don Croyle <croyle@gelemna.org> (maintainer)
This commit is contained in:
Alexander Langer 2000-12-30 16:50:29 +00:00
parent 338a207f4f
commit dfcac50937
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36461
7 changed files with 32 additions and 30 deletions

View file

@ -6,26 +6,26 @@
# #
PORTNAME= xconq PORTNAME= xconq
PORTVERSION= 7.3.3 PORTVERSION= 7.4.1
CATEGORIES= games CATEGORIES= games
MASTER_SITES= ftp://sourceware.cygnus.com/pub/xconq/ \ MASTER_SITES= ftp://sources.redhat.com/pub/xconq/ \
ftp://ftp.freesoftware.com/pub/sourceware/xconq/ \ ftp://ftp.freesoftware.com/pub/sourceware/xconq/ \
ftp://unix.hensa.ac.uk/mirrors/sourceware.cygnus.com/pub/xconq/ ftp://unix.hensa.ac.uk/mirrors/sourceware.cygnus.com/pub/xconq/
MAINTAINER= croyle@gelemna.org MAINTAINER= ports@freebsd.org
LIB_DEPENDS= tk80.1:${PORTSDIR}/x11-toolkits/tk80 LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
GNU_CONFIGURE= yes GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tclconfig=${PREFIX}/lib/tcl8.0 \ CONFIGURE_ARGS= --with-tclconfig=${PREFIX}/lib/tcl8.3 \
--with-tkconfig=${PREFIX}/lib/tk8.0 \ --with-tkconfig=${PREFIX}/lib/tk8.3 \
--enable-alternate-scoresdir=${SCOREDIR} --enable-alternate-scoresdir=${SCOREDIR}
USE_XLIB= yes USE_XLIB= yes
USE_GMAKE= yes USE_GMAKE= yes
CFLAGS+= -I ${PREFIX}/include/tcl8.0 \ CFLAGS+= -I ${PREFIX}/include/tcl8.3 \
-I ${PREFIX}/include/tk8.0 -I ${PREFIX}/include/tk8.3
MAN6= xconq.6 MAN6= xconq.6

View file

@ -1 +1 @@
MD5 (xconq-7.3.3.tar.gz) = 7e14ddf2b3846d989dc8d6af91c32fb7 MD5 (xconq-7.4.1.tar.gz) = c266e182c8f3454730ec4314e5d7b8aa

View file

@ -1,5 +1,5 @@
--- Makefile.in.orig Tue Jun 13 08:04:45 2000 --- Makefile.in.orig Tue Aug 22 07:52:56 2000
+++ Makefile.in Wed Jun 28 21:37:36 2000 +++ Makefile.in Sat Dec 30 04:02:02 2000
@@ -27,12 +27,12 @@ @@ -27,12 +27,12 @@
srcdir = @srcdir@ srcdir = @srcdir@
VPATH = @srcdir@ VPATH = @srcdir@
@ -27,7 +27,7 @@
RANLIB = ranlib RANLIB = ranlib
AR = ar AR = ar
@@ -274,10 +272,8 @@ @@ -254,10 +252,8 @@
install-dirs: install-dirs:
@for i in $(MAKEDIRS) ; do \ @for i in $(MAKEDIRS) ; do \
echo Making $$i... ; \ echo Making $$i... ; \

View file

@ -1,5 +1,5 @@
--- x11/Makefile.in.orig Mon Jun 19 10:36:18 2000 --- x11/Makefile.in.orig Tue Aug 22 07:52:56 2000
+++ x11/Makefile.in Thu Jun 29 04:44:07 2000 +++ x11/Makefile.in Sat Dec 30 04:03:20 2000
@@ -24,10 +24,10 @@ @@ -24,10 +24,10 @@
krnsrcdir = $(srcdir)/../kernel krnsrcdir = $(srcdir)/../kernel
@ -14,12 +14,3 @@
DIRPERM = 0755 DIRPERM = 0755
FILEPERM = 0644 FILEPERM = 0644
@@ -215,7 +215,7 @@
$(CC) -o imf2x $(ALL_CFLAGS) $(LDFLAGS) imf2x.o $(XUTOBJS) $(LOW_LIB) $(X11_LIB_FLAGS) $(WITH_LIBS) $(XAW_LIB) $(NET_EXTRA_LIBS)
ximfapp: ximfapp.o xcutil.o $(TKIAPP_LIB) $(TKIMF_LIB) $(LOW_LIB)
- $(CC) -o ximfapp $(ALL_CFLAGS) $(LDFLAGS) ximfapp.o xcutil.o $(TKIAPP_LIB) $(TKIMF_LIB) $(LOW_LIB) $(X11_LIB_FLAGS) $(WITH_LIBS) $(TCLTK_LIB) $(X11_LIB) $(NET_EXTRA_LIBS)
+ $(CC) -o ximfapp $(ALL_CFLAGS) $(LDFLAGS) ximfapp.o xcutil.o $(TKIAPP_LIB) $(TKIMF_LIB) $(LOW_LIB) $(X11_LIB_FLAGS) $(WITH_LIBS) $(TCLTK_LIB) $(X11_LIB) $(NET_EXTRA_LIBS) -lm
xshowimf: xshowimf.o $(XUTOBJS) $(LOW_LIB)
$(CC) -o xshowimf $(ALL_CFLAGS) $(LDFLAGS) xshowimf.o $(XUTOBJS) $(LOW_LIB) $(X11_LIB_FLAGS) $(WITH_LIBS) $(SELFILE_LIB) $(XAW_LIB) $(NET_EXTRA_LIBS)

View file

@ -1,6 +1,6 @@
--- x11/xconq.c.orig Mon Apr 24 07:56:58 2000 --- x11/xconq.c.orig Thu Nov 23 20:19:09 2000
+++ x11/xconq.c Wed Jun 28 21:45:49 2000 +++ x11/xconq.c Sat Dec 30 04:06:52 2000
@@ -46,8 +46,8 @@ @@ -33,8 +33,8 @@
if (argc == -1) if (argc == -1)
cmd_error(NULL, NULL); cmd_error(NULL, NULL);
/* Shift to being the user that started the game. */ /* Shift to being the user that started the game. */

View file

@ -3,4 +3,4 @@ can use to build all kinds of multi-player simulations. The manual
explains how to do this (in great detail). A large assortment of explains how to do this (in great detail). A large assortment of
predefined game modules is included. predefined game modules is included.
WWW: http://sourceware.cygnus.com/xconq/ WWW: http://sources.redhat.com/xconq/

View file

@ -93,6 +93,7 @@ share/xconq/doc/xcdesign_58.html
share/xconq/doc/xcdesign_59.html share/xconq/doc/xcdesign_59.html
share/xconq/doc/xcdesign_6.html share/xconq/doc/xcdesign_6.html
share/xconq/doc/xcdesign_60.html share/xconq/doc/xcdesign_60.html
share/xconq/doc/xcdesign_61.html
share/xconq/doc/xcdesign_7.html share/xconq/doc/xcdesign_7.html
share/xconq/doc/xcdesign_8.html share/xconq/doc/xcdesign_8.html
share/xconq/doc/xcdesign_9.html share/xconq/doc/xcdesign_9.html
@ -160,7 +161,6 @@ share/xconq/doc/xconq_63.html
share/xconq/doc/xconq_64.html share/xconq/doc/xconq_64.html
share/xconq/doc/xconq_65.html share/xconq/doc/xconq_65.html
share/xconq/doc/xconq_66.html share/xconq/doc/xconq_66.html
share/xconq/doc/xconq_67.html
share/xconq/doc/xconq_7.html share/xconq/doc/xconq_7.html
share/xconq/doc/xconq_8.html share/xconq/doc/xconq_8.html
share/xconq/doc/xconq_9.html share/xconq/doc/xconq_9.html
@ -168,6 +168,7 @@ share/xconq/doc/xconq_toc.html
share/xconq/images/advt24x26.gif share/xconq/images/advt24x26.gif
share/xconq/images/advt32x32.gif share/xconq/images/advt32x32.gif
share/xconq/images/advt44x48.gif share/xconq/images/advt44x48.gif
share/xconq/images/ancient.gif
share/xconq/images/animals32.gif share/xconq/images/animals32.gif
share/xconq/images/beach44x48.gif share/xconq/images/beach44x48.gif
share/xconq/images/civmisc.gif share/xconq/images/civmisc.gif
@ -177,6 +178,10 @@ share/xconq/images/dirt24x26.gif
share/xconq/images/dirt44x48.gif share/xconq/images/dirt44x48.gif
share/xconq/images/dwellings32.gif share/xconq/images/dwellings32.gif
share/xconq/images/eur44x48.gif share/xconq/images/eur44x48.gif
share/xconq/images/flags16x16.gif
share/xconq/images/flags8x8.gif
share/xconq/images/heroes.gif
share/xconq/images/monsters.gif
share/xconq/images/river24x26.gif share/xconq/images/river24x26.gif
share/xconq/images/river44x48.gif share/xconq/images/river44x48.gif
share/xconq/images/river88x96.gif share/xconq/images/river88x96.gif
@ -184,6 +189,7 @@ share/xconq/images/riverc24x26.gif
share/xconq/images/riverc44x48.gif share/xconq/images/riverc44x48.gif
share/xconq/images/road24x26.gif share/xconq/images/road24x26.gif
share/xconq/images/road44x48.gif share/xconq/images/road44x48.gif
share/xconq/images/road48x33i.gif
share/xconq/images/rr24x26.gif share/xconq/images/rr24x26.gif
share/xconq/images/rr44x48.gif share/xconq/images/rr44x48.gif
share/xconq/images/sea.gif share/xconq/images/sea.gif
@ -191,6 +197,7 @@ share/xconq/images/settlers.gif
share/xconq/images/splash.gif share/xconq/images/splash.gif
share/xconq/images/stdt24x26.gif share/xconq/images/stdt24x26.gif
share/xconq/images/stdt44x48.gif share/xconq/images/stdt44x48.gif
share/xconq/images/stdt48x33i.gif
share/xconq/images/stdta88x96.gif share/xconq/images/stdta88x96.gif
share/xconq/images/stdtb88x96.gif share/xconq/images/stdtb88x96.gif
share/xconq/images/tran24x26.gif share/xconq/images/tran24x26.gif
@ -201,6 +208,7 @@ share/xconq/imfapp.tcl
share/xconq/lib/1756.g share/xconq/lib/1756.g
share/xconq/lib/1757.g share/xconq/lib/1757.g
share/xconq/lib/1805.g share/xconq/lib/1805.g
share/xconq/lib/3rd-age.g
share/xconq/lib/advances.g share/xconq/lib/advances.g
share/xconq/lib/advterr.g share/xconq/lib/advterr.g
share/xconq/lib/africa-1850.g share/xconq/lib/africa-1850.g
@ -215,12 +223,12 @@ share/xconq/lib/beirut.g
share/xconq/lib/blasts.imf share/xconq/lib/blasts.imf
share/xconq/lib/cave.g share/xconq/lib/cave.g
share/xconq/lib/cherbourg.g share/xconq/lib/cherbourg.g
share/xconq/lib/chess.g
share/xconq/lib/civ2.g share/xconq/lib/civ2.g
share/xconq/lib/classic.g share/xconq/lib/classic.g
share/xconq/lib/cobra.g share/xconq/lib/cobra.g
share/xconq/lib/colors.imf share/xconq/lib/colors.imf
share/xconq/lib/coral-sea.g share/xconq/lib/coral-sea.g
share/xconq/lib/coral-sea-th.g
share/xconq/lib/crater-lake.g share/xconq/lib/crater-lake.g
share/xconq/lib/duel.g share/xconq/lib/duel.g
share/xconq/lib/dwellings.imf share/xconq/lib/dwellings.imf
@ -251,6 +259,7 @@ share/xconq/lib/insects.imf
share/xconq/lib/intro.g share/xconq/lib/intro.g
share/xconq/lib/lhs.g share/xconq/lib/lhs.g
share/xconq/lib/lhsunit.g share/xconq/lib/lhsunit.g
share/xconq/lib/lord-rings.g
share/xconq/lib/magellan.g share/xconq/lib/magellan.g
share/xconq/lib/magnuszew.g share/xconq/lib/magnuszew.g
share/xconq/lib/mars.g share/xconq/lib/mars.g
@ -280,6 +289,7 @@ share/xconq/lib/ng-japanese.g
share/xconq/lib/ng-misc.g share/xconq/lib/ng-misc.g
share/xconq/lib/ng-nickname.g share/xconq/lib/ng-nickname.g
share/xconq/lib/ng-ships.g share/xconq/lib/ng-ships.g
share/xconq/lib/ng-swedish.g
share/xconq/lib/ng-weird.g share/xconq/lib/ng-weird.g
share/xconq/lib/normandy.g share/xconq/lib/normandy.g
share/xconq/lib/nw-europe.g share/xconq/lib/nw-europe.g
@ -295,7 +305,6 @@ share/xconq/lib/places.imf
share/xconq/lib/postmodern.g share/xconq/lib/postmodern.g
share/xconq/lib/quest.g share/xconq/lib/quest.g
share/xconq/lib/red-october.g share/xconq/lib/red-october.g
share/xconq/lib/rising-sun.g
share/xconq/lib/rom-civ-war.g share/xconq/lib/rom-civ-war.g
share/xconq/lib/roman.g share/xconq/lib/roman.g
share/xconq/lib/russian-rev.g share/xconq/lib/russian-rev.g
@ -314,12 +323,14 @@ share/xconq/lib/t-cent-eur.g
share/xconq/lib/t-e1-river.g share/xconq/lib/t-e1-river.g
share/xconq/lib/t-e50-river.g share/xconq/lib/t-e50-river.g
share/xconq/lib/t-eastmed.g share/xconq/lib/t-eastmed.g
share/xconq/lib/t-midearth.g
share/xconq/lib/t-near-east.g share/xconq/lib/t-near-east.g
share/xconq/lib/t-normandy.g share/xconq/lib/t-normandy.g
share/xconq/lib/t-nw-eur.g share/xconq/lib/t-nw-eur.g
share/xconq/lib/t-pacific.g share/xconq/lib/t-pacific.g
share/xconq/lib/t-roman.g share/xconq/lib/t-roman.g
share/xconq/lib/t-russia.g share/xconq/lib/t-russia.g
share/xconq/lib/tailhook.g
share/xconq/lib/tank.g share/xconq/lib/tank.g
share/xconq/lib/tanks.imf share/xconq/lib/tanks.imf
share/xconq/lib/terrain.imf share/xconq/lib/terrain.imf