upgrade to 7.1.2, it's not in-secure now
PR: 26088 Submitted by: ijliao (me) No Response from: maintainer
This commit is contained in:
parent
11c862ebd1
commit
e017f4f74a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41410
6 changed files with 3 additions and 103 deletions
|
@ -6,42 +6,16 @@
|
|||
#
|
||||
|
||||
PORTNAME= delegate
|
||||
PORTVERSION= 6.1.22
|
||||
CATEGORIES= net www japanese
|
||||
PORTVERSION= 7.1.2
|
||||
CATEGORIES= net www
|
||||
MASTER_SITES= ftp://ftp.delegate.org/pub/DeleGate/ \
|
||||
ftp://ftp.etl.go.jp/pub/DeleGate/
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION}
|
||||
|
||||
MAINTAINER= max@FreeBSD.org
|
||||
|
||||
NO_PACKAGE= "Insecure program."
|
||||
IS_INTERACTIVE= YES
|
||||
|
||||
pre-fetch:
|
||||
.if !defined(FORCE_BUILD) || ${FORCE_BUILD}!="YES"
|
||||
@${ECHO} "*********************************************************************"
|
||||
@${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
|
||||
@${ECHO} "* This program has know security problems which may allow a remote *"
|
||||
@${ECHO} "* attacker to take control of your machine. *"
|
||||
@${ECHO} "* See FreeBSD security advisory 00:04 for more information. *"
|
||||
@${ECHO} "* *"
|
||||
@${ECHO} "* It is strongly recommended that you avoid using this program. *"
|
||||
@${ECHO} "* *"
|
||||
@${ECHO} "* If you would like to use this program despite the danger, run *"
|
||||
@${ECHO} "* make with ``FORCE_BUILD=YES'' *"
|
||||
@${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
|
||||
@${ECHO} "*********************************************************************"
|
||||
@${FALSE}
|
||||
.else
|
||||
@${ECHO} "*********************************************************************"
|
||||
@${ECHO} "* WARNING! WARNING! WARNING! WARNING! WARNING! *"
|
||||
@${ECHO} "* You have chosen to build an insecure program. *"
|
||||
@${ECHO} "* This program has know security problems which may allow a remote *"
|
||||
@${ECHO} "* attacker to take control of your machine. *"
|
||||
@${ECHO} "* See FreeBSD security advisory 00:04 for more information. *"
|
||||
@${ECHO} "*********************************************************************"
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/delegated ${PREFIX}/sbin
|
||||
@${MKDIR} ${PREFIX}/share/examples/delegate
|
||||
|
@ -52,6 +26,5 @@ do-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/doc/Manual.htm \
|
||||
${PREFIX}/share/doc/delegate
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (delegate6.1.22.tar.gz) = 94b5972a172de45a186abd7e81a72ae1
|
||||
MD5 (delegate7.1.2.tar.gz) = af0d60a91520f219aa3d2d41e6c07f45
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
--- src/lock.c.orig Mon Mar 15 19:24:15 1999
|
||||
+++ src/lock.c Sun Apr 18 15:26:15 1999
|
||||
@@ -136,6 +136,22 @@
|
||||
break;
|
||||
}
|
||||
|
||||
+#ifdef EWOULDBLOCK
|
||||
+ /*
|
||||
+ * Only retry the lock if it was busy. Other
|
||||
+ * possible sources for the lock to fail are:
|
||||
+ * invalid argument, bad filedescriptor, and
|
||||
+ * operation not supported by device. The latter
|
||||
+ * happens if you start DeleGateD with -v, so it
|
||||
+ * logs to stderr (which usually doesn't support
|
||||
+ * locking at all).
|
||||
+ */
|
||||
+ if (rcode == -1 && errno != EWOULDBLOCK) {
|
||||
+ /* pretend lock succeeded */
|
||||
+ rcode = 0;
|
||||
+ break;
|
||||
+ }
|
||||
+#endif
|
||||
remain = timeout - elapsed;
|
||||
if( remain <= 0 )
|
||||
break;
|
||||
@@ -146,6 +162,13 @@
|
||||
|
||||
start = Time();
|
||||
rcode = callFuncTimeout(remain/1000,-1,func,fd);
|
||||
+#ifdef EWOULDBLOCK
|
||||
+ if (rcode == -1 && errno != EWOULDBLOCK) {
|
||||
+ /* pretend lock succeeded */
|
||||
+ rcode = 0;
|
||||
+ break;
|
||||
+ }
|
||||
+#endif
|
||||
elapse1 = (Time() - start) * 1000;
|
||||
/*{
|
||||
static int n;
|
|
@ -1,7 +0,0 @@
|
|||
--- maker/__fork.c.orig Tue Jun 3 22:56:42 1997
|
||||
+++ maker/__fork.c Sun Oct 29 22:32:55 2000
|
||||
@@ -1,3 +1,4 @@
|
||||
+#include <sys/types.h>
|
||||
#include <sys/wait.h>
|
||||
|
||||
INHERENT_fork(){ return 1; }
|
|
@ -1,7 +0,0 @@
|
|||
--- maker/spawnvp_.c.orig Thu Jun 19 02:40:16 1997
|
||||
+++ maker/spawnvp_.c Sun Oct 29 22:32:55 2000
|
||||
@@ -1,3 +1,4 @@
|
||||
+#include <sys/types.h>
|
||||
#include <sys/wait.h>
|
||||
|
||||
INHERENT_spawn(){ return 0; }
|
|
@ -1,20 +0,0 @@
|
|||
*********************************************************************
|
||||
* WARNING! WARNING! WARNING! WARNING! WARNING! *
|
||||
* You have installed an insecure program. *
|
||||
* This program has know security problems which may allow a remote *
|
||||
* attacker to take control of your machine. *
|
||||
* Use with great caution! *
|
||||
* See FreeBSD security advisory 00:04 for more information. *
|
||||
*********************************************************************
|
||||
|
||||
----------------------------------------------------------------------
|
||||
Now, edit the sample script in /usr/local/share/examples/delegate directory
|
||||
and copy it into /usr/local/etc/rc.d.
|
||||
Especially, don't forget to specify correct value for the MANAGER.
|
||||
|
||||
You can also run an interactive configuration session by executing
|
||||
delegated with no argument.
|
||||
|
||||
Consult /usr/local/share/doc/delegate/Manual.htm for configuration
|
||||
information.
|
||||
----------------------------------------------------------------------
|
Loading…
Reference in a new issue