- Fix build on sparc64

PR:		99897
Submitted by:	ahze (me)
Approved by:	maintainer (14 days timeout)
This commit is contained in:
Michael Johnson 2006-07-22 19:54:58 +00:00
parent 27bf94e018
commit e01b4d7789
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=168504
2 changed files with 20 additions and 4 deletions

View file

@ -33,10 +33,6 @@ CFLAGS+= -O3 -ffast-math
.include <bsd.port.pre.mk> .include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
BROKEN= "Does not compile on sparc64"
.endif
pre-everything:: pre-everything::
.if !defined(WITH_OPTIMIZED_CFLAGS) .if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "You can enable additional compilation optimizations" @${ECHO_MSG} "You can enable additional compilation optimizations"

View file

@ -0,0 +1,20 @@
--- source/blender/blenlib/intern/storage.c.orig Fri Jul 7 14:15:04 2006
+++ source/blender/blenlib/intern/storage.c Fri Jul 7 14:17:47 2006
@@ -50,7 +50,7 @@
#include <time.h>
#include <sys/stat.h>
-#if !defined(linux) && (defined(__sgi) || defined(__sun__) || defined(__sun) || defined(__sparc) || defined(__sparc__))
+#if !defined(__FreeBSD__) && !defined(linux) && (defined(__sgi) || defined(__sun__) || defined(__sun) || defined(__sparc) || defined(__sparc__))
#include <sys/statfs.h>
#endif
@@ -194,7 +194,7 @@
#ifdef __BeOS
return -1;
#endif
-#if !defined(linux) && (defined (__sgi) || defined (__sun__) || defined (__sun) || defined(__sparc) || defined(__sparc__))
+#if !defined(__FreeBSD__) && !defined(linux) && (defined (__sgi) || defined (__sun__) || defined (__sun) || defined(__sparc) || defined(__sparc__))
if (statfs(name, &disk, sizeof(struct statfs), 0)){
/* printf("diskfree: Couldn't get information about %s.\n",dir); */