comms/nanovna-saver: Update to 3.10

- Fixed FreeBSD specifc Sysctl.py code so it will no longer core
  if no USB device plugged in
- changed delay in NanoVNA__V2.py since too fast for some devices
  see https://github.com/NanoVNA-Saver/nanovna-saver/issues/441

Changelog
=========

v0.3.10
------

- Default Band ranges for 5 and 9cm
- Layout should fit on smaller screens
- Fixed fixed axis settings
- Show VNA type in port selector
- Recognise tinySA (screenshot only)
- Some more cables in TDR
- Reference plane applied after calibration
- Calibration fixes by DiSlord

v0.3.9
------

- TX Power on V2
- New analysis
- Magnitude Z Chart
- VSWR Chart improvements

Reported by:	portscout
This commit is contained in:
Diane Bruce 2022-01-11 14:02:43 -05:00
parent 800703e701
commit e045eef41a
5 changed files with 25 additions and 31 deletions

View file

@ -1,7 +1,6 @@
PORTNAME= nanovna-saver
DISTVERSIONPREFIX= v
DISTVERSION= 0.3.8
PORTREVISION= 2
DISTVERSION= 0.3.10
CATEGORIES= comms hamradio
MAINTAINER= hamradio@FreeBSD.org

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1609597287
SHA256 (mihtjel-nanovna-saver-v0.3.8_GH0.tar.gz) = 761e5ec2d5efc6b0843038b9d241bcbdc433a76d68a5f0631be367a629e78163
SIZE (mihtjel-nanovna-saver-v0.3.8_GH0.tar.gz) = 357896
TIMESTAMP = 1641829596
SHA256 (mihtjel-nanovna-saver-v0.3.10_GH0.tar.gz) = 202c907125015e2fb26926ef1ce365321d749207a74e3029e729e89e50acda88
SIZE (mihtjel-nanovna-saver-v0.3.10_GH0.tar.gz) = 477821

View file

@ -1,31 +1,28 @@
--- NanoVNASaver/Hardware/Hardware.py.orig 2020-11-01 13:28:10 UTC
--- NanoVNASaver/Hardware/Hardware.py.orig 2022-01-04 07:44:03 UTC
+++ NanoVNASaver/Hardware/Hardware.py
@@ -33,6 +33,7 @@ from NanoVNASaver.Hardware.NanoVNA_H import NanoVNA_H
from NanoVNASaver.Hardware.NanoVNA_H4 import NanoVNA_H4
@@ -34,6 +34,7 @@ from NanoVNASaver.Hardware.NanoVNA_H4 import NanoVNA_H
from NanoVNASaver.Hardware.NanoVNA_V2 import NanoVNA_V2
from NanoVNASaver.Hardware.TinySA import TinySA
from NanoVNASaver.Hardware.Serial import drain_serial, Interface
+from NanoVNASaver.Hardware.Sysctl import usb_vid_pid
logger = logging.getLogger(__name__)
@@ -63,8 +64,12 @@ def get_interfaces() -> List[Interface]:
interfaces = []
# serial like usb interfaces
@@ -80,6 +81,11 @@ def get_interfaces() -> List[Interface]:
for d in list_ports.comports():
- if platform.system() == 'Windows' and d.vid is None:
- d = _fix_v2_hwinfo(d)
if platform.system() == 'Windows' and d.vid is None:
d = _fix_v2_hwinfo(d)
+ if platform.system() == 'FreeBSD':
+ logger.debug("Found FreeBSD USB port %s", d.device)
+ vid_pid = usb_vid_pid(d.device)
+ d.vid = vid_pid[0]
+ d.pid = vid_pid[1]
+
for t in USBDEVICETYPES:
if d.vid != t.vid or d.pid != t.pid:
continue
@@ -74,7 +79,6 @@ def get_interfaces() -> List[Interface]:
iface.port = d.device
interfaces.append(iface)
@@ -94,7 +100,6 @@ def get_interfaces() -> List[Interface]:
logger.debug("Interfaces: %s", interfaces)
return interfaces
-

View file

@ -0,0 +1,12 @@
--- NanoVNASaver/Hardware/NanoVNA_V2.py.orig 2022-01-11 18:46:18 UTC
+++ NanoVNASaver/Hardware/NanoVNA_V2.py
@@ -55,7 +55,8 @@ _ADDR_HARDWARE_REVISION = 0xf2
_ADDR_FW_MAJOR = 0xf3
_ADDR_FW_MINOR = 0xf4
-WRITE_SLEEP = 0.05
+#WRITE_SLEEP = 0.05
+WRITE_SLEEP = 0.1
_ADF4350_TXPOWER_DESC_MAP = {
0: '9dB attenuation',

View file

@ -1,14 +0,0 @@
--- setup.py.orig 2021-01-02 14:25:03 UTC
+++ setup.py
@@ -38,11 +38,4 @@ setup(
'NanoVNASaver = NanoVNASaver.__main__:main'
],
},
- install_requires=[
- 'pyserial',
- 'PyQt5',
- 'numpy',
- 'scipy',
- 'cython',
- ],
)