- updated to 1.2.6

- changed for ibus 1.4.0
- clean-up Makefile
This commit is contained in:
Daichi GOTO 2012-01-14 03:35:54 +00:00
parent 196173d5b1
commit e07a57f633
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=289137
8 changed files with 52 additions and 67 deletions

View file

@ -6,59 +6,43 @@
#
PORTNAME= ibus-anthy
PORTVERSION= 1.2.4
PORTVERSION= 1.2.6
CATEGORIES= japanese
PROJECTHOST= ibus
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= daichi@FreeBSD.org
COMMENT= Anthy engine for IBus
BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
LIB_DEPENDS+= anthy.1:${PORTSDIR}/japanese/anthy \
ibus.2:${PORTSDIR}/textproc/ibus
LIB_DEPENDS= anthy.1:${PORTSDIR}/japanese/anthy \
ibus-1.0.400:${PORTSDIR}/textproc/ibus
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify
USE_GNOME= pygtk2
USE_PYTHON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
PROJECTHOST= ibus
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_GMAKE= yes
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
USE_PYTHON= yes
USE_GNOME= pygtk2
REPLACE_FILES= engine/engine.py setup/anthyprefs.py setup/main.py
LOCALBASE_REPLACE_FILES= \
engine/engine.py \
setup/anthyprefs.py \
setup/main.py
INCLUDEDIR_REPLACE_FILES= \
engine/Makefile.am \
engine/Makefile.in
post-patch:
@for FILE in ${REPLACE_FILES}; do \
${SED} -i .bak -e "s/@@LOCALBASE@@/${LOCALBASE:S/\//\\\//g}/g" \
${WRKSRC}/$${FILE}; \
done;
port-build:
.if !defined(WITHOUT_NLS)
@cd ${WRKSRC}/po; \
${GMAKE} all-yes
.endif
cd ${WRKSRC} && \
${REINPLACE_CMD} "s/@@LOCALBASE@@/${LOCALBASE:S/\//\\\//g}/g" \
${LOCALBASE_REPLACE_FILES} && \
${REINPLACE_CMD} "s/@@INCLUDEDIR@@/${INCLUDEDIR:S/\//\\\//g}/g" \
${INCLUDEDIR_REPLACE_FILES}
post-install:
.if !defined(WITHOUT_NLS)
@cd ${WRKSRC}/po; \
${GMAKE} install-data-yes
@${CHMOD} 444 \
${LOCALBASE}/share/locale/fr/LC_MESSAGES/ibus-anthy.mo \
${LOCALBASE}/share/locale/ja/LC_MESSAGES/ibus-anthy.mo \
${LOCALBASE}/share/locale/zh_CN/LC_MESSAGES/ibus-anthy.mo
.endif
@${CAT} ${PKGMESSAGE}
@${ECHO} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
@${ECHO_CMD} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (ibus-anthy-1.2.4.tar.gz) = 6fb22a28445b8c6d4e42ebc163968709faab1a903a2699aa1ce30b4c11e06736
SIZE (ibus-anthy-1.2.4.tar.gz) = 496158
SHA256 (ibus-anthy-1.2.6.tar.gz) = e4d5eb27c35295a69c0baa308a6589c8aea19f72317d08b692437af5512dd6f6
SIZE (ibus-anthy-1.2.6.tar.gz) = 519488

View file

@ -1,38 +1,38 @@
--- configure.org 2010-10-26 21:43:56.110339260 +0900
+++ configure 2010-10-26 21:45:26.167340080 +0900
@@ -16347,7 +16347,7 @@
--- configure.orig 2012-01-14 12:14:14.987155483 +0900
+++ configure 2012-01-14 12:24:25.699154843 +0900
@@ -17010,7 +17010,7 @@
if test $ac_have_decl = 1; then :
else
- as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+# as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
- as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+# as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
fi
ac_fn_c_check_decl "$LINENO" "NTH_KATAKANA_CANDIDATE" "ac_cv_have_decl_NTH_KATAKANA_CANDIDATE" "#include <anthy/anthy.h>
"
@@ -16363,7 +16363,7 @@
@@ -17026,7 +17026,7 @@
if test $ac_have_decl = 1; then :
else
- as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+# as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
- as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+# as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
fi
ac_fn_c_check_decl "$LINENO" "NTH_HIRAGANA_CANDIDATE" "ac_cv_have_decl_NTH_HIRAGANA_CANDIDATE" "#include <anthy/anthy.h>
"
@@ -16379,7 +16379,7 @@
@@ -17042,7 +17042,7 @@
if test $ac_have_decl = 1; then :
else
- as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+# as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
- as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+# as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
fi
ac_fn_c_check_decl "$LINENO" "NTH_HALFKANA_CANDIDATE" "ac_cv_have_decl_NTH_HALFKANA_CANDIDATE" "#include <anthy/anthy.h>
"
@@ -16395,7 +16395,7 @@
@@ -17058,7 +17058,7 @@
if test $ac_have_decl = 1; then :
else
- as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+# as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
- as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+# as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
fi

View file

@ -1,11 +1,11 @@
--- engine/Makefile.am.org 2010-10-26 21:45:32.256341895 +0900
+++ engine/Makefile.am 2010-10-26 21:46:30.290338394 +0900
--- engine/Makefile.am.orig 2012-01-14 12:14:14.982155825 +0900
+++ engine/Makefile.am 2012-01-14 12:24:26.006155593 +0900
@@ -62,7 +62,7 @@
enginedir = $(datadir)/ibus/component
anthy.py anthy_wrap.c: anthy.i
- $(SWIG) -python $(ANTHY_CFLAGS) -I/usr/include -o anthy_wrap.c $(srcdir)/anthy.i
+ $(SWIG) -python -I/usr/include ${ANTHY_CFLAGS} -o anthy_wrap.c $(srcdir)/anthy.i
+ $(SWIG) -python -I@@INCLUDEDIR@@ ${ANTHY_CFLAGS} -o anthy_wrap.c $(srcdir)/anthy.i
anthy.xml: anthy.xml.in
( \

View file

@ -1,11 +1,11 @@
--- engine/Makefile.in.org 2010-10-26 21:46:34.816343795 +0900
+++ engine/Makefile.in 2010-10-26 21:46:56.693338776 +0900
@@ -791,7 +791,7 @@
--- engine/Makefile.in.orig 2012-01-14 12:14:14.982155825 +0900
+++ engine/Makefile.in 2012-01-14 12:24:25.982156733 +0900
@@ -795,7 +795,7 @@
anthy.py anthy_wrap.c: anthy.i
- $(SWIG) -python $(ANTHY_CFLAGS) -I/usr/include -o anthy_wrap.c $(srcdir)/anthy.i
+ $(SWIG) -python -I/usr/include ${ANTHY_CFLAGS} -o anthy_wrap.c $(srcdir)/anthy.i
+ $(SWIG) -python -I@@INCLUDEDIR@@ ${ANTHY_CFLAGS} -o anthy_wrap.c $(srcdir)/anthy.i
anthy.xml: anthy.xml.in
( \

View file

@ -1,5 +1,5 @@
--- po/Makefile.in.in.org 2010-10-26 21:47:03.832342476 +0900
+++ po/Makefile.in.in 2010-10-26 21:47:19.182337797 +0900
--- po/Makefile.in.in.orig 2012-01-14 12:14:14.985154041 +0900
+++ po/Makefile.in.in 2012-01-13 11:29:00.154154365 +0900
@@ -34,7 +34,7 @@
datarootdir = @datarootdir@
libdir = @libdir@

View file

@ -1,5 +1,5 @@
--- setup/main.py.org 2010-10-26 21:47:23.526339618 +0900
+++ setup/main.py 2010-10-26 21:47:47.987340388 +0900
--- setup/main.py.orig 2012-01-14 12:14:14.986154797 +0900
+++ setup/main.py 2012-01-14 12:24:25.953154304 +0900
@@ -58,7 +58,7 @@
# glade "icon_name" property has a custom scaling and it seems
# to be difficult to show the complicated small icon in metacity.

View file

@ -3,6 +3,7 @@
%%PYTHON_SITELIBDIR%%/anthy.py
libexec/ibus-engine-anthy
libexec/ibus-setup-anthy
%%DATADIR%%/dicts/oldchar.t
%%DATADIR%%/dicts/symbol.t
%%DATADIR%%/engine/engine.py
%%DATADIR%%/engine/engine.pyc
@ -43,9 +44,9 @@ libexec/ibus-setup-anthy
%%DATADIR%%/setup/prefs.pyo
%%DATADIR%%/setup/setup.glade
share/ibus/component/anthy.xml
%%NLS%%share/locale/fr/LC_MESSAGES/ibus-anthy.mo
%%NLS%%share/locale/ja/LC_MESSAGES/ibus-anthy.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus-anthy.mo
share/locale/fr/LC_MESSAGES/ibus-anthy.mo
share/locale/ja/LC_MESSAGES/ibus-anthy.mo
share/locale/zh_CN/LC_MESSAGES/ibus-anthy.mo
@dirrm %%DATADIR%%/setup
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%/engine