- Update to 2.0.5.

- Convert to OptionsNG.
- Install the .desktop file and PNG icon into ${PREFIX} instead of
  ${LOCALBASE}. This should make no difference to everyone else, but makes
  using `port test' easier with the port.
This commit is contained in:
Raphael Kubo da Costa 2012-12-25 16:28:34 +00:00
parent 5c30de3a0f
commit e07f9e9773
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=309487
4 changed files with 29 additions and 16 deletions

View file

@ -21,7 +21,7 @@ LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs \
CONFLICTS= lyx-1.[0-9]*
MAJOR_VERSION= 2.0
MINOR_VERSION= 4
MINOR_VERSION= 5
USE_XZ= yes
USE_GMAKE= yes
@ -40,32 +40,32 @@ MAKE_JOBS_SAFE= yes
MAN1= lyx.1 lyxclient.1 tex2lyx.1
OPTIONS= ASPELL "Use Aspell for spell checking" off \
ENCHANT "Use Enchant for spell checking" off \
HUNSPELL "Use Hunspell for spell checking" on \
NLS "Native language support" on
OPTIONS_DEFINE= ASPELL ENCHANT HUNSPELL NLS
OPTIONS_DEFAULT= HUNSPELL NLS
ENCHANT_DESC= Spell checking using Enchant
HUNSPELL_DESC= Spell checking using Hunspell
.include <bsd.port.options.mk>
.if !defined(WITHOUT_ASPELL)
.if ${PORT_OPTIONS:MASPELL}
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
.else
CONFIGURE_ARGS+= --without-aspell
.endif
.if !defined(WITHOUT_ENCHANT)
.if ${PORT_OPTIONS:MENCHANT}
LIB_DEPENDS+= enchant.1:${PORTSDIR}/textproc/enchant
.else
CONFIGURE_ARGS+= --without-enchant
.endif
.if !defined(WITHOUT_HUNSPELL)
.if ${PORT_OPTIONS:MHUNSPELL}
LIB_DEPENDS+= hunspell-1.3.0:${PORTSDIR}/textproc/hunspell
.else
CONFIGURE_ARGS+= --without-hunspell
.endif
.if defined(WITHOUT_NLS)
.if empty(PORT_OPTIONS:MNLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.else
@ -76,10 +76,10 @@ PLIST_SUB+= NLS=""
post-install:
# Manually install the 48x48 icon and .desktop file.
# Will not be needed in the 2.1 series, see LyX tickets 2820 and 7919.
${MKDIR} ${LOCALBASE}/share/icons/hicolor/48x48/apps
${MKDIR} ${LOCALBASE}/share/applications
${INSTALL_DATA} ${WRKSRC}/lib/images/lyx.png ${LOCALBASE}/share/icons/hicolor/48x48/apps
${INSTALL_DATA} ${FILESDIR}/lyx.desktop ${LOCALBASE}/share/applications
${MKDIR} ${PREFIX}/share/icons/hicolor/48x48/apps
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/lib/images/lyx.png ${PREFIX}/share/icons/hicolor/48x48/apps
${INSTALL_DATA} ${FILESDIR}/lyx.desktop ${PREFIX}/share/applications
${LOCALBASE}/bin/update-desktop-database --quiet
@${CAT} ${PKGMESSAGE}

View file

@ -1,2 +1,2 @@
SHA256 (lyx-2.0.4.tar.xz) = 68317ba1c19fb372823421f967acd349033341acf521d96afa58991f7efded8c
SIZE (lyx-2.0.4.tar.xz) = 10280308
SHA256 (lyx-2.0.5.tar.xz) = d39aada3390a0468b354ec1703f12734bdfe56b08baa7950373748745313fb02
SIZE (lyx-2.0.5.tar.xz) = 10314440

View file

@ -0,0 +1,12 @@
Build fix for gcc 4.5+, which complains about FILE not being defined in
mythes.hxx.
--- src/Thesaurus.cpp.orig 2012-12-25 17:28:52.000000000 +0200
+++ src/Thesaurus.cpp 2012-12-25 17:29:18.000000000 +0200
@@ -24,6 +24,7 @@
#include "support/os.h"
#ifdef USE_EXTERNAL_MYTHES
+#include <cstdio>
#include MYTHES_H_LOCATION
#else
#include <cstdio>

View file

@ -294,7 +294,9 @@ share/icons/hicolor/48x48/apps/lyx.png
%%DATADIR%%/examples/es/ItemizeBullets.lyx
%%DATADIR%%/examples/es/ejemplo_con_lyx.lyx
%%DATADIR%%/examples/es/ejemplo_sin_lyx.lyx
%%DATADIR%%/examples/es/europeCV.lyx
%%DATADIR%%/examples/es/linguistics.lyx
%%DATADIR%%/examples/es/modernCV.lyx
%%DATADIR%%/examples/es/multicol.lyx
%%DATADIR%%/examples/es/splash.lyx
%%DATADIR%%/examples/es/tufte-book.lyx
@ -1756,7 +1758,6 @@ share/icons/hicolor/48x48/apps/lyx.png
@dirrm %%DATADIR%%/kbd
@dirrm %%DATADIR%%/images/oxygen
@dirrm %%DATADIR%%/images/math
@dirrm %%DATADIR%%/images/commands
@dirrm %%DATADIR%%/images/classic
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%/fonts