Okay, I've gone through every example and doc that I can think of that would

be relevant, and think I've covered everything...

This now build and a 'make package' now works...with my track record on
this particular port, its bound to be still broken for *someone*, no?
This commit is contained in:
Marc G. Fournier 1998-11-16 03:25:26 +00:00
parent 0567867787
commit e0bfbdc723
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=14549
3 changed files with 16 additions and 10 deletions

View file

@ -3,7 +3,7 @@
# Date created: 11 July 1998
# Whom: Marc G. Fournier <scrappy@freebsd.org>
#
# $Id: Makefile,v 1.23 1998/11/15 07:08:20 scrappy Exp $
# $Id: Makefile,v 1.24 1998/11/15 07:50:11 scrappy Exp $
#
DISTNAME= mico-2.2.3
@ -12,8 +12,6 @@ MASTER_SITES= http://diamant-atm.vsb.cs.uni-frankfurt.de/~mico/
MAINTAINER= scrappy@freebsd.org
BROKEN_ELF= yes
.include <bsd.port.pre.mk>
.if ${PORTOBJFORMAT} == "elf"

View file

@ -1,11 +1,11 @@
--- configure.in.orig Wed Oct 21 10:29:16 1998
+++ configure.in Sun Nov 15 03:40:45 1998
+++ configure.in Sun Nov 15 15:20:10 1998
@@ -102,7 +102,7 @@
# extra dirs
#
-wi_EXTRA_DIRS(no, /usr/local /local /user/local /usr/share /opt /opt/local $QTDIR $GTKDIR $TCLDIR $SSLDIR)
+wi_EXTRA_DIRS(no, /usr/local /local /user/local /usr/share /opt /opt/local $QTDIR $GTKDIR $TCLDIR $SSLDIR, tcl8.0)
+wi_EXTRA_DIRS(no, /usr/local /local /user/local /usr/share /opt /opt/local /usr/X11R6 $QTDIR $GTKDIR $TCLDIR $SSLDIR, tcl8.0 X11/qt )
#
# misc
@ -14,9 +14,9 @@
;;
*bsd*)
- CONF_SOEXT=so.1.0
+ if [ "$PORTOBJFORMAT" = "elf" ]; then
+ if test "X$PORTOBJFORMAT" = "Xelf"; then
+ CONF_SHARED_CC="$CXX -shared -Wl,-soname,\$@"
+ CONF_SOEXE=so.1
+ CONF_SOEXT=so.1
+ else
+ CONF_SOEXT=so.1.0
+ fi

View file

@ -6,6 +6,8 @@ bin/mico-ar
bin/mico-c++
bin/mico-cpp
bin/mico-ld
bin/mico-shc++
bin/mico-shld
bin/micod
bin/nsadmin
bin/nsd
@ -403,12 +405,18 @@ include/ministl/vector
include/ministl/vector.h
lib/libmico2.2.3.a
lib/libmicoaux2.2.3.a
lib/libmicoaux2.2.3.so.1.0
lib/libmicoaux2.2.3.so.1
lib/libmicocoss2.2.3.a
lib/libmicogtk2.2.3.a
lib/libmicogtk2.2.3.so.1
lib/libmicoqt2.2.3.a
lib/libmicoqt2.2.3.so.1.0
lib/libmicoqt2.2.3.so.1
lib/libmicotcl2.2.3.a
lib/libmicotcl2.2.3.so.1
lib/libmicox2.2.3.a
lib/libmicox2.2.3.so.1.0
lib/libmicox2.2.3.so.1
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
lib/mico-setup.csh
lib/mico-setup.sh
@dirrm include/ministl