Update to a recent snapshot

This commit is contained in:
Antoine Brodin 2015-02-01 12:07:59 +00:00
parent f80f3827b5
commit e0ddbd9df9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=378240
5 changed files with 24 additions and 25 deletions

View file

@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= faup
PORTVERSION= 1.4
PORTVERSION= 1.4.20150118
CATEGORIES= www devel
MASTER_SITES= http://github.com/stricaud/${PORTNAME}/archive/v${PORTVERSION}.tar.gz?dummy=/ \
LOCAL/antoine
MASTER_SITES= GH LOCAL/antoine
MAINTAINER= antoine@FreeBSD.org
COMMENT= Fast URL decoder library
@ -15,8 +14,14 @@ LICENSE_NAME= Do What The [expletive] You Want To Public License, Version 2
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
USE_GITHUB= yes
GH_ACCOUNT= stricaud
GH_TAGNAME= af9e5db
GH_COMMIT= af9e5db
USES= cmake:outsource lua
USE_LDCONFIG= yes
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=${PREFIX}/man
PORTDOCS= *
@ -26,7 +31,8 @@ post-patch:
@${REINPLACE_CMD} -e "s/5.1/${LUA_VER}/g" -e \
"s/51/${LUA_VER_STR}/g" ${WRKSRC}/cmake/FindLua51.cmake
@${REINPLACE_CMD} -e "s/LUA51_FOUND/LUA${LUA_VER_STR}_FOUND/g" \
${WRKSRC}/CMakeLists.txt ${WRKSRC}/src/lib/CMakeLists.txt
${WRKSRC}/CMakeLists.txt ${WRKSRC}/src/lib/CMakeLists.txt \
${WRKSRC}/src/tools/CMakeLists.txt
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}

View file

@ -1,2 +1,2 @@
SHA256 (faup-1.4.tar.gz) = 4cee73571ae35694b4a741c4a6b6fac7039c5e014bc63b67aab716b6ae177086
SIZE (faup-1.4.tar.gz) = 570002
SHA256 (faup-1.4.20150118.tar.gz) = 4a5469662f6f540cbdee6cadd5bb61f610c7e432017d48d26668482f23e1cce4
SIZE (faup-1.4.20150118.tar.gz) = 731613

View file

@ -1,11 +0,0 @@
--- ./CMakeLists.txt.orig 2013-09-25 08:53:24.000000000 +0000
+++ ./CMakeLists.txt 2013-11-16 12:02:09.000000000 +0000
@@ -74,7 +74,7 @@
set(FAUP_INCLUDE_DIRS "${faup-project_SOURCE_DIR}/src/lib/include/" "${faup-project_BINARY_DIR}/src/lib/include")
-set(FAUP_LIBRARY "${faup-project_BINARY_DIR}/src/lib/libfaupl.so")
+set(FAUP_LIBRARY faupl)
if(WIN32)
set(FAUP_LIBRARY "${faup-project_BINARY_DIR}/src/lib/${CMAKE_BUILD_TYPE}/faup_static.lib")
endif(WIN32)

View file

@ -1,8 +0,0 @@
--- ./src/lib/modules/CMakeLists.txt.orig 2013-09-25 08:53:24.000000000 +0000
+++ ./src/lib/modules/CMakeLists.txt 2013-11-16 12:02:09.000000000 +0000
@@ -5,4 +5,4 @@
install(FILES ${MODULES_AVAILABLE} DESTINATION share/faup/modules_available)
-install(CODE "file(MAKE_DIRECTORY ${CMAKE_INSTALL_PREFIX}/share/faup/modules_enabled)")
+install(DIRECTORY DESTINATION share/faup/modules_enabled)

View file

@ -2,18 +2,30 @@ bin/faup
include/faup/compat.h
include/faup/datadir.h
include/faup/decode.h
include/faup/errors.h
include/faup/faup.h
include/faup/features.h
include/faup/handler.h
include/faup/modules.h
include/faup/options.h
include/faup/output.h
include/faup/portable.h
include/faup/return-codes.h
include/faup/scheme-codes.h
include/faup/tld-tree.h
include/faup/tld.h
include/faup/urllengths.h
include/faup/version.h
include/faup/webserver.h
lib/libfaupl.so
lib/libfaupl.so.1
man/man1/faup.1.gz
%%DATADIR%%/README.txt
%%DATADIR%%/mozilla.tlds
%%DATADIR%%/modules_available/emulation_ie.lua
%%DATADIR%%/modules_available/printcsv.lua
%%DATADIR%%/modules_available/redis-url-threatintel.lua
%%DATADIR%%/modules_available/uppercase.lua
%%DATADIR%%/modules_available/writeall.lua
%%DATADIR%%/modules_available/writeinput.lua
@dir %%DATADIR%%/modules_enabled