math/calc: Update to 2.12.9.0
This commit is contained in:
parent
9681738b31
commit
e10b7a5313
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=568267
4 changed files with 62 additions and 5 deletions
|
@ -2,7 +2,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= calc
|
||||
PORTVERSION= 2.12.8.2
|
||||
PORTVERSION= 2.12.9.0
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= math
|
||||
|
||||
MAINTAINER= adamw@FreeBSD.org
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1613908119
|
||||
SHA256 (lcn2-calc-2.12.8.2_GH0.tar.gz) = 3bb24e13766a0b17fb69b2f30de6acca13f19e703c496d575d96703fe920b0b8
|
||||
SIZE (lcn2-calc-2.12.8.2_GH0.tar.gz) = 1122396
|
||||
TIMESTAMP = 1615656151
|
||||
SHA256 (lcn2-calc-v2.12.9.0_GH0.tar.gz) = ccad3b99c6dbbbd80883d66213774ea335fc638233d62cf6c4cdfaa45c70956a
|
||||
SIZE (lcn2-calc-v2.12.9.0_GH0.tar.gz) = 1134337
|
||||
|
|
50
math/calc/files/patch-help_Makefile
Normal file
50
math/calc/files/patch-help_Makefile
Normal file
|
@ -0,0 +1,50 @@
|
|||
Remove this patch at > 2.12.9.0
|
||||
|
||||
From a86d62998263a8d7fa76cd89c59314b9aaf4b72e Mon Sep 17 00:00:00 2001
|
||||
From: Landon Curt Noll <github-mail@asthe.com>
|
||||
Date: Fri, 12 Mar 2021 11:31:21 -0800
|
||||
Subject: [PATCH] Fixed a typo in help/Makefile
|
||||
|
||||
Fixed a typo typo in help/Makefile that caused the build of
|
||||
2.12.9.0 to fail in a number of cases. Thanks to a report by
|
||||
<GitHub user balducci>.
|
||||
diff --git a/help/Makefile b/help/Makefile
|
||||
index eb48305..c40bf3d 100644
|
||||
--- help/Makefile
|
||||
+++ help/Makefile
|
||||
@@ -252,7 +252,7 @@ BLT_HELP_FILES_13= bugs changes
|
||||
|
||||
STD_HELP_FILES_14= credit
|
||||
|
||||
-BLT_HELP_FILES_14= contrib COPYING COPYING-LGPL question
|
||||
+BLT_HELP_FILES_14= contrib COPYING COPYING-LGPL questions
|
||||
|
||||
STD_HELP_FILES_15= wishlist todo
|
||||
|
||||
@@ -536,7 +536,7 @@ COPYING-LGPL: ../COPYING-LGPL
|
||||
${TRUE}; \
|
||||
fi
|
||||
|
||||
-question: ../QUESTIONS
|
||||
+questions: ../QUESTIONS
|
||||
${RM} -f $@
|
||||
${CP} ../QUESTIONS $@
|
||||
${CHMOD} 0444 $@
|
||||
@@ -705,7 +705,7 @@ detail_help_list:
|
||||
! -name mat ! -name obj.file ! -name operator \
|
||||
! -name overview ! -name script ! -name statement \
|
||||
! -name todo ! -name types ! -name unexpected \
|
||||
- ! -name variable ! -name wishlist ! -name question \
|
||||
+ ! -name variable ! -name wishlist ! -name questions \
|
||||
-print | \
|
||||
while read i; do \
|
||||
if [ X"$$i" != X"/dev/null" ]; then \
|
||||
@@ -740,7 +740,7 @@ echo_inst_files:
|
||||
|
||||
clean:
|
||||
${RM} -f obj mkbuiltin funclist.c funclist.o funclist${EXT}
|
||||
- ${RM} -f COPYING COPYING-LGPL question
|
||||
+ ${RM} -f COPYING COPYING-LGPL questions
|
||||
|
||||
clobber: clean
|
||||
${RM} -f ${BLT_HELP_FILES} full .all calc
|
|
@ -2,10 +2,12 @@ bin/calc
|
|||
%%FULL%%include/calc/align32.h
|
||||
%%FULL%%include/calc/alloc.h
|
||||
%%FULL%%include/calc/args.h
|
||||
%%FULL%%include/calc/banned.h
|
||||
%%FULL%%include/calc/blkcpy.h
|
||||
%%FULL%%include/calc/block.h
|
||||
%%FULL%%include/calc/byteswap.h
|
||||
%%FULL%%include/calc/calc.h
|
||||
%%FULL%%include/calc/calcerr.c
|
||||
%%FULL%%include/calc/calcerr.h
|
||||
%%FULL%%include/calc/cmath.h
|
||||
%%FULL%%include/calc/conf.h
|
||||
|
@ -17,6 +19,7 @@ bin/calc
|
|||
%%FULL%%include/calc/fposval.h
|
||||
%%FULL%%include/calc/func.h
|
||||
%%FULL%%include/calc/hash.h
|
||||
%%FULL%%include/calc/have_ban_pragma.h
|
||||
%%FULL%%include/calc/have_const.h
|
||||
%%FULL%%include/calc/have_fpos.h
|
||||
%%FULL%%include/calc/have_fpos_pos.h
|
||||
|
@ -31,6 +34,8 @@ bin/calc
|
|||
%%FULL%%include/calc/have_rusage.h
|
||||
%%FULL%%include/calc/have_stdlib.h
|
||||
%%FULL%%include/calc/have_strdup.h
|
||||
%%FULL%%include/calc/have_strlcat.h
|
||||
%%FULL%%include/calc/have_strlcpy.h
|
||||
%%FULL%%include/calc/have_string.h
|
||||
%%FULL%%include/calc/have_times.h
|
||||
%%FULL%%include/calc/have_uid_t.h
|
||||
|
@ -50,6 +55,7 @@ bin/calc
|
|||
%%FULL%%include/calc/qmath.h
|
||||
%%FULL%%include/calc/sha1.h
|
||||
%%FULL%%include/calc/str.h
|
||||
%%FULL%%include/calc/strl.h
|
||||
%%FULL%%include/calc/symbol.h
|
||||
%%FULL%%include/calc/terminal.h
|
||||
%%FULL%%include/calc/token.h
|
||||
|
@ -365,7 +371,7 @@ man/man1/calc.1.gz
|
|||
%%HELP%%%%DATADIR%%/help/ptest
|
||||
%%HELP%%%%DATADIR%%/help/push
|
||||
%%HELP%%%%DATADIR%%/help/putenv
|
||||
%%HELP%%%%DATADIR%%/help/question
|
||||
%%HELP%%%%DATADIR%%/help/questions
|
||||
%%HELP%%%%DATADIR%%/help/quo
|
||||
%%HELP%%%%DATADIR%%/help/quomod
|
||||
%%HELP%%%%DATADIR%%/help/rand
|
||||
|
|
Loading…
Reference in a new issue