Upgrade Apache OpenOffice to version 4.1.0.

Fix all portlint -a and check-plist errors and warnings.

Fix all but one stage-qa warnings.

Disable --with-system-boost because it broke the build.

Enable the --with-system-graphite, --with-system-hyphen, and
--with-system-nss configure options.

Add all distfiles that were previously downloaded during
built to the ext_sources distfile.  Add the --disable-fetch-external
configure flag to disable downloads during build.

PR:		192258
Approved by:	office@ (bapt)
This commit is contained in:
Don Lewis 2014-08-05 16:34:47 +00:00
parent fd9fadce4f
commit e110bb96bc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=364119
12 changed files with 366 additions and 291 deletions

View file

@ -2,30 +2,88 @@
# $FreeBSD$
PORTNAME= apache-openoffice
PORTVERSION= 4.0.1
PORTREVISION= 4
PORTVERSION= 4.1.0
CATEGORIES= editors java
MASTER_SITES= http://www.apache.org/dist/openoffice/${PORTVERSION}/source/ \
ftp://ftp.riken.jp/net/apache/openoffice/${PORTVERSION}/source/ \
${MASTER_SITE_LOCAL:S@%SUBDIR%@maho/openoffice@}:extsrc
DISTFILES+= ${OOOSRC} unowinreg.dll ${EXTSRC}:extsrc
MASTER_SITES= ${MASTER_SITE_APACHE:S@%SUBDIR%@openoffice/${PORTVERSION}/source@} \
${MASTER_SITE_LOCAL:S@%SUBDIR%@truckman/openoffice@}:extsrc
.if defined(LANG_PKGNAME)
PKGNAMEPREFIX= ${LANG_PKGNAME}-
.endif
.if defined(LANG_SUFFIX)
PKGNAMESUFFIX= -${LANG_SUFFIX}
.endif
DISTFILES= ${OOOSRC} unowinreg.dll ${EXTSRC}:extsrc
EXTRACT_ONLY= ${OOOSRC} ${EXTSRC}
MAINTAINER= office@FreeBSD.org
#de facto maintainer is maho@FreeBSD.org
#Frequent Patch submitters should optionally sign Apache iCLA
MAINTAINER= office@FreeBSD.org
COMMENT= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
LICENSE= APACHE20
BUILD_DEPENDS= \
p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip \
${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
zip:${PORTSDIR}/archivers/zip \
ant:${PORTSDIR}/devel/apache-ant \
dmake:${PORTSDIR}/devel/dmake \
epm:${PORTSDIR}/devel/epm \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
imake:${PORTSDIR}/devel/imake \
gpatch:${PORTSDIR}/devel/patch \
${LOCALBASE}/bin/vigra-config:${PORTSDIR}/graphics/vigra \
${JAVALIBDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
${JAVALIBDIR}/commons-lang.jar:${PORTSDIR}/java/jakarta-commons-lang \
${JAVALIBDIR}/junit.jar:${PORTSDIR}/java/junit \
${JAVALIBDIR}/bsh.jar:${PORTSDIR}/lang/bsh \
bash:${PORTSDIR}/shells/bash \
${JAVALIBDIR}/saxon9.jar:${PORTSDIR}/textproc/saxon-devel \
${JAVALIBDIR}/lucene-core-3.6.2.jar:${PORTSDIR}/textproc/lucene \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
# mdds>=0.9.0:${PORTSDIR}/devel/mdds
LIB_DEPENDS= \
libapr-1.so:${PORTSDIR}/devel/apr1 \
libcurl.so:${PORTSDIR}/ftp/curl \
libcairo.so:${PORTSDIR}/graphics/cairo \
libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib \
libgraphite.so:${PORTSDIR}/graphics/silgraphite \
libCoinMP.so:${PORTSDIR}/math/coinmp \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libnss3.so:${PORTSDIR}/security/nss \
libexpat.so:${PORTSDIR}/textproc/expat2 \
libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell \
libtextcat.so:${PORTSDIR}/textproc/libtextcat \
libhyphen.so:${PORTSDIR}/textproc/hyphen \
librdf.so:${PORTSDIR}/textproc/redland \
libserf-1.so:${PORTSDIR}/www/serf
# libjpeg.so:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
${JAVALIBDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
${JAVALIBDIR}/bsh.jar:${PORTSDIR}/lang/bsh \
${JAVALIBDIR}/saxon9.jar:${PORTSDIR}/textproc/saxon-devel \
${LOCALBASE}/lib/X11/fonts/ChromeOS/Arimo-Bold.ttf:${PORTSDIR}/x11-fonts/croscorefonts-fonts-ttf
SVNREVISION= 1589052
OOOSRC= apache-openoffice-${PORTVERSION}-r${SVNREVISION}-src${EXTRACT_SUFX}
EXTSRC= ApacheOpenOffice.ext_sources.${PORTVERSION}.r${SVNREVISION}_1${EXTRACT_SUFX}
OOODIR= openoffice4
INSTALLATION_BASEDIR?= openoffice-${PORTVERSION}
EXECBASE?= openoffice-${PORTVERSION}
DIST_SUBDIR= openoffice
SIMPLEOSVER= ${OSREL:C/\.//g}
NO_LATEST_LINK= yes
ONLY_FOR_ARCHS= i386 amd64
USE_GNOME= gtk20 libxslt libidl glib20
USE_XORG= x11 ice xaw xau xext xrender xrandr \
xi xt xcursor xdamage xcomposite xfixes
USE_GL= gl glu
USE_GSTREAMER= yes
USE_GCC= any
USE_GCC= yes
USE_PYTHON= yes
USES+= bison perl5 gmake pkgconfig tar:bzip2 desktop-file-utils
USE_PERL5= build
@ -37,22 +95,22 @@ OPTIONS_DEFAULT=GCONF GNOMEVFS
GNOMEVFS_DESC= Enable GNOME Virtual File System
CCACHE_DESC= Mimimize compile time of C/C++ programs
.include "${.CURDIR}/files/Makefile.localized"
USE_JAVA= yes
JAVA_BUILD= jdk
JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6+
GCONF_USE= GNOME=gconf2
GCONF_CONFIGURE_OFF=--disable-gconf
GNOMEVFS_USE= GNOME=gnomevfs2
GNOMEVFS_CONFIGURE_OFF=--disable-gnome-vfs
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
ONLY_FOR_ARCHS= i386 amd64
.include <${FILESDIR}/Makefile.localized>
USE_JAVA= yes
JAVA_BUILD= jdk
JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6+
.if ${ARCH} == amd64
FREEBSD_ENV_SET= FreeBSDAMDEnv.Set.sh
@ -60,36 +118,16 @@ FREEBSD_ENV_SET= FreeBSDAMDEnv.Set.sh
FREEBSD_ENV_SET= FreeBSDX86Env.Set.sh
.endif
OOOSRC= apache-openoffice-${PORTVERSION}-r${SVNREVISION}-src${EXTRACT_SUFX}
EXTSRC= ApacheOpenOffice.ext_sources.${PORTVERSION}.r${SVNREVISION}${EXTRACT_SUFX}
OOODIR= openoffice4
SVNREVISION= 1524958
INSTALLATION_BASEDIR?= openoffice-${PORTVERSION}
EXECBASE?= openoffice-${PORTVERSION}
DIST_SUBDIR= openoffice
SIMPLEOSVER= ${OSREL:C/\.//g}
LOCALIZED_LANG?= en-US
PACKAGE_PREFIX= Apache_OpenOffice
.if ${ARCH} == amd64
PACKAGE_MIDDLE= ${PORTVERSION}_${OPSYS}_x86-64
.else
PACKAGE_MIDDLE= ${PORTVERSION}_${OPSYS}_x86
.endif
LOCALIZED_LANG?= en-US
.if defined(LANG_PKGNAME)
PKGNAMEPREFIX= ${LANG_PKGNAME}-
.endif
.if defined(LANG_SUFFIX)
PKGNAMESUFFIX= -${LANG_SUFFIX}
.endif
RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
${JAVALIBDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
${JAVALIBDIR}/bsh.jar:${PORTSDIR}/lang/bsh \
${JAVALIBDIR}/saxon9.jar:${PORTSDIR}/textproc/saxon-devel \
${LOCALBASE}/lib/X11/fonts/ChromeOS/Arimo-Bold.ttf:${PORTSDIR}/x11-fonts/croscorefonts-fonts-ttf
.if ${PORT_OPTIONS:MCCACHE} || defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
CCACHE_PREFIX= ccache
@ -100,43 +138,7 @@ OOOCC= ${CC}
OOOCXX= ${CXX}
.endif
CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
PATH=${WRKSRC}/solenv/bin:$$PATH \
CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
libexpat.so:${PORTSDIR}/textproc/expat2 \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libcurl.so:${PORTSDIR}/ftp/curl \
libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell \
libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib \
librdf.so:${PORTSDIR}/textproc/redland \
libtextcat.so:${PORTSDIR}/textproc/libtextcat \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libapr-1.so:${PORTSDIR}/devel/apr1 \
libCoinMP.so:${PORTSDIR}/math/coinmp \
libserf-1.so:${PORTSDIR}/www/serf \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libtextcat.so:${PORTSDIR}/textproc/libtextcat
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
gpatch:${PORTSDIR}/devel/patch \
p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip \
bash:${PORTSDIR}/shells/bash \
imake:${PORTSDIR}/devel/imake \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
ant:${PORTSDIR}/devel/apache-ant \
${LOCALBASE}/lib/libboost_regex.a:${PORTSDIR}/devel/boost-libs \
${LOCALBASE}/bin/vigra-config:${PORTSDIR}/graphics/vigra \
${JAVALIBDIR}/junit.jar:${PORTSDIR}/java/junit \
${JAVALIBDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
${JAVALIBDIR}/commons-lang.jar:${PORTSDIR}/java/jakarta-commons-lang \
${JAVALIBDIR}/lucene-core-3.6.2.jar:${PORTSDIR}/textproc/lucene \
${JAVALIBDIR}/bsh.jar:${PORTSDIR}/lang/bsh \
${JAVALIBDIR}/saxon9.jar:${PORTSDIR}/textproc/saxon-devel \
epm:${PORTSDIR}/devel/epm \
dmake:${PORTSDIR}/devel/dmake \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
PATH=${WRKSRC}/solenv/bin:$$PATH
USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
@ -149,59 +151,59 @@ SUB_LIST= EXECBASE=${EXECBASE} OOOTAG=${OOOTAG} OOODIR=${OOODIR}
MAKE_JOBS_NUMBER= 4
.endif
CONFIGURE_ARGS+= --enable-verbose \
--enable-symbols=small \
--enable-crashdump \
--with-vendor="FreeBSD ports system" \
--with-epm=${LOCALBASE}/bin/epm \
--with-gnu-patch=${LOCALBASE}/bin/gpatch \
--with-gperf=${LOCALBASE}/bin/gperf \
--x-includes=${LOCALBASE}/include \
--x-libraries=${LOCALBASE}lib \
--with-system-libxml \
--with-system-libxslt \
--with-system-cairo --enable-cairo \
--with-system-boost \
--with-system-zlib \
--with-system-python \
--with-system-expat \
--with-system-openssl \
--with-system-curl \
--with-system-poppler \
--with-system-redland \
--with-system-libtextcat \
--with-system-vigra \
--with-system-stdlibs \
--with-system-apr \
--with-system-apr-util \
--with-system-coinmp \
--with-system-apache-commons=yes \
CONFIGURE_ARGS+= --with-system-apache-commons=yes \
--with-commons-codec-jar=${JAVALIBDIR}/commons-codec.jar \
--with-commons-lang-jar=${JAVALIBDIR}/commons-lang.jar \
--with-commons-lang-jar=${JAVALIBDIR}/commons-lang.jar \
--with-commons-httpclient-jar=${JAVALIBDIR}/commons-httpclient.jar \
--with-commons-logging-jar=${JAVALIBDIR}/commons-logging.jar \
--with-system-lucene \
--with-lucene-core-jar=${JAVALIBDIR}/lucene-core-3.6.2.jar \
--with-lucene-analyzers-jar=${JAVALIBDIR}/lucene-analyzers-3.6.2.jar \
--with-commons-logging-jar=${JAVALIBDIR}/commons-logging.jar \
--with-system-apr \
--with-system-apr-util \
--with-system-beanshell \
--with-beanshell-jar=${JAVALIBDIR}/bsh.jar \
--enable-category-b \
--with-system-cairo --enable-cairo \
--with-system-coinmp \
--with-system-curl \
--enable-crashdump \
--enable-dbus \
--with-epm=${LOCALBASE}/bin/epm \
--with-system-expat \
--disable-fetch-external \
--without-fonts \
--with-gnu-patch=${LOCALBASE}/bin/gpatch \
--with-gperf=${LOCALBASE}/bin/gperf \
--enable-gstreamer \
--with-system-graphite \
--with-system-hunspell \
--with-system-hyphen \
--with-junit=${LOCALBASE}/share/java/classes/junit.jar \
--with-package-format="archive" \
--enable-gstreamer \
--enable-wiki-publisher \
--enable-dbus \
--enable-opengl \
--enable-category-b \
--enable-lockdown \
--with-system-hunspell \
--with-system-saxon \
--with-saxon-jar=${JAVALIBDIR}/saxon9.jar \
--with-system-beanshell \
--with-beanshell-jar=${JAVALIBDIR}/bsh.jar \
--without-fonts \
--with-system-serf
# --with-system-jpeg
# --enable-pdfimport
# --without-stlport --disable-mozilla \
# --with-system-graphite \
--with-system-libtextcat \
--with-system-libxml \
--with-system-libxslt \
--enable-lockdown \
--with-system-lucene \
--with-lucene-core-jar=${JAVALIBDIR}/lucene-core-3.6.2.jar \
--with-lucene-analyzers-jar=${JAVALIBDIR}/lucene-analyzers-3.6.2.jar \
--with-system-nss \
--enable-opengl \
--with-system-openssl \
--with-package-format="archive" \
--with-system-poppler \
--with-system-python \
--with-system-redland \
--with-system-saxon \
--with-saxon-jar=${JAVALIBDIR}/saxon9.jar \
--with-system-serf \
--with-system-stdlibs \
--enable-symbols=small \
--without-stlport \
--with-vendor="FreeBSD ports system" \
--enable-verbose \
--with-system-vigra \
--enable-wiki-publisher \
--x-includes={LOCALBASE}/include \
--x-libraries=${LOCALBASE}lib \
--with-system-zlib
#OOOEXTENSIONS+= minimizer/presentation-minimizer.oxt
#OOOEXTENSIONS+= presenter/presenter-screen.oxt
@ -232,10 +234,6 @@ pre-everything::
post-extract:
@${CP} ${DISTDIR}/${DIST_SUBDIR}/unowinreg.dll ${WRKSRC}/external/unowinreg/
# @${MKDIR} ${WRKSRC}/../ext_sources
# @${MV} ${WRKDIR}/aoo/ext_sources/* ${WRKSRC}/../ext_sources/
# @${RM} -rf ${WRKSRC}/l10n
@${MKDIR} ${WRKSRC}/../ext_sources
@${RM} -rf ${WRKSRC}/l10n
post-patch:
@ -270,9 +268,13 @@ do-install:
@${REINPLACE_CMD} -e 's/^UserInstallation.*$$/USERINSTALLATION/' ${STAGEDIR}${PREFIX}/${INSTALLATION_BASEDIR}/${OOODIR}/program/bootstraprc
@${REINPLACE_CMD} -e 's/USERINSTALLATION/UserInstallation=$$SYSUSERCONFIG\/\.openoffice\.org-devel\/4/' ${STAGEDIR}${PREFIX}/${INSTALLATION_BASEDIR}/openoffice4/program/bootstraprc
@${MKDIR} ${STAGEDIR}${PREFIX}/${INSTALLATION_BASEDIR}/extensions/
@cd ${WRKSRC}/solver/4??/unxfbsd?.pro/bin/ ; ${INSTALL_DATA} ${OOOEXTENSIONS} ${STAGEDIR}${PREFIX}/${INSTALLATION_BASEDIR}/extensions/
@cd ${WRKSRC}/solver/4?0/unxfbsd?.pro/bin/ ; ${INSTALL_DATA} ${OOOEXTENSIONS} ${STAGEDIR}${PREFIX}/${INSTALLATION_BASEDIR}/extensions/
post-install:
@${FIND} ${STAGEDIR}${PREFIX}/${INSTALLATION_BASEDIR}/openoffice4/program -type f \( -name '*.so*' -or -name '*.bin' \) -print0 | ${XARGS} -0 -n1 ${STRIP_CMD}
@for prog in crashrep pagein uri-encode javaldx regmerge regview; do \
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${INSTALLATION_BASEDIR}/openoffice4/program/$${prog}; \
done
@${FIND} ${STAGEDIR}${PREFIX}/${INSTALLATION_BASEDIR} -type d -exec ${CHMOD} 755 {} \;
@${ECHO_MSG} "===> Add wrapper scripts";
@${CP} ${FILESDIR}/openoffice-wrapper ${WRKDIR}/
@ -295,8 +297,6 @@ post-install:
@${ECHO_CMD} "share/licenses/${PKGNAME}/catalog.mk" >> ${TMPPLIST}
@${ECHO_CMD} "share/licenses/${PKGNAME}/LICENSE" >> ${TMPPLIST}
@${ECHO_CMD} "share/licenses/${PKGNAME}/APACHE20" >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm share/licenses/${PKGNAME}" >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm share/licenses" >> ${TMPPLIST}
@cd ${STAGEDIR}${PREFIX} ; ${FIND} -s bin \( -type f -or -type l \) -name "${EXECBASE}*" >> ${TMPPLIST}
@cd ${STAGEDIR}${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} \( -type f -or -type l \) >> ${TMPPLIST}
@cd ${STAGEDIR}${PREFIX} ; ${FIND} ${INSTALLATION_BASEDIR} -type d | ${SORT} -r | \
@ -338,4 +338,5 @@ post-install:
@${ECHO_CMD} "@unexec ${PREFIX}/bin/gtk-update-icon-cache -q -f %D/share/icons/hicolor 2>/dev/null || ${TRUE}" >> ${TMPPLIST}
.include <${FILESDIR}/Makefile.others>
.include <bsd.port.post.mk>

View file

@ -1,6 +1,6 @@
SHA256 (openoffice/apache-openoffice-4.0.1-r1524958-src.tar.bz2) = 577862db1934754e56475b4c124a303a8825cbaefef5ede570c2aee7c99b0667
SIZE (openoffice/apache-openoffice-4.0.1-r1524958-src.tar.bz2) = 214506399
SHA256 (openoffice/apache-openoffice-4.1.0-r1589052-src.tar.bz2) = f73d01082fe52cc04dc91c4a53d9c8c27b551c0561b8e51ed14b1bfee8fa783e
SIZE (openoffice/apache-openoffice-4.1.0-r1589052-src.tar.bz2) = 217686497
SHA256 (openoffice/ApacheOpenOffice.ext_sources.4.1.0.r1589052_1.tar.bz2) = ce261cc499f54a61f3b0f06e0f86eedc6fa477deb2ada25f6ca3f0e7f05400b5
SIZE (openoffice/ApacheOpenOffice.ext_sources.4.1.0.r1589052_1.tar.bz2) = 128368053
SHA256 (openoffice/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
SIZE (openoffice/unowinreg.dll) = 6144
SHA256 (openoffice/ApacheOpenOffice.ext_sources.4.0.1.r1524958.tar.bz2) = 0c77c1edd0641336d839f27424f89808c61cf9cfeefba4f5e015c4cf2685a63c
SIZE (openoffice/ApacheOpenOffice.ext_sources.4.0.1.r1524958.tar.bz2) = 137466799

View file

@ -1,13 +0,0 @@
$FreeBSD$
--- lingucomponent/source/languageguessing/simpleguesser.cxx.orig 2012-01-10 19:42:30.000000000 +0900
+++ lingucomponent/source/languageguessing/simpleguesser.cxx 2012-08-07 11:14:45.000000000 +0900
@@ -114,7 +114,7 @@
if(!h){return guesses;}
//calculate le number of unicode charcters (symbols)
- int len = utfstrlen(text);
+ int len = strlen(text);
if( len > MAX_STRING_LENGTH_TO_ANALYSE ){len = MAX_STRING_LENGTH_TO_ANALYSE ;}

View file

@ -1,19 +0,0 @@
--- configmgr/source/partial.hxx
+++ configmgr/source/partial.hxx
@@ -26,6 +26,7 @@
#include "sal/config.h"
+#include <boost/functional/hash.hpp>
#include <boost/unordered_map.hpp> // using the boost container because it explicitly allows recursive types
#include <set>
@@ -50,7 +51,7 @@ public:
private:
struct Node {
- typedef boost::unordered_map< rtl::OUString, Node > Children;
+ typedef boost::unordered_map< rtl::OUString, Node, rtl::OUStringHash > Children;
Node(): startInclude(false) {}
void clear() { startInclude=false; children.clear(); }

View file

@ -1,11 +0,0 @@
--- offapi/com/sun/star/awt/grid/XMutableGridDataModel.idl 2013/08/12 08:53:46 1513085
+++ offapi/com/sun/star/awt/grid/XMutableGridDataModel.idl 2013/08/12 09:41:11 1513086
@@ -122,7 +122,7 @@
<p>The change in the data model will be notified to registered listeners via
<member">XGridDataListener::dataChanged</member>. The <member>GridDataEvent::FirstColumn</member> and
<member>GridDataEvent::LastColumn</member> will denote the smallest respectively largest column
- index from <argColumnIndexes</arg>.</p>
+ index from <arg>ColumnIndexes</arg>.</p>
@param ColumnIndexes
contains the column indexes of the cells, which should be updated

View file

@ -1,73 +0,0 @@
--- moz/makefile.mk.orig 2013-08-13 11:49:32.000000000 +0000
+++ moz/makefile.mk 2014-01-01 20:09:17.000000000 +0000
@@ -99,7 +99,8 @@
patches/respect_disable_pango.patch \
patches/arm_build_fix.patch \
patches/link_fontconfig.patch \
- patches/brokenmakefile.patch
+ patches/brokenmakefile.patch \
+ patches/freetype_header_relocation.patch
.IF "$(OS)"=="LINUX"
PATCH_FILES+=patches/nss_linux.patch
--- moz/patches/freetype_header_relocation.patch.orig 1970-01-01 00:00:00.000000000 +0000
+++ moz/patches/freetype_header_relocation.patch 2014-01-01 20:50:11.000000000 +0000
@@ -0,0 +1,58 @@
+--- misc/build/mozilla/config/system-headers.orig 2007-11-19 21:36:18.000000000 +0100
++++ misc/build/mozilla/config/system-headers 2014-01-01 20:47:56.000000000 +0100
+@@ -193,12 +193,12 @@
+ fpieee.h
+ frame/log.h
+ frame/req.h
+-freetype/freetype.h
+-freetype/ftcache.h
+-freetype/ftglyph.h
+-freetype/ftoutln.h
+-freetype/ttnameid.h
+-freetype/tttables.h
++freetype.h
++ftcache.h
++ftglyph.h
++ftoutln.h
++ttnameid.h
++tttables.h
+ fribidi/fribidi.h
+ FSp_fopen.h
+ fstream.h
+--- misc/build/mozilla/gfx/src/gtk/nsFontMetricsXft.cpp.orig 2008-01-29 19:31:08.000000000 +0000
++++ misc/build/mozilla/gfx/src/gtk/nsFontMetricsXft.cpp 2014-01-01 20:43:42.000000000 +0000
+@@ -67,8 +67,8 @@
+ #include "nsFontConfigUtils.h"
+
+ #include <gdk/gdkx.h>
+-#include <freetype/tttables.h>
+-#include <freetype/freetype.h>
++#include <tttables.h>
++#include <freetype.h>
+
+ #define FORCE_PR_LOG
+ #include "prlog.h"
+--- misc/build/mozilla/gfx/src/gtk/nsFontMetricsPango.cpp.orig 2008-01-29 19:31:08.000000000 +0000
++++ misc/build/mozilla/gfx/src/gtk/nsFontMetricsPango.cpp 2014-01-01 20:44:06.000000000 +0000
+@@ -58,7 +58,7 @@
+ #include <fontconfig/fontconfig.h>
+ #include <gdk/gdk.h>
+ #include <gdk/gdkx.h>
+-#include <freetype/tttables.h>
++#include <tttables.h>
+
+ #include "mozilla-decoder.h"
+
+--- misc/build/mozilla/gfx/src/cairo/nsFontMetricsXft.cpp.orig 2008-01-29 19:31:08.000000000 +0000
++++ misc/build/mozilla/gfx/src/cairo/nsFontMetricsXft.cpp 2014-01-01 20:44:34.000000000 +0000
+@@ -67,8 +67,8 @@
+ #include "nsFontConfigUtils.h"
+
+ #include <gdk/gdkx.h>
+-#include <freetype/tttables.h>
+-#include <freetype/freetype.h>
++#include <tttables.h>
++#include <freetype.h>
+
+ #define FORCE_PR_LOG
+ #include "prlog.h"

View file

@ -0,0 +1,43 @@
--- set_soenv.in~ 2014-01-22 15:21:04.000000000 +0900
+++ set_soenv.in 2014-02-03 12:12:03.000000000 +0900
@@ -1864,6 +1864,8 @@
ToFile( "SYSTEM_STDLIBS", "@SYSTEM_STDLIBS@", "e" );
ToFile( "SYSTEM_ZLIB", "@SYSTEM_ZLIB@", "e" );
ToFile( "SYSTEM_NSS", "@SYSTEM_NSS@", "e" );
+ToFile( "NSS_CFLAGS", "@NSS_CFLAGS@", "e" );
+ToFile( "NSS_LIBS", "@NSS_LIBS@", "e" );
ToFile( "SYSTEM_OPENSSL", "@SYSTEM_OPENSSL@", "e" );
ToFile( "OPENSSL_CFLAGS", "@OPENSSL_CFLAGS@", "e" );
ToFile( "OPENSSL_LIBS", "@OPENSSL_LIBS@", "e" );
--- xmlsecurity/util/makefile.mk 2014-02-03 15:50:50.000000000 +0900
+++ xmlsecurity/util/makefile.mk 2014-02-03 16:03:11.000000000 +0900
@@ -98,12 +98,12 @@
SHL2STDLIBS +=-ldl
.ENDIF
-.IF "$(ENABLE_NSS_MODULE)"=="YES" && "$(SYSTEM_NSS)"!="YES"
+.IF "$(ENABLE_NSS_MODULE)"=="YES" && "$(SYSTEM_NSS)"=="YES"
.IF "$(NSPR_LIB)" != ""
SHL2STDLIBS += $(NSPR_LIB)
.ENDIF
-.IF "$(NSS_LIB)" != ""
-SHL2STDLIBS += $(NSS_LIB)
+.IF "$(NSS_LIBS)" != ""
+SHL2STDLIBS += $(NSS_LIBS)
.ENDIF
.ENDIF
--- xmlsecurity/source/xmlsec/nss/makefile.mk 2014-01-22 15:07:16.000000000 +0900
+++ xmlsecurity/source/xmlsec/nss/makefile.mk 2014-02-03 16:13:30.000000000 +0900
@@ -48,8 +48,8 @@
NSPR_INC = $(MOZ_INC)$/nspr
.ELSE
# TODO: better use pkgconfig to find the proper system include path
-NSS_INC = /usr/include/nss3
-NSPR_INC = /usr/include/nspr4
+NSS_INC = $(NSS_CFLAGS)
+NSPR_INC = $(NSS_CFLAGS)
.ENDIF
.IF "$(GUI)" == "WNT"

View file

@ -1,27 +0,0 @@
--- nss/makefile.mk.orig 2013-08-13 11:46:06.000000000 +0000
+++ nss/makefile.mk 2014-01-01 18:13:26.000000000 +0000
@@ -44,6 +44,10 @@
TARFILE_ROOTDIR=nss-3.12.6
PATCH_FILES=nss.patch
+.IF "$(OS)"=="FREEBSD"
+PATCH_FILES+=nss_freebsd.patch
+.ENDIF # "$(OS)"=="FREEBSD"
+
.IF "$(OS)"=="MACOSX"
MACOS_SDK_DIR=/Developer/SDKs/MacOSX10.4u.sdk
.EXPORT : MACOS_SDK_DIR
--- nss/nss_freebsd.patch.orig 1970-01-01 00:00:00.000000000 +0000
+++ nss/nss_freebsd.patch 2014-01-01 18:08:20.000000000 +0000
@@ -0,0 +1,11 @@
+--- misc/build/nss-3.12.6/mozilla/security/coreconf/FreeBSD.mk.orig 2009-08-22 05:33:09.000000000 +0000
++++ misc/build/nss-3.12.6/mozilla/security/coreconf/FreeBSD.mk 2014-01-01 13:47:48.000000000 +0000
+@@ -38,7 +38,7 @@
+ include $(CORE_DEPTH)/coreconf/UNIX.mk
+
+ DEFAULT_COMPILER = gcc
+-CC = gcc
++#CC = gcc
+ CCC = g++
+ RANLIB = ranlib
+

View file

@ -0,0 +1,53 @@
--- sal/inc/rtl/string.hxx 2014-01-24 03:32:49.000000000 +0900
+++ sal/inc/rtl/string.hxx 2014-02-04 14:57:30.000000000 +0900
@@ -234,8 +234,9 @@
@return a pointer to a (not necessarily null-terminated) byte string
representing the characters of this string object.
*/
- operator const sal_Char *() const SAL_THROW(()) { return pData->buffer; }
+
public:
+ operator const sal_Char *() const SAL_THROW(()) { return pData->buffer; }
/** Returns a reference to a character of this string. */
sal_Char& operator[]( int n ) { return pData->buffer[n]; }
/** Returns a const reference to a character of this string. */
build -- version: 275224
=============
Building module canvas
=============
Entering /work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/inc
Entering /work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/factory
Entering /work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/tools
Entering /work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/null
Entering /work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/vcl
Entering /work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/cairo
Compiling: canvas/source/cairo/cairo_textlayout.cxx
g++46 -fmessage-length=0 -c -O2 -fno-strict-aliasing -DENABLE_LAYOUT=0 -DENABLE_LAYOUT_EXPERIMENTAL=0 -I/usr/local/include/cairo -I/usr/local/include/glib-2.0 -I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/freetype2 -I. -I../../unxfbsdx.pro/inc/cairocanvas -I../inc -I../../inc/pch -I../../inc -I../../unx/inc -I../../unxfbsdx.pro/inc -I. -I/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/solver/410/unxfbsdx.pro/inc/stl -I/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/solver/410/unxfbsdx.pro/inc/external -I/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/solver/410/unxfbsdx.pro/inc -I/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/solenv/unxfbsdx/inc -I/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/solenv/inc -I/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/res -I/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/solenv/inc/Xp31 -I/usr/local/openjdk6/include -I/usr/local/openjdk6/include/freebsd -I/usr/local/openjdk6/include/bsd -I/usr/local/openjdk6/include/linux -I/usr/local/openjdk6/include/native_threads/include -I/usr/local/include -I/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/solver/410/unxfbsdx.pro/inc/offuh -I. -I../../res -I. -pipe -Wl,-rpath=/usr/local/lib/gcc46 -fvisibility-inlines-hidden -g1 -Wall -Wextra -Wendif-labels -Wshadow -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -fpic -DFREEBSD -DUNX -DVCL -DGCC -DC341 -DX86_64 -DX86_64 -D_PTHREADS -D_REENTRANT -DNEW_SOLAR -D_USE_NAMESPACE=1 -DSTLPORT_VERSION=450 -DHAVE_GCC_VISIBILITY_FEATURE -D__DMAKE -DUNIX -DCPPU_ENV=gcc3 -DGXX_INCLUDE_PATH=/usr/local/lib/gcc46/include/c++ -DSUPD=410 -DPRODUCT -DNDEBUG -DOSL_DEBUG_LEVEL=0 -DOPTIMIZE -DGUI -DSOLAR_JAVA -DVERBOSE -DSHAREDLIB -D_DLL_ -fexceptions -fno-enforce-eh-specs -DEXCEPTIONS_ON -o ../../unxfbsdx.pro/slo/cairo_textlayout.o /work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/cairo/cairo_textlayout.cxx
/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/solver/410/unxfbsdx.pro/inc/rtl/string.hxx: In member function 'void cairocanvas::TextLayout::useFont(cairo::Cairo*)':
/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/solver/410/unxfbsdx.pro/inc/rtl/string.hxx:237:5: error: 'rtl::OString::operator const sal_Char*() const' is private
/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/cairo/cairo_textlayout.cxx:315:157: error: within this context
/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/solver/410/unxfbsdx.pro/inc/rtl/string.hxx: In member function 'bool cairocanvas::TextLayout::draw(cairo::Cairo*)':
/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/solver/410/unxfbsdx.pro/inc/rtl/string.hxx:237:5: error: 'rtl::OString::operator const sal_Char*() const' is private
/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/cairo/cairo_textlayout.cxx:336:40: error: within this context
/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/cairo/cairo_textlayout.cxx: In member function 'bool cairocanvas::TextLayout::draw(cairo::SurfaceSharedPtr&, OutputDevice&, const Point&, const com::sun::star::rendering::ViewState&, const com::sun::star::rendering::RenderState&) const':
/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/cairo/cairo_textlayout.cxx:475:51: warning: declaration of 'aIter' shadows a previous local [-Wshadow]
/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/cairo/cairo_textlayout.cxx:415:47: warning: shadowed declaration is here [-Wshadow]
/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/cairo/cairo_textlayout.cxx:476:57: warning: declaration of 'aEnd' shadows a previous local [-Wshadow]
/work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/cairo/cairo_textlayout.cxx:416:53: warning: shadowed declaration is here [-Wshadow]
dmake: Error code 1, while making '../../unxfbsdx.pro/slo/cairo_textlayout.obj'
ERROR: error 65280 occurred while making /work/tinderbox-ligeti8amd64/portstrees/FreeBSD/ports/editors/openoffice-devel/work/aoo/main/canvas/source/cairo

View file

@ -1,11 +0,0 @@
--- vcl/source/glyphs/graphite_adaptors.cxx.orig 2013-08-13 11:45:43.000000000 +0000
+++ vcl/source/glyphs/graphite_adaptors.cxx 2013-12-31 16:39:41.000000000 +0000
@@ -45,7 +45,7 @@
#include <salgdi.hxx>
-#include <freetype/ftsynth.h>
+#include <ftsynth.h>
// Module
#include "gcach_ftyp.hxx"

View file

@ -0,0 +1,133 @@
--- ucb/source/ucp/webdav/SerfUri.hxx_ 2014-02-04 14:39:02.000000000 +0900
+++ ucb/source/ucp/webdav/SerfUri.hxx 2014-02-04 14:39:18.000000000 +0900
@@ -23,7 +23,7 @@
#ifndef INCLUDED_SERFURI_HXX
#define INCLUDED_SERFURI_HXX
-#include <apr-util/apr_uri.h>
+#include <apr_uri.h>
#include <rtl/ustring.hxx>
#include "DAVException.hxx"
--- ucb/source/ucp/webdav/SerfSession.cxx_ 2014-02-04 14:40:19.000000000 +0900
+++ ucb/source/ucp/webdav/SerfSession.cxx 2014-02-04 14:40:26.000000000 +0900
@@ -30,7 +30,7 @@
#include "ucbhelper/simplecertificatevalidationrequest.hxx"
#include "AprEnv.hxx"
-#include <apr/apr_strings.h>
+#include <apr_strings.h>
#include "DAVAuthListener.hxx"
#include "SerfTypes.hxx"
--- ucb/source/ucp/webdav/SerfTypes.hxx 2014-01-24 03:33:21.000000000 +0900
+++ ucb/source/ucp/webdav/SerfTypes.hxx 2014-02-04 14:38:44.000000000 +0900
@@ -24,7 +24,7 @@
#ifndef INCLUDED_SERFTYPES_HXX
#define INCLUDED_SERFTYPES_HXX
-#include <serf/serf.h>
+#include <serf.h>
typedef serf_connection_t SerfConnection;
--- ucb/source/ucp/webdav/SerfCallbacks.hxx.orig 2014-02-25 00:24:42.000000000 -0800
+++ ucb/source/ucp/webdav/SerfCallbacks.hxx 2014-07-28 01:11:38.000000000 -0700
@@ -23,7 +23,7 @@
#ifndef INCLUDED_CALLBACKS_HXX
#define INCLUDED_CALLBACKS_HXX
-#include <serf/serf.h>
+#include <serf.h>
extern "C" apr_status_t Serf_ConnectSetup( apr_socket_t *skt,
serf_bucket_t **read_bkt,
--- ucb/source/ucp/webdav/SerfCopyReqProcImpl.cxx.orig 2014-02-25 00:24:43.000000000 -0800
+++ ucb/source/ucp/webdav/SerfCopyReqProcImpl.cxx 2014-07-28 01:11:43.000000000 -0700
@@ -24,7 +24,7 @@
#include "SerfCopyReqProcImpl.hxx"
-#include <serf/serf.h>
+#include <serf.h>
namespace http_dav_ucp
{
--- ucb/source/ucp/webdav/SerfDeleteReqProcImpl.cxx.orig 2014-02-25 00:24:42.000000000 -0800
+++ ucb/source/ucp/webdav/SerfDeleteReqProcImpl.cxx 2014-07-28 01:11:47.000000000 -0700
@@ -24,7 +24,7 @@
#include "SerfDeleteReqProcImpl.hxx"
-#include <serf/serf.h>
+#include <serf.h>
namespace http_dav_ucp
{
--- ucb/source/ucp/webdav/SerfMkColReqProcImpl.cxx.orig 2014-02-25 00:24:43.000000000 -0800
+++ ucb/source/ucp/webdav/SerfMkColReqProcImpl.cxx 2014-07-28 01:11:51.000000000 -0700
@@ -24,7 +24,7 @@
#include "SerfMkColReqProcImpl.hxx"
-#include <serf/serf.h>
+#include <serf.h>
namespace http_dav_ucp
{
--- ucb/source/ucp/webdav/SerfMoveReqProcImpl.cxx.orig 2014-02-25 00:24:43.000000000 -0800
+++ ucb/source/ucp/webdav/SerfMoveReqProcImpl.cxx 2014-07-28 01:11:57.000000000 -0700
@@ -24,7 +24,7 @@
#include "SerfMoveReqProcImpl.hxx"
-#include <serf/serf.h>
+#include <serf.h>
namespace http_dav_ucp
{
--- ucb/source/ucp/webdav/SerfPostReqProcImpl.cxx.orig 2014-02-25 00:24:43.000000000 -0800
+++ ucb/source/ucp/webdav/SerfPostReqProcImpl.cxx 2014-07-28 01:12:00.000000000 -0700
@@ -24,7 +24,7 @@
#include "SerfPostReqProcImpl.hxx"
-#include <serf/serf.h>
+#include <serf.h>
using namespace com::sun::star;
--- ucb/source/ucp/webdav/SerfPutReqProcImpl.cxx.orig 2014-02-25 00:24:43.000000000 -0800
+++ ucb/source/ucp/webdav/SerfPutReqProcImpl.cxx 2014-07-28 01:12:05.000000000 -0700
@@ -26,7 +26,7 @@
#include "SerfPutReqProcImpl.hxx"
-#include <serf/serf.h>
+#include <serf.h>
namespace http_dav_ucp
{
--- ucb/source/ucp/webdav/SerfRequestProcessor.hxx.orig 2014-02-25 00:24:43.000000000 -0800
+++ ucb/source/ucp/webdav/SerfRequestProcessor.hxx 2014-07-28 01:12:10.000000000 -0700
@@ -26,7 +26,7 @@
#include <apr_errno.h>
#include <apr_pools.h>
-#include <serf/serf.h>
+#include <serf.h>
#include "DAVTypes.hxx"
#include "DAVResource.hxx"
--- ucb/source/ucp/webdav/SerfRequestProcessorImpl.hxx.orig 2014-02-25 00:24:42.000000000 -0800
+++ ucb/source/ucp/webdav/SerfRequestProcessorImpl.hxx 2014-07-28 01:12:14.000000000 -0700
@@ -22,7 +22,7 @@
#ifndef INCLUDED_SERFREQUESTPROCESSORIMPL_HXX
#define INCLUDED_SERFREQUESTPROCESSORIMPL_HXX
-#include <serf/serf.h>
+#include <serf.h>
#include <sal/types.h>
#include "DAVRequestEnvironment.hxx"

View file

@ -1 +0,0 @@
# Dummy file, do not delete. Package list is generated automatically.