- Update to snapshot r5576.
This snapshot has a significantly reworked build system (now GNU autoconf and automake) which makes this port much simpler. I've worked with the upstream authors to ensure this works on FreeBSD and have helped them to remove the dependence on gmake and the need for us to have local patches.
This commit is contained in:
parent
9d712428f5
commit
e127105094
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=231418
5 changed files with 625 additions and 556 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= kroc
|
||||
PORTVERSION= 1.5.r5519
|
||||
PORTVERSION= 1.5.r5576
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://ftp.i-scream.org/pub/kroc/ \
|
||||
ftp://ftp.i-scream.org/pub/kroc/
|
||||
|
@ -17,14 +17,12 @@ COMMENT= The Kent Retargettable occam-pi Compiler
|
|||
|
||||
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
|
||||
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
|
||||
|
||||
# Note to maintainer: remember to test with NOPORTDOCS and NOPORTEXAMPLES
|
||||
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GL= yes
|
||||
USE_MYSQL= yes
|
||||
USE_PYTHON= yes
|
||||
|
@ -32,76 +30,24 @@ USE_SDL= sdl sound
|
|||
USE_GNOME= libxslt
|
||||
USE_AUTOTOOLS= autoconf:262:env automake:110:env
|
||||
USE_XORG= xmu xi
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
MAN1= kmakef.1 kroc.1 mkoccdeps.1 occ21.1 occamdoc.1
|
||||
MAN3= libconvert-inmos.3 libcourse-cycles.3 libcourse-nets.3 \
|
||||
libcourse-utils.3 libfile.3 libhostio-inmos.3 libmath-inmos.3 \
|
||||
libproc.3 libsock.3 libstreamio-inmos.3 libstring-inmos.3
|
||||
|
||||
FAKEDIR= ${WRKDIR}/fake
|
||||
|
||||
# Fix pkgconfig location
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name "Makefile.am" -type f | \
|
||||
${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
|
||||
|
||||
# Path options to build are inconsistent
|
||||
do-build:
|
||||
@cd ${WRKSRC} && \
|
||||
CPPFLAGS=-I${PREFIX}/include \
|
||||
LDFLAGS=-L${PREFIX}/lib \
|
||||
./build \
|
||||
--prefix=${FAKEDIR} \
|
||||
--configdir=${FAKEDIR}/etc \
|
||||
--krocdir=/${DATADIR_REL} \
|
||||
--mandir=/man
|
||||
.ifndef(NOPORTEXAMPLES)
|
||||
@cd ${WRKSRC} && \
|
||||
CPPFLAGS=-I${PREFIX}/include \
|
||||
LDFLAGS=-L${PREFIX}/lib \
|
||||
./build \
|
||||
--prefix=${FAKEDIR} \
|
||||
--configdir=${FAKEDIR}/etc \
|
||||
--krocdir=/${DATADIR_REL} \
|
||||
--mandir=/man \
|
||||
examples
|
||||
.endif
|
||||
.ifndef(NOPORTDOCS)
|
||||
@cd ${WRKSRC} && \
|
||||
CPPFLAGS=-I${PREFIX}/include \
|
||||
LDFLAGS=-L${PREFIX}/lib \
|
||||
./build \
|
||||
--prefix=${FAKEDIR} \
|
||||
--configdir=${FAKEDIR}/etc \
|
||||
--krocdir=/${DATADIR_REL} \
|
||||
--mandir=/man \
|
||||
doc
|
||||
.endif
|
||||
|
||||
FAKEDIR_FILES= bin/kroc bin/occamdoc bin/occbuild \
|
||||
libdata/pkgconfig/ccsp-1.6.pc
|
||||
pre-configure:
|
||||
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} \
|
||||
${AUTORECONF} -f -i)
|
||||
|
||||
regression-test:
|
||||
@cd ${WRKSRC} && \
|
||||
CPPFLAGS=-I${PREFIX}/include \
|
||||
LDFLAGS=-L${PREFIX}/lib \
|
||||
./build \
|
||||
--prefix=${FAKEDIR} \
|
||||
--configdir=${FAKEDIR}/etc \
|
||||
--krocdir=/${DATADIR_REL} \
|
||||
--mandir=/man \
|
||||
tests
|
||||
|
||||
pre-install:
|
||||
@${RM} ${FAKEDIR}/bin/kroc-setup.sh ${FAKEDIR}/bin/kroc-setup.csh
|
||||
.for i in ${FAKEDIR_FILES}
|
||||
@${REINPLACE_CMD} \
|
||||
-i '' -e 's|${FAKEDIR}|${PREFIX}|' \
|
||||
${FAKEDIR}/$i
|
||||
.endfor
|
||||
|
||||
do-install:
|
||||
@cd ${FAKEDIR} && ${TAR} -cf - . | ${TAR} -xf - -C ${PREFIX}
|
||||
@cd ${WRKSRC} && ${MAKE} check
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (kroc-1.5-r5519.tar.bz2) = 14d90e40e5ff976ace85dd727508c3c7
|
||||
SHA256 (kroc-1.5-r5519.tar.bz2) = dadbd3c143b82d1579246013678f1ce091dbdbb83c65aa8778ca388dfced3010
|
||||
SIZE (kroc-1.5-r5519.tar.bz2) = 2959857
|
||||
MD5 (kroc-1.5-r5576.tar.bz2) = c3b1ae40c38fba9a511540dc5d68ad04
|
||||
SHA256 (kroc-1.5-r5576.tar.bz2) = d5d238fc9de706978604014c3ed39b901148ae9f7056514568cff3ba403816bd
|
||||
SIZE (kroc-1.5-r5576.tar.bz2) = 3608841
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- ./modules/occGL/libsrc/Makefile.am.orig 2008-07-07 13:33:12.000000000 +0100
|
||||
+++ ./modules/occGL/libsrc/Makefile.am 2008-07-07 13:33:27.000000000 +0100
|
||||
@@ -31,7 +31,7 @@
|
||||
endif
|
||||
|
||||
occGL.lib: $(occGL_lib_objs)
|
||||
- $(OCCBUILD) --library occGL.lib --include occGL.inc @GL_LIBS@ $(occGL_lib_objs)
|
||||
+ $(OCCBUILD) --library occGL.lib --include occGL.inc @LDFLAGS@ @GL_LIBS@ $(occGL_lib_objs)
|
||||
|
||||
install-exec-local: $(libs) $(includes)
|
||||
$(OCCBUILD) --install --prefix "$(prefix)" --destdir "$(DESTDIR)" $(libs) $(includes)
|
|
@ -2,10 +2,15 @@ KRoC, the Kent Retargettable occam-pi Compiler, is a collection
|
|||
of programs/libraries which facilitates the execution of occam-pi
|
||||
programs on various platforms. The main components are:
|
||||
|
||||
* occ21, the Inmos occam compiler
|
||||
* tranx86, a translator from extended transputer code (ETC) to
|
||||
intel i386 object code
|
||||
* CCSP, the run-time kernel, providing the virtual transputer
|
||||
* occ21, an occam-pi compiler derived from the Inmos occam 2 compiler
|
||||
* tranx86, an ETC-to-native-code translator
|
||||
* CCSP, an occam-pi runtime
|
||||
* The Transterpreter Virtual Machine (TVM), a portable runtime for
|
||||
occam-pi bytecode (unsupported by CIF)
|
||||
* CIF, a C interface to CCSP
|
||||
* standard libraries such as course, filelib, socklib, inmoslibs and
|
||||
pony
|
||||
* OccamDoc, a documentation extraction tool for occam
|
||||
|
||||
As well as these are various libraries, example programs, fun
|
||||
animations, etc.
|
||||
|
|
1083
lang/kroc/pkg-plist
1083
lang/kroc/pkg-plist
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue