textproc/py-markdown-callouts: Update to 0.4.0

* Remove no longer needed patch because the required build system has
  been changed from py-poetry to py-hatchling.

Changelog:

https://github.com/oprypin/markdown-callouts/compare/v0.3.0...v0.4.0
This commit is contained in:
Kai Knoblich 2024-03-09 10:53:22 +01:00
parent b84a053759
commit e15cd26700
3 changed files with 6 additions and 27 deletions

View File

@ -1,9 +1,9 @@
PORTNAME= markdown-callouts
DISTVERSION= 0.3.0
PORTREVISION= 1
DISTVERSION= 0.4.0
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= markdown_callouts-${DISTVERSION}
MAINTAINER= kai@FreeBSD.org
COMMENT= Markdown extension: Classier syntax for admonitions
@ -12,7 +12,7 @@ WWW= https://github.com/oprypin/markdown-callouts
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=0.12:devel/py-poetry-core@${PY_FLAVOR}
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>0:devel/py-hatchling@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>=3.3.3:textproc/py-markdown@${PY_FLAVOR}
USES= python

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1688225214
SHA256 (markdown-callouts-0.3.0.tar.gz) = 21e99d72a879663343e232158413e12eeaa9fb78b90e669f41cdbf0962a364fb
SIZE (markdown-callouts-0.3.0.tar.gz) = 5287
TIMESTAMP = 1708698020
SHA256 (markdown_callouts-0.4.0.tar.gz) = 7ed2c90486967058a73a547781121983839522d67041ae52c4979616f1b2b746
SIZE (markdown_callouts-0.4.0.tar.gz) = 9768

View File

@ -1,21 +0,0 @@
Use the more lightweight py-poetry-core instead py-poetry.
--- pyproject.toml.orig 2022-09-18 20:43:59 UTC
+++ pyproject.toml
@@ -13,7 +13,7 @@ python = "^3.6"
[tool.poetry.dependencies]
python = "^3.6"
-Markdown = "^3.3.3"
+Markdown = ">=3.3.3"
[tool.poetry.dev-dependencies]
pytest = "^6.1.2"
@@ -48,5 +48,5 @@ filterwarnings = ["ignore::DeprecationWarning:.*:",
"default::DeprecationWarning:markdown_callouts.*:"]
[build-system]
-requires = ["poetry>=0.12"]
-build-backend = "poetry.masonry.api"
+requires = ["poetry-core>=0.12"]
+build-backend = "poetry.core.masonry.api"