Update freetype2 to 2.6.2. [1]
Mark magicpoint broken, maintainer is notified. Exp-runs run by antoine@ This version also fixes shadowing of TYPEOF in ftconfig.h [2] PR: 203554 [1], 202083 [2] Submitted by: rhurlin@gwdg.de [2]
This commit is contained in:
parent
3c8d04907f
commit
e1add76b39
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=403474
16 changed files with 183 additions and 262 deletions
|
@ -1,11 +1,11 @@
|
|||
--- plugins/zynaddsubfx/fltk/CMakeLists.txt.orig 2013-12-24 21:48:53.000000000 +0200
|
||||
+++ plugins/zynaddsubfx/fltk/CMakeLists.txt 2013-12-24 21:49:16.000000000 +0200
|
||||
@@ -165,7 +165,7 @@
|
||||
mark_as_advanced(HAVE_SYS_STDTYPES_H HAVE_XDBE_H)
|
||||
|
||||
# where to find freetype headers
|
||||
-find_path(FREETYPE_PATH freetype/config/ftheader.h PATH_SUFFIXES freetype2)
|
||||
+find_path(FREETYPE_PATH config/ftheader.h PATH_SUFFIXES freetype2)
|
||||
if(FREETYPE_PATH)
|
||||
include_directories(${FREETYPE_PATH})
|
||||
endif(FREETYPE_PATH)
|
||||
--- plugins/zynaddsubfx/fltk/CMakeLists.txt.orig 2013-06-11 17:46:42.000000000 +0200
|
||||
+++ plugins/zynaddsubfx/fltk/CMakeLists.txt 2015-10-21 10:24:19.901416000 +0200
|
||||
@@ -139,7 +139,7 @@
|
||||
find_file(HAVE_ALSA_ASOUNDLIB_H alsa/asoundlib.h)
|
||||
find_file(HAVE_DIRENT_H dirent.h)
|
||||
find_file(HAVE_DLFCN_H dlfcn.h)
|
||||
-find_file(HAVE_FREETYPE_H freetype.h PATH_SUFFIXES freetype2)
|
||||
+find_file(HAVE_FREETYPE_H ft2build.h PATH_SUFFIXES freetype2)
|
||||
find_file(HAVE_GL_GL_H GL/gl.h)
|
||||
find_file(HAVE_GL_GLU_H GL/glu.h)
|
||||
find_file(HAVE_LIBPNG_PNG_H libpng/png.h)
|
||||
|
|
|
@ -1,14 +1,5 @@
|
|||
--- cmake/FindFreetype2.cmake.orig 2013-12-24 19:02:55.000000000 +0100
|
||||
+++ cmake/FindFreetype2.cmake 2013-12-24 19:03:21.000000000 +0100
|
||||
@@ -52,7 +52,7 @@
|
||||
#
|
||||
|
||||
|
||||
-FIND_PATH(FREETYPE2_INCLUDE_DIR freetype/config/ftheader.h
|
||||
+FIND_PATH(FREETYPE2_INCLUDE_DIR config/ftheader.h
|
||||
${ADDITIONAL_INCLUDE_PATH}
|
||||
/usr/include
|
||||
/usr/include/freetype2
|
||||
@@ -67,7 +67,7 @@
|
||||
NO_DEFAULT_PATH
|
||||
)
|
||||
|
|
|
@ -23,18 +23,17 @@ RUN_DEPENDS= psselect:${PORTSDIR}/print/psutils \
|
|||
|
||||
USE_XORG= xft xmu xpm
|
||||
GNU_CONFIGURE= yes
|
||||
USES= ghostscript:run jpeg libtool:build shebangfix tar:bzip2
|
||||
USES= ghostscript:run jpeg libtool:build pkgconfig shebangfix \
|
||||
tar:bzip2
|
||||
SHEBANG_FILES= share/bin/imgmerge share/bin/xpaint_ocr
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
|
||||
-I${LOCALBASE}/include/freetype2/freetype
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
MAKE_ENV+= RM="${RM} -f"
|
||||
|
||||
post-patch:
|
||||
@${RM} -f ${WRKSRC}/XPaint.ad
|
||||
@${REINPLACE_CMD} -e 's/-ldl //' \
|
||||
-e 's|freetype/||g' \
|
||||
${WRKSRC}/configure ${WRKSRC}/rw/configure
|
||||
@${REINPLACE_CMD} -e '/^LIBTOOL =/s|=.*|= ${LOCALBASE}/bin/libtool|' \
|
||||
-e '/^install-exec-am:/s/install-libLTLIBRARIES//' \
|
||||
|
|
11
graphics/xpaint/files/patch-configure
Normal file
11
graphics/xpaint/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig 2015-12-03 20:52:59.771668000 +0100
|
||||
+++ configure 2015-12-03 20:53:09.226361000 +0100
|
||||
@@ -5611,7 +5611,7 @@
|
||||
$as_echo_n "checking location of freetype2 headers... " >&6; }
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
-#include <freetype2/config/ftheader.h>
|
||||
+#include <freetype2/freetype/config/ftheader.h>
|
||||
int
|
||||
main ()
|
||||
{
|
11
graphics/xpaint/files/patch-rw_configure
Normal file
11
graphics/xpaint/files/patch-rw_configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- rw/configure.orig 2015-12-03 20:56:32.251228000 +0100
|
||||
+++ rw/configure 2015-12-03 20:56:55.905547000 +0100
|
||||
@@ -11691,7 +11691,7 @@
|
||||
$as_echo_n "checking location of freetype2 headers... " >&6; }
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
||||
-#include <freetype2/config/ftheader.h>
|
||||
+#include <freetype2/freetype/config/ftheader.h>
|
||||
int
|
||||
main ()
|
||||
{
|
|
@ -10,6 +10,8 @@ MASTER_SITES= ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/
|
|||
MAINTAINER= dinoex@FreeBSD.org
|
||||
COMMENT= X11-based presentation tool
|
||||
|
||||
BROKEN= Doesn't build with freetype2 2.6.1 or higher
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png \
|
||||
|
|
|
@ -321,7 +321,6 @@ post-patch:
|
|||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
@${REINPLACE_CMD} -e 's|-ldl||; s|$$(LIBMAJOR)|${SHLIB_VER}|g;' \
|
||||
-e 's|opencv opencv/cxcore.h|opencv-core opencv2/core/core_c.h|g' \
|
||||
-e 's|freetype/freetype.h|freetype.h|g' \
|
||||
-e 's|check_ldflags -Wl,--as-needed||' \
|
||||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
@${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL5}|g' \
|
||||
|
|
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= freetype2
|
||||
PORTVERSION= 2.6
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.6.2
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://savannah.nongnu.org/download/freetype/ \
|
||||
SF/freetype/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/}/ \
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (freetype-2.6.tar.bz2) = 8469fb8124764f85029cc8247c31e132a2c5e51084ddce2a44ea32ee4ae8347e
|
||||
SIZE (freetype-2.6.tar.bz2) = 1726219
|
||||
SHA256 (freetype-2.6.2.tar.bz2) = baf6bdef7cdcc12ac270583f76ef245efe936267dbecef835f02a3409fcbb892
|
||||
SIZE (freetype-2.6.2.tar.bz2) = 1767940
|
||||
|
|
|
@ -1,163 +0,0 @@
|
|||
Revert commit below to fix cut off text
|
||||
|
||||
https://savannah.nongnu.org/bugs/?45520
|
||||
|
||||
From 5cd21551131ef3a9690ecbefcc9782286ee5199e Mon Sep 17 00:00:00 2001
|
||||
From: Werner Lemberg <wl@gnu.org>
|
||||
Date: Fri, 10 Apr 2015 05:01:01 +0000
|
||||
Subject: [cff] Update advance width handling to OpenType 1.7.
|
||||
|
||||
Problem reported by Behdad.
|
||||
|
||||
* src/cff/cffdrivr.c (cff_get_advances): Handle SFNT case
|
||||
separately.
|
||||
|
||||
* src/cff/cffgload.c (cff_slot_load): Use advance width and side
|
||||
bearing values from `hmtx' table if present.
|
||||
---
|
||||
|
||||
--- src/cff/cffdrivr.c.orig 2015-04-28 09:15:13.000000000 +0200
|
||||
+++ src/cff/cffdrivr.c 2015-07-25 17:42:23.025572000 +0200
|
||||
@@ -195,68 +195,6 @@
|
||||
FT_GlyphSlot slot = face->glyph;
|
||||
|
||||
|
||||
- if ( FT_IS_SFNT( face ) )
|
||||
- {
|
||||
- /* OpenType 1.7 mandates that the data from `hmtx' table be used; */
|
||||
- /* it is no longer necessary that those values are identical to */
|
||||
- /* the values in the `CFF' table */
|
||||
-
|
||||
- TT_Face ttface = (TT_Face)face;
|
||||
- FT_Short dummy;
|
||||
-
|
||||
-
|
||||
- if ( flags & FT_LOAD_VERTICAL_LAYOUT )
|
||||
- {
|
||||
- /* check whether we have data from the `vmtx' table at all; */
|
||||
- /* otherwise we extract the info from the CFF glyphstrings */
|
||||
- /* (instead of synthesizing a global value using the `OS/2' */
|
||||
- /* table) */
|
||||
- if ( !ttface->vertical_info )
|
||||
- goto Missing_Table;
|
||||
-
|
||||
- for ( nn = 0; nn < count; nn++ )
|
||||
- {
|
||||
- FT_UShort ah;
|
||||
-
|
||||
-
|
||||
- ( (SFNT_Service)ttface->sfnt )->get_metrics( ttface,
|
||||
- 1,
|
||||
- start + nn,
|
||||
- &dummy,
|
||||
- &ah );
|
||||
-
|
||||
- FT_TRACE5(( " idx %d: advance height %d font units\n",
|
||||
- start + nn, ah ));
|
||||
- advances[nn] = ah;
|
||||
- }
|
||||
- }
|
||||
- else
|
||||
- {
|
||||
- /* check whether we have data from the `hmtx' table at all */
|
||||
- if ( !ttface->horizontal.number_Of_HMetrics )
|
||||
- goto Missing_Table;
|
||||
-
|
||||
- for ( nn = 0; nn < count; nn++ )
|
||||
- {
|
||||
- FT_UShort aw;
|
||||
-
|
||||
-
|
||||
- ( (SFNT_Service)ttface->sfnt )->get_metrics( ttface,
|
||||
- 0,
|
||||
- start + nn,
|
||||
- &dummy,
|
||||
- &aw );
|
||||
-
|
||||
- FT_TRACE5(( " idx %d: advance width %d font units\n",
|
||||
- start + nn, aw ));
|
||||
- advances[nn] = aw;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- return error;
|
||||
- }
|
||||
-
|
||||
- Missing_Table:
|
||||
flags |= (FT_UInt32)FT_LOAD_ADVANCE_ONLY;
|
||||
|
||||
for ( nn = 0; nn < count; nn++ )
|
||||
--- src/cff/cffgload.c.orig 2015-04-16 07:02:23.000000000 +0200
|
||||
+++ src/cff/cffgload.c 2015-07-25 17:42:23.027008000 +0200
|
||||
@@ -2725,7 +2725,7 @@
|
||||
face->vertical_info &&
|
||||
face->vertical.number_Of_VMetrics > 0 );
|
||||
|
||||
- /* get the vertical metrics from the vmtx table if we have one */
|
||||
+ /* get the vertical metrics from the vtmx table if we have one */
|
||||
if ( has_vertical_info )
|
||||
{
|
||||
(void)( (SFNT_Service)face->sfnt )->get_metrics( face, 1,
|
||||
@@ -2953,43 +2953,25 @@
|
||||
FT_Bool has_vertical_info;
|
||||
|
||||
|
||||
- if ( face->horizontal.number_Of_HMetrics )
|
||||
- {
|
||||
- FT_Short horiBearingX = 0;
|
||||
- FT_UShort horiAdvance = 0;
|
||||
-
|
||||
-
|
||||
- ( (SFNT_Service)face->sfnt )->get_metrics( face, 0,
|
||||
- glyph_index,
|
||||
- &horiBearingX,
|
||||
- &horiAdvance );
|
||||
- metrics->horiAdvance = horiAdvance;
|
||||
- metrics->horiBearingX = horiBearingX;
|
||||
- glyph->root.linearHoriAdvance = horiAdvance;
|
||||
- }
|
||||
- else
|
||||
- {
|
||||
- /* copy the _unscaled_ advance width */
|
||||
- metrics->horiAdvance = decoder.glyph_width;
|
||||
- glyph->root.linearHoriAdvance = decoder.glyph_width;
|
||||
- }
|
||||
-
|
||||
+ /* copy the _unscaled_ advance width */
|
||||
+ metrics->horiAdvance = decoder.glyph_width;
|
||||
+ glyph->root.linearHoriAdvance = decoder.glyph_width;
|
||||
glyph->root.internal->glyph_transformed = 0;
|
||||
|
||||
has_vertical_info = FT_BOOL( face->vertical_info &&
|
||||
face->vertical.number_Of_VMetrics > 0 );
|
||||
|
||||
- /* get the vertical metrics from the vmtx table if we have one */
|
||||
+ /* get the vertical metrics from the vtmx table if we have one */
|
||||
if ( has_vertical_info )
|
||||
{
|
||||
FT_Short vertBearingY = 0;
|
||||
FT_UShort vertAdvance = 0;
|
||||
|
||||
|
||||
- ( (SFNT_Service)face->sfnt )->get_metrics( face, 1,
|
||||
- glyph_index,
|
||||
- &vertBearingY,
|
||||
- &vertAdvance );
|
||||
+ (void)( (SFNT_Service)face->sfnt )->get_metrics( face, 1,
|
||||
+ glyph_index,
|
||||
+ &vertBearingY,
|
||||
+ &vertAdvance );
|
||||
metrics->vertBearingY = vertBearingY;
|
||||
metrics->vertAdvance = vertAdvance;
|
||||
}
|
||||
@@ -3064,9 +3046,7 @@
|
||||
metrics->width = cbox.xMax - cbox.xMin;
|
||||
metrics->height = cbox.yMax - cbox.yMin;
|
||||
|
||||
- if ( !face->horizontal.number_Of_HMetrics )
|
||||
- metrics->horiBearingX = cbox.xMin;
|
||||
-
|
||||
+ metrics->horiBearingX = cbox.xMin;
|
||||
metrics->horiBearingY = cbox.yMax;
|
||||
|
||||
if ( has_vertical_info )
|
|
@ -1,5 +1,5 @@
|
|||
--- builds/unix/detect.mk.orig 2015-03-11 01:47:10.000000000 -0400
|
||||
+++ builds/unix/detect.mk 2015-06-16 05:45:17.176216000 -0400
|
||||
--- builds/unix/detect.mk.orig 2015-09-25 07:58:57.000000000 +0200
|
||||
+++ builds/unix/detect.mk 2015-10-04 12:35:05.733855000 +0200
|
||||
@@ -22,6 +22,9 @@
|
||||
$(wildcard /usr/sbin/init) \
|
||||
$(wildcard /dev/null) \
|
||||
|
@ -10,21 +10,17 @@
|
|||
ifneq ($(is_unix),)
|
||||
|
||||
PLATFORM := unix
|
||||
@@ -81,12 +84,12 @@
|
||||
@@ -80,10 +83,10 @@
|
||||
ifdef must_configure
|
||||
ifneq ($(have_Makefile),)
|
||||
# we are building FT2 not in the src tree
|
||||
- CONFIG_SHELL="$(CONFIG_SHELL)" \
|
||||
- $(CONFIG_SHELL) $(TOP_DIR)/builds/unix/configure $(value CFG)
|
||||
+# CONFIG_SHELL="$(CONFIG_SHELL)" \
|
||||
+# $(CONFIG_SHELL) $(TOP_DIR)/builds/unix/configure $(value CFG)
|
||||
- $(TOP_DIR)/builds/unix/configure $(value CFG)
|
||||
+# $(TOP_DIR)/builds/unix/configure $(value CFG)
|
||||
else
|
||||
- cd builds/unix; \
|
||||
- CONFIG_SHELL="$(CONFIG_SHELL)" \
|
||||
- $(CONFIG_SHELL) ./configure $(value CFG)
|
||||
- ./configure $(value CFG)
|
||||
+# cd builds/unix; \
|
||||
+# CONFIG_SHELL="$(CONFIG_SHELL)" \
|
||||
+# $(CONFIG_SHELL) ./configure $(value CFG)
|
||||
+# ./configure $(value CFG)
|
||||
endif
|
||||
endif
|
||||
|
||||
|
|
|
@ -1,59 +1,59 @@
|
|||
bin/freetype-config
|
||||
include/freetype2/config/ftconfig.h
|
||||
include/freetype2/config/ftheader.h
|
||||
include/freetype2/config/ftmodule.h
|
||||
include/freetype2/config/ftoption.h
|
||||
include/freetype2/config/ftstdlib.h
|
||||
include/freetype2/freetype.h
|
||||
include/freetype2/freetype/config/ftconfig.h
|
||||
include/freetype2/freetype/config/ftheader.h
|
||||
include/freetype2/freetype/config/ftmodule.h
|
||||
include/freetype2/freetype/config/ftoption.h
|
||||
include/freetype2/freetype/config/ftstdlib.h
|
||||
include/freetype2/freetype/freetype.h
|
||||
include/freetype2/freetype/ftadvanc.h
|
||||
include/freetype2/freetype/ftautoh.h
|
||||
include/freetype2/freetype/ftbbox.h
|
||||
include/freetype2/freetype/ftbdf.h
|
||||
include/freetype2/freetype/ftbitmap.h
|
||||
include/freetype2/freetype/ftbzip2.h
|
||||
include/freetype2/freetype/ftcache.h
|
||||
include/freetype2/freetype/ftcffdrv.h
|
||||
include/freetype2/freetype/ftchapters.h
|
||||
include/freetype2/freetype/ftcid.h
|
||||
include/freetype2/freetype/fterrdef.h
|
||||
include/freetype2/freetype/fterrors.h
|
||||
include/freetype2/freetype/ftfntfmt.h
|
||||
include/freetype2/freetype/ftgasp.h
|
||||
include/freetype2/freetype/ftglyph.h
|
||||
include/freetype2/freetype/ftgxval.h
|
||||
include/freetype2/freetype/ftgzip.h
|
||||
include/freetype2/freetype/ftimage.h
|
||||
include/freetype2/freetype/ftincrem.h
|
||||
include/freetype2/freetype/ftlcdfil.h
|
||||
include/freetype2/freetype/ftlist.h
|
||||
include/freetype2/freetype/ftlzw.h
|
||||
include/freetype2/freetype/ftmac.h
|
||||
include/freetype2/freetype/ftmm.h
|
||||
include/freetype2/freetype/ftmodapi.h
|
||||
include/freetype2/freetype/ftmoderr.h
|
||||
include/freetype2/freetype/ftotval.h
|
||||
include/freetype2/freetype/ftoutln.h
|
||||
include/freetype2/freetype/ftpfr.h
|
||||
include/freetype2/freetype/ftrender.h
|
||||
include/freetype2/freetype/ftsizes.h
|
||||
include/freetype2/freetype/ftsnames.h
|
||||
include/freetype2/freetype/ftstroke.h
|
||||
include/freetype2/freetype/ftsynth.h
|
||||
include/freetype2/freetype/ftsystem.h
|
||||
include/freetype2/freetype/fttrigon.h
|
||||
include/freetype2/freetype/ftttdrv.h
|
||||
include/freetype2/freetype/fttypes.h
|
||||
include/freetype2/freetype/ftwinfnt.h
|
||||
include/freetype2/freetype/t1tables.h
|
||||
include/freetype2/freetype/ttnameid.h
|
||||
include/freetype2/freetype/tttables.h
|
||||
include/freetype2/freetype/tttags.h
|
||||
include/freetype2/freetype/ttunpat.h
|
||||
include/freetype2/ft2build.h
|
||||
include/freetype2/ftadvanc.h
|
||||
include/freetype2/ftautoh.h
|
||||
include/freetype2/ftbbox.h
|
||||
include/freetype2/ftbdf.h
|
||||
include/freetype2/ftbitmap.h
|
||||
include/freetype2/ftbzip2.h
|
||||
include/freetype2/ftcache.h
|
||||
include/freetype2/ftcffdrv.h
|
||||
include/freetype2/ftchapters.h
|
||||
include/freetype2/ftcid.h
|
||||
include/freetype2/fterrdef.h
|
||||
include/freetype2/fterrors.h
|
||||
include/freetype2/ftfntfmt.h
|
||||
include/freetype2/ftgasp.h
|
||||
include/freetype2/ftglyph.h
|
||||
include/freetype2/ftgxval.h
|
||||
include/freetype2/ftgzip.h
|
||||
include/freetype2/ftimage.h
|
||||
include/freetype2/ftincrem.h
|
||||
include/freetype2/ftlcdfil.h
|
||||
include/freetype2/ftlist.h
|
||||
include/freetype2/ftlzw.h
|
||||
include/freetype2/ftmac.h
|
||||
include/freetype2/ftmm.h
|
||||
include/freetype2/ftmodapi.h
|
||||
include/freetype2/ftmoderr.h
|
||||
include/freetype2/ftotval.h
|
||||
include/freetype2/ftoutln.h
|
||||
include/freetype2/ftpfr.h
|
||||
include/freetype2/ftrender.h
|
||||
include/freetype2/ftsizes.h
|
||||
include/freetype2/ftsnames.h
|
||||
include/freetype2/ftstroke.h
|
||||
include/freetype2/ftsynth.h
|
||||
include/freetype2/ftsystem.h
|
||||
include/freetype2/fttrigon.h
|
||||
include/freetype2/ftttdrv.h
|
||||
include/freetype2/fttypes.h
|
||||
include/freetype2/ftwinfnt.h
|
||||
include/freetype2/t1tables.h
|
||||
include/freetype2/ttnameid.h
|
||||
include/freetype2/tttables.h
|
||||
include/freetype2/tttags.h
|
||||
include/freetype2/ttunpat.h
|
||||
lib/libfreetype.a
|
||||
lib/libfreetype.so
|
||||
lib/libfreetype.so.6
|
||||
lib/libfreetype.so.6.12.0
|
||||
lib/libfreetype.so.6.12.2
|
||||
libdata/pkgconfig/freetype2.pc
|
||||
man/man1/freetype-config.1.gz
|
||||
share/aclocal/freetype2.m4
|
||||
|
|
35
www/firefox/files/patch-1194520
Normal file
35
www/firefox/files/patch-1194520
Normal file
|
@ -0,0 +1,35 @@
|
|||
From bb146548c7846ba5d14f070f4be985797d83d5ca Mon Sep 17 00:00:00 2001
|
||||
From: Mike Hommey <mh+mozilla@glandium.org>
|
||||
Date: Fri, 14 Aug 2015 08:50:38 +0900
|
||||
Subject: [PATCH] Bug 1194520 - Add a system header wrapper for
|
||||
<freetype/ftfntfmt.h>
|
||||
|
||||
---
|
||||
config/system-headers | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/config/system-headers b/config/system-headers
|
||||
index bee35da..ad1f88d 100644
|
||||
--- config/system-headers
|
||||
+++ config/system-headers
|
||||
@@ -450,16 +450,17 @@ foundation/base64.h
|
||||
foundation/hexdump.h
|
||||
#endif
|
||||
fp.h
|
||||
fpieee.h
|
||||
frame/log.h
|
||||
frame/req.h
|
||||
freetype/freetype.h
|
||||
freetype/ftcache.h
|
||||
+freetype/ftfntfmt.h
|
||||
freetype/ftglyph.h
|
||||
freetype/ftsynth.h
|
||||
freetype/ftoutln.h
|
||||
freetype/ttnameid.h
|
||||
freetype/tttables.h
|
||||
freetype/t1tables.h
|
||||
freetype/ftlcdfil.h
|
||||
freetype/ftsizes.h
|
||||
--
|
||||
2.5.0.3.ge81d485
|
||||
|
35
www/seamonkey/files/patch-1194520
Normal file
35
www/seamonkey/files/patch-1194520
Normal file
|
@ -0,0 +1,35 @@
|
|||
From bb146548c7846ba5d14f070f4be985797d83d5ca Mon Sep 17 00:00:00 2001
|
||||
From: Mike Hommey <mh+mozilla@glandium.org>
|
||||
Date: Fri, 14 Aug 2015 08:50:38 +0900
|
||||
Subject: [PATCH] Bug 1194520 - Add a system header wrapper for
|
||||
<freetype/ftfntfmt.h>
|
||||
|
||||
---
|
||||
config/system-headers | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/config/system-headers b/config/system-headers
|
||||
index bee35da..ad1f88d 100644
|
||||
--- mozilla/config/system-headers
|
||||
+++ mozilla/config/system-headers
|
||||
@@ -450,16 +450,17 @@ foundation/base64.h
|
||||
foundation/hexdump.h
|
||||
#endif
|
||||
fp.h
|
||||
fpieee.h
|
||||
frame/log.h
|
||||
frame/req.h
|
||||
freetype/freetype.h
|
||||
freetype/ftcache.h
|
||||
+freetype/ftfntfmt.h
|
||||
freetype/ftglyph.h
|
||||
freetype/ftsynth.h
|
||||
freetype/ftoutln.h
|
||||
freetype/ttnameid.h
|
||||
freetype/tttables.h
|
||||
freetype/t1tables.h
|
||||
freetype/ftlcdfil.h
|
||||
freetype/ftsizes.h
|
||||
--
|
||||
2.5.0.3.ge81d485
|
||||
|
11
x11-fm/xfe/files/patch-configure
Normal file
11
x11-fm/xfe/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig 2015-10-21 16:59:07.344253000 +0200
|
||||
+++ configure 2015-10-21 16:59:18.245643000 +0200
|
||||
@@ -14940,7 +14940,7 @@
|
||||
LIBS="$LIBS $freetype_libs"
|
||||
CPPFLAGS="$freetype_cflags $CPPFLAGS"
|
||||
fi
|
||||
- ac_fn_cxx_check_header_mongrel "$LINENO" "config/ftheader.h" "ac_cv_header_config_ftheader_h" "$ac_includes_default"
|
||||
+ ac_fn_cxx_check_header_mongrel "$LINENO" "freetype/config/ftheader.h" "ac_cv_header_config_ftheader_h" "$ac_includes_default"
|
||||
if test "x$ac_cv_header_config_ftheader_h" = xyes; then :
|
||||
|
||||
else
|
|
@ -1,6 +1,6 @@
|
|||
--- cmake/modules/FREETYPEConfig.cmake.orig 2008-04-07 23:45:10.000000000 +0300
|
||||
+++ cmake/modules/FREETYPEConfig.cmake 2013-12-23 19:53:13.000000000 +0200
|
||||
@@ -1,14 +1,14 @@
|
||||
--- cmake/modules/FREETYPEConfig.cmake.orig 2008-04-07 22:45:10.000000000 +0200
|
||||
+++ cmake/modules/FREETYPEConfig.cmake 2015-12-02 14:40:47.871063000 +0100
|
||||
@@ -1,10 +1,10 @@
|
||||
#
|
||||
# Find the native FREETYPE includes and library
|
||||
# (from Scribus)
|
||||
|
@ -15,8 +15,3 @@
|
|||
NO_CMAKE_SYSTEM_PATH
|
||||
)
|
||||
|
||||
- FIND_PATH(FREETYPE_INCLUDE_DIR_FTHEADER freetype/config/ftheader.h
|
||||
+ FIND_PATH(FREETYPE_INCLUDE_DIR_FTHEADER config/ftheader.h
|
||||
/usr/include/freetype2
|
||||
/usr/local/include/freetype2
|
||||
/usr/X11R6/include/freetype2
|
||||
|
|
Loading…
Reference in a new issue