mail/datovka: Fix build with openssl3

Approved by:	portmgr (blanket)
Sponsored by:	The FreeBSD Foundation
This commit is contained in:
Muhammad Moinur Rahman 2023-08-07 18:28:40 +02:00
parent ebc2ad83fe
commit e1cfb4d871
2 changed files with 13 additions and 7 deletions

View File

@ -19,10 +19,4 @@ USE_GL= gl
USE_QT= buildtools core gui network printsupport sql svg websockets \
widgets
.include <bsd.port.pre.mk>
.if ( ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && ${SSL_DEFAULT} == base ) || ${SSL_DEFAULT:Mopenssl3*}
CXXFLAGS+= -DOPENSSL_API_COMPAT=0x30000000L
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,12 @@
--- src/crypto/crypto.c.orig 2023-08-07 16:26:04 UTC
+++ src/crypto/crypto.c
@@ -312,7 +312,9 @@ int crypto_init(void)
OpenSSL_add_all_algorithms();
ERR_load_crypto_strings();
+#if OPENSSL_VERSION_NUMBER < 0x30000000L
ERR_load_CMS_strings();
+#endif
//ERR_free_strings();
if (NULL != ca_certs) {