Tech gnome-session how to set-up a LD_LIBRARY_PATH, so that mozilla

component of nautilus Just Works[tm], without the need to customize
environment. Remove appropriate comment from post-install section
of nautilus' Makefile.
This commit is contained in:
Maxim Sobolev 2001-11-20 13:07:45 +00:00
parent 8d8ae7ba6b
commit e1dc354541
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=50254
5 changed files with 35 additions and 24 deletions

View file

@ -64,14 +64,4 @@ pre-patch:
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.if !defined(WITHOUT_MOZILLA)
post-install:
@${ECHO} ""
@${ECHO} "To be able view WWW pages and HTML documents from Nautilus please"
@${ECHO} "add the following into your environment:"
@${ECHO} ""
@${ECHO} " LD_LIBRARY_PATH=${X11BASE}/lib/mozilla-embedded"
@${ECHO} ""
.endif
.include <bsd.port.mk>

View file

@ -64,14 +64,4 @@ pre-patch:
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.if !defined(WITHOUT_MOZILLA)
post-install:
@${ECHO} ""
@${ECHO} "To be able view WWW pages and HTML documents from Nautilus please"
@${ECHO} "add the following into your environment:"
@${ECHO} ""
@${ECHO} " LD_LIBRARY_PATH=${X11BASE}/lib/mozilla-embedded"
@${ECHO} ""
.endif
.include <bsd.port.mk>

View file

@ -7,7 +7,7 @@
PORTNAME= gnomecore
PORTVERSION= 1.4.0.4
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES?= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-core

View file

@ -1,7 +1,17 @@
--- gsm/Makefile.in.orig Tue Aug 1 23:56:19 2000
+++ gsm/Makefile.in Tue Aug 1 23:59:25 2000
@@ -143,3 +143,3 @@
$FreeBSD$
--- gsm/Makefile.in.orig Tue Nov 20 12:20:56 2001
+++ gsm/Makefile.in Tue Nov 20 14:56:33 2001
@@ -157,9 +157,9 @@
SUBDIRS = help
-defaultdir = $(datadir)/gnome
+defaultdir = $(datadir)
-INCLUDES = -I$(includedir) $(GNOME_INCLUDEDIR) -I$(top_srcdir)/intl -I$(top_builddir)/intl -DGNOMELOCALEDIR=\""$(prefix)/share/locale\"" -DDEFAULTDIR="\"$(defaultdir)\"" @CANVAS_PIXBUF_CFLAGS@
+INCLUDES = -I$(includedir) $(GNOME_INCLUDEDIR) -I$(top_srcdir)/intl -I$(top_builddir)/intl -DGNOMELOCALEDIR=\""$(prefix)/share/locale\"" -DDEFAULTDIR="\"$(defaultdir)\"" @CANVAS_PIXBUF_CFLAGS@ -DX11BASE="\"$(X11BASE)\""
LDADD = $(GNOME_LIBDIR) $(GNOMEUI_LIBS) $(INTLLIBS)

View file

@ -0,0 +1,21 @@
$FreeBSD$
--- gsm/ice.c 2001/11/20 12:53:53 1.1
+++ gsm/ice.c 2001/11/20 12:53:56
@@ -337,6 +337,15 @@
p = g_strconcat (ENVNAME "=", ids, NULL);
putenv (p);
+
+ /* XXX: hack for embedded Mozilla */
+ p = getenv ("LD_LIBRARY_PATH");
+ if (p == NULL)
+ p = "";
+ else
+ p = g_strconcat (p, ":", NULL);
+ p = g_strconcat (p, X11BASE "/lib/mozilla-embedded", NULL);
+ setenv ("LD_LIBRARY_PATH", p, 1);
}
void