Import XML parser library.
PR: ports/8227 Submitted by: <nakai@technologist.com>
This commit is contained in:
parent
68a7bf4041
commit
e1fbee612d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=13857
12 changed files with 92 additions and 0 deletions
21
textproc/libxml/Makefile
Normal file
21
textproc/libxml/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# New ports collection makefile for: libxml
|
||||
# Version required: 0.30
|
||||
# Date created: 28 September 1998
|
||||
# Whom: Yukihiro Nakai <Nakai@technologist.com>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= libxml-0.30
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
|
||||
ftp://ftp.gnome.org/pub/GNOME/sources/
|
||||
|
||||
MAINTAINER= Nakai@technologist.com
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
post-install:
|
||||
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
1
textproc/libxml/distinfo
Normal file
1
textproc/libxml/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (libxml-0.30.tar.gz) = 62cadf0c00e7b0742d663c97ad910e2b
|
11
textproc/libxml/files/patch-aa
Normal file
11
textproc/libxml/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.in.orig Thu Oct 8 17:36:15 1998
|
||||
+++ Makefile.in Thu Oct 8 18:18:42 1998
|
||||
@@ -105,7 +105,7 @@
|
||||
tester_DEPENDENCIES = $(DEPS)
|
||||
tester_LDADD= $(LDADDS)
|
||||
|
||||
-confexecdir=$(libdir)
|
||||
+confexecdir=$(sysconfdir)
|
||||
confexec_DATA = xmlConf.sh
|
||||
|
||||
EXTRA_DIST = xmlConf.sh.in
|
1
textproc/libxml/pkg-comment
Normal file
1
textproc/libxml/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
xml parser library for GNOME
|
1
textproc/libxml/pkg-descr
Normal file
1
textproc/libxml/pkg-descr
Normal file
|
@ -0,0 +1 @@
|
|||
xml parser library for GNOME
|
11
textproc/libxml/pkg-plist
Normal file
11
textproc/libxml/pkg-plist
Normal file
|
@ -0,0 +1,11 @@
|
|||
etc/xmlConf.sh
|
||||
include/gnome-xml/entities.h
|
||||
include/gnome-xml/parser.h
|
||||
include/gnome-xml/tree.h
|
||||
lib/libxml.a
|
||||
@exec ranlib %D/%F
|
||||
lib/libxml.la
|
||||
lib/libxml.so.0
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
@dirrm include/gnome-xml
|
21
textproc/libxml2/Makefile
Normal file
21
textproc/libxml2/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# New ports collection makefile for: libxml
|
||||
# Version required: 0.30
|
||||
# Date created: 28 September 1998
|
||||
# Whom: Yukihiro Nakai <Nakai@technologist.com>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= libxml-0.30
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
|
||||
ftp://ftp.gnome.org/pub/GNOME/sources/
|
||||
|
||||
MAINTAINER= Nakai@technologist.com
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
post-install:
|
||||
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
1
textproc/libxml2/distinfo
Normal file
1
textproc/libxml2/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (libxml-0.30.tar.gz) = 62cadf0c00e7b0742d663c97ad910e2b
|
11
textproc/libxml2/files/patch-aa
Normal file
11
textproc/libxml2/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.in.orig Thu Oct 8 17:36:15 1998
|
||||
+++ Makefile.in Thu Oct 8 18:18:42 1998
|
||||
@@ -105,7 +105,7 @@
|
||||
tester_DEPENDENCIES = $(DEPS)
|
||||
tester_LDADD= $(LDADDS)
|
||||
|
||||
-confexecdir=$(libdir)
|
||||
+confexecdir=$(sysconfdir)
|
||||
confexec_DATA = xmlConf.sh
|
||||
|
||||
EXTRA_DIST = xmlConf.sh.in
|
1
textproc/libxml2/pkg-comment
Normal file
1
textproc/libxml2/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
xml parser library for GNOME
|
1
textproc/libxml2/pkg-descr
Normal file
1
textproc/libxml2/pkg-descr
Normal file
|
@ -0,0 +1 @@
|
|||
xml parser library for GNOME
|
11
textproc/libxml2/pkg-plist
Normal file
11
textproc/libxml2/pkg-plist
Normal file
|
@ -0,0 +1,11 @@
|
|||
etc/xmlConf.sh
|
||||
include/gnome-xml/entities.h
|
||||
include/gnome-xml/parser.h
|
||||
include/gnome-xml/tree.h
|
||||
lib/libxml.a
|
||||
@exec ranlib %D/%F
|
||||
lib/libxml.la
|
||||
lib/libxml.so.0
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
@dirrm include/gnome-xml
|
Loading…
Reference in a new issue