devel/ispc: Only enable host architecture (no cross-platrorm compilation)
PR: 249289 Reported by: VVD <vvd@unislabs.com>
This commit is contained in:
parent
750d5f92f9
commit
e265804c5c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=548470
2 changed files with 24 additions and 8 deletions
|
@ -4,7 +4,7 @@
|
|||
PORTNAME= ispc
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.14.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= devel
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -17,13 +17,15 @@ ONLY_FOR_ARCHS= aarch64 amd64 i386
|
|||
ONLY_FOR_ARCHS_REASON= only available for these architectures
|
||||
|
||||
BUILD_DEPENDS= m4:devel/m4
|
||||
LIB_DEPENDS= libLLVM.so:devel/llvm${LLVM_DEFAULT}
|
||||
LIB_DEPENDS= libLLVM.so:devel/llvm${LLVM_VERSION}
|
||||
|
||||
USES= bison cmake compiler:c++14-lang python:build shebangfix
|
||||
USES= bison cmake compiler:c++14-lang python:build,test shebangfix
|
||||
USE_GITHUB= yes
|
||||
SHEBANG_FILES= *.py
|
||||
|
||||
CONFIGURE_ENV= PATH=${LOCALBASE}/llvm${LLVM_DEFAULT}/bin:${PATH}
|
||||
LLVM_VERSION= ${LLVM_DEFAULT}
|
||||
|
||||
CONFIGURE_ENV= PATH=${LOCALBASE}/llvm${LLVM_VERSION}/bin:${PATH}
|
||||
CMAKE_OFF= ISPC_INCLUDE_EXAMPLES
|
||||
|
||||
BINARY_ALIAS= python=${PYTHON_CMD} m4=${LOCALBASE}/bin/gm4
|
||||
|
@ -31,8 +33,11 @@ BINARY_ALIAS= python=${PYTHON_CMD} m4=${LOCALBASE}/bin/gm4
|
|||
PLIST_FILES= bin/ispc \
|
||||
bin/check_isa
|
||||
|
||||
do-test: # tests are broken with python-3.6
|
||||
@cd ${WRKSRC} && ISPC_HOME=${WRKSRC} ./run_tests.py
|
||||
do-test: # some tests fail: https://github.com/ispc/ispc/issues/1868
|
||||
@cd ${WRKSRC} && ISPC_HOME=${BUILD_WRKSRC}/bin ./run_tests.py
|
||||
|
||||
test-check-all:
|
||||
@cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} check-all
|
||||
|
||||
run-examples: build
|
||||
@[ -f ${LOCALBASE}/lib/libtbb.so ] || ! echo "ERROR run-examples target requires devel/tbb package installed"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2020-09-13 01:22:29 UTC
|
||||
--- CMakeLists.txt.orig 2020-08-28 19:43:13 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -45,7 +45,7 @@ set(ISPC_BUILD TRUE)
|
||||
@@ -45,12 +45,17 @@ set(ISPC_BUILD TRUE)
|
||||
project(${PROJECT_NAME})
|
||||
|
||||
set(X86_HOST FALSE)
|
||||
|
@ -9,3 +9,14 @@
|
|||
set(X86_HOST TRUE)
|
||||
endif()
|
||||
|
||||
+set(ARM_HOST FALSE)
|
||||
+if (${CMAKE_HOST_SYSTEM_PROCESSOR} MATCHES "aarch64")
|
||||
+ set(ARM_HOST TRUE)
|
||||
+endif()
|
||||
+
|
||||
option(X86_ENABLED "Enable x86 support" ${X86_HOST})
|
||||
-option(ARM_ENABLED "Enable ARM support" ON)
|
||||
+option(ARM_ENABLED "Enable ARM support" ${ARM_HOST})
|
||||
option(WASM_ENABLED "Enable experimental Web Assembly support" OFF)
|
||||
option(GENX_ENABLED "Enable GenX support" OFF)
|
||||
option(ISPC_INCLUDE_EXAMPLES "Generate build targets for the ISPC examples" ON)
|
||||
|
|
Loading…
Reference in a new issue