Update to 4.1.26
This commit is contained in:
parent
ecd98fe1be
commit
e2680d8f42
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=499373
6 changed files with 72 additions and 31 deletions
|
@ -2,11 +2,9 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= quisk
|
||||
PORTVERSION= 4.1.3
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 4.1.26
|
||||
CATEGORIES= comms hamradio
|
||||
MASTER_SITES= http://james.ahlstrom.name/quisk/ \
|
||||
LOCAL/db
|
||||
MASTER_SITES= CHEESESHOP
|
||||
|
||||
MAINTAINER= hamradio@FreeBSD.org
|
||||
COMMENT= Software Defined Radio (SDR)
|
||||
|
@ -21,10 +19,13 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
|
|||
USES= python:2.7
|
||||
USE_PYTHON= distutils autoplist
|
||||
USE_WX= 3.0+
|
||||
|
||||
WX_COMPS= python
|
||||
|
||||
post-extract:
|
||||
${RM} ${WRKSRC}/_quisk.so ${WRKSRC}/sdriqpkg/sdriq.so
|
||||
${RM} ${WRKSRC}/_quisk.so ${WRKSRC}/sdriqpkg/sdriq.so \
|
||||
${WRKSRC}/freedvpkg/libcodec2_32.so \
|
||||
${WRKSRC}/freedvpkg/libcodec2_64.so
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1482446629
|
||||
SHA256 (quisk-4.1.3.tar.gz) = 3bb41e3d5dd7feb4c949a6086fe4d2adad12048d5eccb6499ced85b2b46f5999
|
||||
SIZE (quisk-4.1.3.tar.gz) = 2093660
|
||||
TIMESTAMP = 1555665888
|
||||
SHA256 (quisk-4.1.26.tar.gz) = 6df5ac3adb43fa4daeafec4cef2a19ade33f6d561053302b761f944d98fc1890
|
||||
SIZE (quisk-4.1.26.tar.gz) = 3236756
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- microphone.c.orig 2016-10-25 20:57:54 UTC
|
||||
--- microphone.c.orig 2018-11-21 19:08:22 UTC
|
||||
+++ microphone.c
|
||||
@@ -56,7 +56,7 @@ static int timeVOX = 2000; // VOX han
|
||||
@@ -58,7 +58,7 @@ static int timeVOX = 2000; // VOX han
|
||||
|
||||
static int doTxCorrect = 0; // Corrections for UDP sample transmit
|
||||
static double TxCorrectLevel;
|
||||
|
|
11
comms/quisk/files/patch-quisk.c
Normal file
11
comms/quisk/files/patch-quisk.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- quisk.c.orig 2019-04-19 15:39:19 UTC
|
||||
+++ quisk.c
|
||||
@@ -4065,7 +4065,7 @@ static PyObject * get_bandscope(void) //
|
||||
j2 = floor(d2);
|
||||
sample = (j1 + 1 - d1) * bandscopeAverage[j1];
|
||||
for (j = j1 + 1; j < j2; j++)
|
||||
- sample += cabs(bandscopeAverage[j]);
|
||||
+ sample += fabs(bandscopeAverage[j]);
|
||||
sample += (d2 - j2) * bandscopeAverage[j2];
|
||||
sample = sample / frac;
|
||||
// Normalize to max == 1
|
|
@ -1,6 +1,6 @@
|
|||
--- quisk.py.orig 2016-11-30 13:26:59.000000000 -0500
|
||||
+++ quisk.py 2018-06-17 10:30:03.031192000 -0400
|
||||
@@ -21,6 +21,13 @@
|
||||
--- quisk.py.orig 2019-04-19 15:47:26 UTC
|
||||
+++ quisk.py
|
||||
@@ -21,6 +21,13 @@ os.chdir(os.path.normpath(os.path.dirnam
|
||||
if sys.path[0] != "'.'": # Make sure the current working directory is on path
|
||||
sys.path.insert(0, '.')
|
||||
|
||||
|
@ -9,8 +9,8 @@
|
|||
+locale.setlocale(locale.LC_ALL, '')
|
||||
+cloc = locale.getdefaultlocale()
|
||||
+if locale.nl_langinfo(locale.CODESET) != 'UTF-8':
|
||||
+ locale.setlocale(locale.LC_ALL, (cloc[0], 'UTF-8'))
|
||||
+ locale.setlocale(locale.LC_ALL, (cloc[0], 'UTF-8'))
|
||||
+
|
||||
import wxversion # Thanks to Mario, DH5YM
|
||||
wxversion.ensureMinimal('2.8')
|
||||
|
||||
import wx, wx.html, wx.lib.buttons, wx.lib.stattext, wx.lib.colourdb, wx.grid, wx.richtext
|
||||
import math, cmath, time, traceback, string, select, subprocess
|
||||
import threading, pickle, webbrowser
|
||||
|
|
|
@ -1,22 +1,51 @@
|
|||
--- setup.py.orig 2016-12-08 22:14:02 UTC
|
||||
--- setup.py.orig 2018-11-22 14:56:57 UTC
|
||||
+++ setup.py
|
||||
@@ -12,8 +12,8 @@ fp.write("#Quisk version %s\n" % Version
|
||||
fp.close()
|
||||
@@ -18,18 +18,18 @@ if sys.platform != "win32":
|
||||
except ImportError:
|
||||
print ("Please install the package python-wxgtk3.0 or later")
|
||||
missing = True
|
||||
- if not os.path.isfile("/usr/include/fftw3.h"):
|
||||
- print ("Please install the package libfftw3-dev")
|
||||
- missing = True
|
||||
- if not os.path.isdir("/usr/include/alsa"):
|
||||
- print ("Please install the package libasound2-dev")
|
||||
- missing = True
|
||||
- if not os.path.isfile("/usr/include/portaudio.h"):
|
||||
- print ("Please install the package portaudio19-dev")
|
||||
- missing = True
|
||||
- if not os.path.isdir("/usr/include/pulse"):
|
||||
- print ("please install the package libpulse-dev")
|
||||
- missing = True
|
||||
+# if not os.path.isfile("/usr/include/fftw3.h"):
|
||||
+# print ("Please install the package libfftw3-dev")
|
||||
+# missing = True
|
||||
+# if not os.path.isdir("/usr/include/alsa"):
|
||||
+# print ("Please install the package libasound2-dev")
|
||||
+# missing = True
|
||||
+# if not os.path.isfile("/usr/include/portaudio.h"):
|
||||
+# print ("Please install the package portaudio19-dev")
|
||||
+# missing = True
|
||||
+# if not os.path.isdir("/usr/include/pulse"):
|
||||
+# print ("please install the package libpulse-dev")
|
||||
+# missing = True
|
||||
if missing:
|
||||
ans = raw_input("Do you want to continue (y, N): ")
|
||||
ans = ans.strip()
|
||||
@@ -37,6 +37,8 @@ if sys.platform != "win32":
|
||||
sys.exit(1)
|
||||
|
||||
module1 = Extension ('quisk._quisk',
|
||||
- #include_dirs = ['.'],
|
||||
- #library_dirs = ['.'],
|
||||
+ include_dirs = ['%%LOCALBASE%%/include'],
|
||||
+ library_dirs = ['%%LOCALBASE%%/lib'],
|
||||
libraries = ['asound', 'portaudio', 'pulse', 'fftw3', 'm'],
|
||||
sources = ['quisk.c', 'sound.c', 'sound_alsa.c', 'sound_portaudio.c', 'sound_pulseaudio.c',
|
||||
'is_key_down.c', 'microphone.c', 'utility.c',
|
||||
@@ -116,7 +116,7 @@ control the N8LP LP-PAN panadapter and t
|
||||
author_email = 'jahlstr@gmail.com',
|
||||
url = 'http://james.ahlstrom.name/quisk/',
|
||||
download_url = 'http://james.ahlstrom.name/quisk/',
|
||||
- packages = ['quisk', 'quisk.sdriqpkg', 'quisk.n2adr', 'quisk.softrock', 'quisk.usb'],
|
||||
+ packages = ['quisk', 'quisk.sdriqpkg', 'quisk.n2adr', 'quisk.softrock', 'quisk.usb', 'quisk.hermes'],
|
||||
package_dir = {'quisk' : '.'},
|
||||
package_data = {'quisk' : ['*.txt', '*.html']},
|
||||
ext_modules = Modules,
|
||||
@@ -69,8 +71,6 @@ modulew2 = Extension ('quisk.sdriqpkg.sd
|
||||
|
||||
# Changes for MacOS support thanks to Mario, DL3LSM.
|
||||
modulem1 = Extension ('quisk._quisk',
|
||||
- #include_dirs = ['.'],
|
||||
- #library_dirs = ['.'],
|
||||
libraries = ['portaudio', 'fftw3', 'm', 'pulse'],
|
||||
sources = ['quisk.c', 'sound.c', 'sound_portaudio.c',
|
||||
'is_key_down.c', 'microphone.c', 'utility.c',
|
||||
|
|
Loading…
Reference in a new issue