- Prefer USES=gmake, add OPTIONS_DEFINE=DOCS, and support staging.

- Add an upstream patch to fix kmk_sed with GCC 4.7.

http://trac.netlabs.org/kbuild/ticket/112
http://trac.netlabs.org/kbuild/changeset/2727
This commit is contained in:
Jung-uk Kim 2014-03-13 17:36:30 +00:00
parent 33b3e14dbf
commit e28d234a3c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=348106
2 changed files with 23 additions and 9 deletions

View file

@ -3,7 +3,7 @@
PORTNAME= kBuild PORTNAME= kBuild
DISTVERSION= ${KBUILD_VERSION} DISTVERSION= ${KBUILD_VERSION}
PORTREVISION= 1 PORTREVISION= 2
CATEGORIES= devel CATEGORIES= devel
MASTER_SITES= ftp://ftp.netlabs.org/pub/kbuild/ \ MASTER_SITES= ftp://ftp.netlabs.org/pub/kbuild/ \
http://tmp.chruetertee.ch/ \ http://tmp.chruetertee.ch/ \
@ -16,7 +16,7 @@ COMMENT= Makefile framework
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
USE_AUTOTOOLS= automake autoconf USE_AUTOTOOLS= automake autoconf
USE_GMAKE= yes USES= gmake
CONFLICTS_INSTALL= kBuild-devel-[0-9]* CONFLICTS_INSTALL= kBuild-devel-[0-9]*
@ -46,7 +46,10 @@ ENV=
.SHELL: path="/bin/sh" unsetenv=true .SHELL: path="/bin/sh" unsetenv=true
.endif .endif
NO_STAGE= yes OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch: post-patch:
${REINPLACE_CMD} -e '11269d;11274d' ${WRKSRC}/src/sed/configure ${REINPLACE_CMD} -e '11269d;11274d' ${WRKSRC}/src/sed/configure
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/Config.kmk ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/Config.kmk
@ -66,14 +69,14 @@ do-build:
do-install: do-install:
.for bin in ${KBUILD_BINS} .for bin in ${KBUILD_BINS}
${INSTALL_PROGRAM} ${WRKSRC}/out/${KBUILD_TARGET}.${KBUILD_ARCH}/release/stage${PREFIX}/bin/${bin} ${PREFIX}/bin ${INSTALL_PROGRAM} ${WRKSRC}/out/${KBUILD_TARGET}.${KBUILD_ARCH}/release/stage${PREFIX}/bin/${bin} ${STAGEDIR}${PREFIX}/bin
.endfor .endfor
${MKDIR} ${DATADIR} ${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC}/out/${KBUILD_TARGET}.${KBUILD_ARCH}/release/stage${PREFIX}/share/kBuild && ${COPYTREE_SHARE} \* ${DATADIR}) (cd ${WRKSRC}/out/${KBUILD_TARGET}.${KBUILD_ARCH}/release/stage${PREFIX}/share/kBuild && ${COPYTREE_SHARE} \* ${STAGEDIR}${DATADIR})
.if !defined(NOPORTDOCS) .if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR} ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS} .for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/out/${KBUILD_TARGET}.${KBUILD_ARCH}/release/stage${PREFIX}/share/doc/${PORTNAME}-${KBUILD_VERSION}/${doc} ${DOCSDIR} ${INSTALL_DATA} ${WRKSRC}/out/${KBUILD_TARGET}.${KBUILD_ARCH}/release/stage${PREFIX}/share/doc/${PORTNAME}-${KBUILD_VERSION}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor .endfor
.endif .endif

View file

@ -0,0 +1,11 @@
--- src/sed/lib/regex_internal.c.orig 2012-07-17 18:30:18.000000000 -0400
+++ src/sed/lib/regex_internal.c 2014-03-13 12:52:57.000000000 -0400
@@ -781,7 +781,7 @@
}
static unsigned char
-internal_function __attribute ((pure))
+internal_function
re_string_fetch_byte_case (re_string_t *pstr)
{
if (BE (!pstr->mbs_allocated, 1))