Remove expired ports:
2013-11-07 textproc/stardict2: Newer version available in ports: textproc/stardict3
This commit is contained in:
parent
c1d74378d8
commit
e2a22dd5aa
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=333077
15 changed files with 1 additions and 271 deletions
1
MOVED
1
MOVED
|
@ -5171,3 +5171,4 @@ net-p2p/libtorrent-rasterbar-16|net-p2p/libtorrent-rasterbar|2013-11-06|Moved to
|
|||
net-p2p/libtorrent-rasterbar-python-16|net-p2p/libtorrent-rasterbar-python|2013-11-06|Moved to net-p2p/libtorrent-rasterbar-python since it's a stable version
|
||||
devel/ORBit||2013-11-07|Has expired: EOLed upstream for very long
|
||||
x11/gnome-libs||2013-11-07|Has expired: EOLed upstream for very long
|
||||
textproc/stardict2||2013-11-07|Has expired: Newer version available in ports: textproc/stardict3
|
||||
|
|
|
@ -1421,7 +1421,6 @@
|
|||
SUBDIR += stardict-longman
|
||||
SUBDIR += stardict-oald
|
||||
SUBDIR += stardict-rptts
|
||||
SUBDIR += stardict2
|
||||
SUBDIR += stardict2-dictd_mova
|
||||
SUBDIR += stardict2-quick
|
||||
SUBDIR += stardict3
|
||||
|
|
|
@ -1,57 +0,0 @@
|
|||
# Created by: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= stardict
|
||||
PORTVERSION= 2.4.8
|
||||
PORTREVISION= 15
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= GOOGLE_CODE
|
||||
PROJECTHOST= stardict-3
|
||||
PKGNAMESUFFIX= 2
|
||||
DIST_SUBDIR= stardict
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Cross-platform and international dictionary written in Gtk2
|
||||
|
||||
DEPRECATED= Newer version available in ports: textproc/stardict3
|
||||
EXPIRATION_DATE= 2013-11-07
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
USE_BZIP2= yes
|
||||
USE_GNOME= gnomehack gnomeprefix
|
||||
USES= gettext gmake pkgconfig
|
||||
|
||||
OPTIONS_DEFINE= GNOME
|
||||
OPTIONS_DEFAULT= GNOME
|
||||
|
||||
CONFLICTS= stardict-3.[0-9]*
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.pre.mk>
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MGNOME}
|
||||
USE_GNOME+= libgnomeui
|
||||
GCONF_SCHEMAS= stardict.schemas
|
||||
INSTALLS_OMF= yes
|
||||
PLIST_SUB= GNOME=""
|
||||
.else
|
||||
USE_GNOME+= gtk20
|
||||
CONFIGURE_ARGS+=--disable-gnome-support --disable-schemas-install
|
||||
PLIST_SUB= GNOME="@comment not installed: "
|
||||
.endif
|
||||
|
||||
MAN1= stardict.1
|
||||
|
||||
post-patch:
|
||||
# gcc 2.95 does not know std::string::clear()
|
||||
@${REINPLACE_CMD} -e 's|.clear()|.erase()|' \
|
||||
${WRKSRC}/src/docklet.cpp ${WRKSRC}/src/floatwin.cpp \
|
||||
${WRKSRC}/src/selection.cpp
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (stardict/stardict-2.4.8.tar.bz2) = 3aadc8a1a86ba168db2808f9b5c73c2aa410427aa9a62ae89b2f69c679b11bb4
|
||||
SIZE (stardict/stardict-2.4.8.tar.bz2) = 1234893
|
|
@ -1,11 +0,0 @@
|
|||
--- src/conf.cpp.orig Mon Jul 10 05:23:39 2006
|
||||
+++ src/conf.cpp Mon Jul 10 05:24:36 2006
|
||||
@@ -93,7 +93,7 @@
|
||||
#ifdef _WIN32
|
||||
add_entry("/apps/stardict/preferences/dictionary/tts_path", std::string("C:\\Program Files\\WyabdcRealPeopleTTS\nC:\\Program Files\\OtdRealPeopleTTS\nWyabdcRealPeopleTTS\nOtdRealPeopleTTS"));
|
||||
#else
|
||||
- add_entry("/apps/stardict/preferences/dictionary/tts_path", std::string("/usr/share/WyabdcRealPeopleTTS\n/usr/share/OtdRealPeopleTTS"));
|
||||
+ add_entry("/apps/stardict/preferences/dictionary/tts_path", std::string("/usr/local/share/WyabdcRealPeopleTTS\n/usr/local/share/OtdRealPeopleTTS"));
|
||||
#endif
|
||||
add_entry("/apps/stardict/preferences/dictionary/history", get_default_history_filename());
|
||||
add_entry("/apps/stardict/preferences/dictionary/only_export_word", true);
|
|
@ -1,11 +0,0 @@
|
|||
--- src/docklet.h.orig Tue Sep 23 18:19:44 2003
|
||||
+++ src/docklet.h Tue Jan 18 02:20:01 2005
|
||||
@@ -7,7 +7,7 @@
|
||||
enum DockLetIconType {
|
||||
DOCKLET_NORMAL_ICON,
|
||||
DOCKLET_SCAN_ICON,
|
||||
- DOCKLET_STOP_ICON,
|
||||
+ DOCKLET_STOP_ICON
|
||||
};
|
||||
|
||||
class DockLet{
|
|
@ -1,10 +0,0 @@
|
|||
--- src/inifile.hpp.orig 2005-12-24 21:38:54.000000000 -0800
|
||||
+++ src/inifile.hpp 2013-09-26 11:29:14.007146339 -0700
|
||||
@@ -1,6 +1,7 @@
|
||||
#ifndef _INIFILE_HPP_
|
||||
#define _INIFILE_HPP_
|
||||
|
||||
+#include <cstdlib>
|
||||
#include <map>
|
||||
#include <string>
|
||||
|
|
@ -1,10 +0,0 @@
|
|||
--- src/lib/common.hpp.orig 2006-06-29 20:54:59.000000000 -0700
|
||||
+++ src/lib/common.hpp 2013-09-26 11:27:56.369120859 -0700
|
||||
@@ -2,6 +2,7 @@
|
||||
#define _COMMON_HPP_
|
||||
|
||||
#include <glib.h>
|
||||
+#include <cstdlib>
|
||||
#include <list>
|
||||
#include <string>
|
||||
|
|
@ -1,29 +0,0 @@
|
|||
--- ./src/mainwin.h.orig 2006-06-29 22:29:34.000000000 -0700
|
||||
+++ ./src/mainwin.h 2008-01-26 13:26:47.532687040 -0800
|
||||
@@ -22,7 +22,7 @@
|
||||
TEXT_WIN_PATTERN_NOT_FOUND,
|
||||
TEXT_WIN_TIPS, // when the word entry is empty,it will show tip
|
||||
TEXT_WIN_INFO,
|
||||
- TEXT_WIN_TREEDICT,
|
||||
+ TEXT_WIN_TREEDICT
|
||||
};
|
||||
|
||||
enum ListWinListWordType {
|
||||
@@ -68,8 +68,6 @@
|
||||
static void on_main_menu_about_activate(GtkMenuItem *menuitem, TopWin *oTopWin);
|
||||
static void on_main_menu_quit_activate(GtkMenuItem *menuitem, TopWin *oTopWin);
|
||||
|
||||
- static void ClipboardReceivedCallback(GtkClipboard *clipboard, const gchar *text, gpointer data);
|
||||
-
|
||||
void LoadHistory(void);
|
||||
void SaveHistory(void);
|
||||
public:
|
||||
@@ -79,6 +77,8 @@
|
||||
TopWin();
|
||||
~TopWin();
|
||||
|
||||
+ static void ClipboardReceivedCallback(GtkClipboard *clipboard, const gchar *text, gpointer data);
|
||||
+
|
||||
void Create(GtkWidget *vbox);
|
||||
void Destroy(void);
|
||||
void SetText(const gchar *word, bool notify=true);
|
|
@ -1,8 +0,0 @@
|
|||
--- src/stardict-application-server.cpp.orig Tue Sep 23 18:19:48 2003
|
||||
+++ src/stardict-application-server.cpp Tue Jan 18 02:25:54 2005
|
||||
@@ -117,4 +117,4 @@
|
||||
StardictApplicationServer,
|
||||
GNOME_Stardict_Application,
|
||||
BONOBO_TYPE_OBJECT,
|
||||
- stardict_application_server);
|
||||
+ stardict_application_server)
|
|
@ -1,12 +0,0 @@
|
|||
--- ./src/stardict.cpp.orig 2006-07-02 23:19:31.000000000 -0700
|
||||
+++ ./src/stardict.cpp 2013-09-05 17:40:53.829831298 -0700
|
||||
@@ -873,7 +873,8 @@
|
||||
gtk_widget_show_all(search_window);
|
||||
|
||||
//clock_t t=clock();
|
||||
- std::vector<gchar *> reslist[oLibs.ndicts()];
|
||||
+ std::vector<gchar *> *reslist;
|
||||
+ reslist = new std::vector<gchar *>[oLibs.ndicts()];
|
||||
if (oLibs.LookupData(sWord, reslist, updateSearchDialog, &Dialog, &cancel)) {
|
||||
oMidWin.oIndexWin.oListWin.list_word_type = LIST_WIN_DATA_LIST;
|
||||
for (int i=0; i<oLibs.ndicts(); i++) {
|
|
@ -1,12 +0,0 @@
|
|||
--- tests/t_lookupdata.cpp.orig 2006-06-19 00:16:21.000000000 -0700
|
||||
+++ tests/t_lookupdata.cpp 2013-09-26 11:31:36.077140174 -0700
|
||||
@@ -18,7 +18,8 @@
|
||||
|
||||
Libs libs(NULL, false, false, 0);
|
||||
libs.load(dirs, List(), List());
|
||||
- std::vector<gchar *> reslist[libs.ndicts()];
|
||||
+ std::vector<gchar *> *reslist;
|
||||
+ reslist = new std::vector<gchar *>[libs.ndicts()];
|
||||
if (libs.LookupData("letter", reslist, NULL, NULL, NULL))
|
||||
return EXIT_SUCCESS;
|
||||
else
|
|
@ -1,5 +0,0 @@
|
|||
StarDict is a Cross-Platform and international dictionary written in Gtk2.
|
||||
It has powerful features such as "Glob-style pattern matching," "Scan
|
||||
selection word," "Fuzzy query," etc.
|
||||
|
||||
WWW: http://stardict.sourceforge.net/
|
|
@ -1,9 +0,0 @@
|
|||
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
|
||||
|
||||
Now it's time to install some dictionary files:
|
||||
|
||||
chinese/stardict-dict-zh_CN Simplified Chinese - English
|
||||
chinese/stardict-dict-zh_TW Traditional Chinese - English
|
||||
japanese/stardict-dict-ja Japanese - English
|
||||
|
||||
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
|
|
@ -1,94 +0,0 @@
|
|||
bin/stardict
|
||||
%%GNOME%%libdata/bonobo/servers/GNOME_Stardict.server
|
||||
share/applications/stardict.desktop
|
||||
%%GNOME%%share/gnome/help/stardict/C/figures/stardict_float_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/C/figures/stardict_main_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/C/figures/stardict_notification_area.png
|
||||
%%GNOME%%share/gnome/help/stardict/C/legal.xml
|
||||
%%GNOME%%share/gnome/help/stardict/C/stardict.xml
|
||||
%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_float_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_main_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/mk/figures/stardict_notification_area.png
|
||||
%%GNOME%%share/gnome/help/stardict/mk/legal.xml
|
||||
%%GNOME%%share/gnome/help/stardict/mk/stardict.xml
|
||||
%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_float_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_main_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/nl/figures/stardict_notification_area.png
|
||||
%%GNOME%%share/gnome/help/stardict/nl/legal.xml
|
||||
%%GNOME%%share/gnome/help/stardict/nl/stardict.xml
|
||||
%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_float_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_main_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/ru/figures/stardict_notification_area.png
|
||||
%%GNOME%%share/gnome/help/stardict/ru/legal.xml
|
||||
%%GNOME%%share/gnome/help/stardict/ru/stardict.xml
|
||||
%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_float_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_main_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/uk/figures/stardict_notification_area.png
|
||||
%%GNOME%%share/gnome/help/stardict/uk/legal.xml
|
||||
%%GNOME%%share/gnome/help/stardict/uk/stardict.xml
|
||||
%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_float_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_main_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/zh_CN/figures/stardict_notification_area.png
|
||||
%%GNOME%%share/gnome/help/stardict/zh_CN/legal.xml
|
||||
%%GNOME%%share/gnome/help/stardict/zh_CN/stardict.xml
|
||||
%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_float_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_main_window.png
|
||||
%%GNOME%%share/gnome/help/stardict/zh_TW/figures/stardict_notification_area.png
|
||||
%%GNOME%%share/gnome/help/stardict/zh_TW/legal.xml
|
||||
%%GNOME%%share/gnome/help/stardict/zh_TW/stardict.xml
|
||||
%%GNOME%%share/idl/GNOME_Stardict.idl
|
||||
%%GNOME%%share/omf/stardict/stardict-C.omf
|
||||
%%GNOME%%share/omf/stardict/stardict-mk.omf
|
||||
%%GNOME%%share/omf/stardict/stardict-nl.omf
|
||||
%%GNOME%%share/omf/stardict/stardict-ru.omf
|
||||
%%GNOME%%share/omf/stardict/stardict-uk.omf
|
||||
%%GNOME%%share/omf/stardict/stardict-zh_CN.omf
|
||||
%%GNOME%%share/omf/stardict/stardict-zh_TW.omf
|
||||
share/pixmaps/stardict.png
|
||||
share/stardict/pixmaps/docklet_normal.png
|
||||
share/stardict/pixmaps/docklet_scan.png
|
||||
share/stardict/pixmaps/docklet_stop.png
|
||||
share/stardict/pixmaps/index_appendix.png
|
||||
share/stardict/pixmaps/index_dictlist.png
|
||||
share/stardict/pixmaps/index_wazard.png
|
||||
share/stardict/pixmaps/splash.png
|
||||
share/stardict/sounds/buttonactive.wav
|
||||
share/stardict/sounds/menushow.wav
|
||||
share/locale/cs/LC_MESSAGES/stardict.mo
|
||||
share/locale/de/LC_MESSAGES/stardict.mo
|
||||
share/locale/el/LC_MESSAGES/stardict.mo
|
||||
share/locale/fr/LC_MESSAGES/stardict.mo
|
||||
share/locale/hr/LC_MESSAGES/stardict.mo
|
||||
share/locale/hu/LC_MESSAGES/stardict.mo
|
||||
share/locale/ku/LC_MESSAGES/stardict.mo
|
||||
share/locale/mk/LC_MESSAGES/stardict.mo
|
||||
share/locale/nl/LC_MESSAGES/stardict.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/stardict.mo
|
||||
share/locale/ru/LC_MESSAGES/stardict.mo
|
||||
share/locale/sk/LC_MESSAGES/stardict.mo
|
||||
share/locale/tt/LC_MESSAGES/stardict.mo
|
||||
share/locale/uk/LC_MESSAGES/stardict.mo
|
||||
share/locale/vi/LC_MESSAGES/stardict.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/stardict.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/stardict.mo
|
||||
@dirrmtry share/locale/tt/LC_MESSAGES
|
||||
@dirrmtry share/locale/tt
|
||||
@dirrm share/stardict/sounds
|
||||
@dirrm share/stardict/pixmaps
|
||||
@dirrmtry share/stardict
|
||||
%%GNOME%%@dirrm share/omf/stardict
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/zh_TW/figures
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/zh_TW
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/zh_CN/figures
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/zh_CN
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/uk/figures
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/uk
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/ru/figures
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/ru
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/nl/figures
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/nl
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/mk/figures
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/mk
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/C/figures
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict/C
|
||||
%%GNOME%%@dirrm share/gnome/help/stardict
|
Loading…
Reference in a new issue