Remove expired port:
2013-11-01 devel/ruby-io-reactor: Does not work with Ruby 1.9
This commit is contained in:
parent
804d58013a
commit
e2edca1c4c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=332610
7 changed files with 1 additions and 102 deletions
1
MOVED
1
MOVED
|
@ -5162,3 +5162,4 @@ lang/dragonegg46||2013-11-03|Has expired: Upgrade to dragonegg46-33 or dragonegg
|
|||
sysutils/mktool||2013-11-03|Has expired
|
||||
databases/ruby-memcache||2013-11-03|Has expired: Development has been abandoned upstream
|
||||
deskutils/blogtk||2013-11-03|Has expired: This is dead upstream and is no longer being maintained
|
||||
devel/ruby-io-reactor||2013-11-03|Has expired: Does not work with Ruby 1.9
|
||||
|
|
|
@ -3998,7 +3998,6 @@
|
|||
SUBDIR += ruby-gio2
|
||||
SUBDIR += ruby-glib2
|
||||
SUBDIR += ruby-intl
|
||||
SUBDIR += ruby-io-reactor
|
||||
SUBDIR += ruby-korundum
|
||||
SUBDIR += ruby-krossruby
|
||||
SUBDIR += ruby-langscan
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= io-reactor
|
||||
PORTVERSION= 1.0.4
|
||||
CATEGORIES= devel ruby
|
||||
MASTER_SITES= http://deveiate.org/code/
|
||||
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
|
||||
DISTNAME= io-reactor-${PORTVERSION}
|
||||
DIST_SUBDIR= ruby
|
||||
|
||||
MAINTAINER= ruby@FreeBSD.org
|
||||
COMMENT= Ruby module that implements an asynchronous multiplexed IO Reactor
|
||||
|
||||
DEPRECATED= Does not work with Ruby 1.9
|
||||
EXPIRATION_DATE= 2013-11-01
|
||||
|
||||
USE_RUBY= yes
|
||||
USE_RAKE= yes
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
DOCS= ChangeLog README
|
||||
EXAMPLES= examples/*
|
||||
|
||||
BUILD_DEPENDS= rubygem-rdoc>=0:${PORTSDIR}/devel/rubygem-rdoc
|
||||
|
||||
NO_STAGE= yes
|
||||
do-install:
|
||||
cd ${WRKSRC}; ${RUBY} ${RAKE_BIN} install
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${RUBY_MODDOCDIR}
|
||||
.for f in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
|
||||
.endfor
|
||||
${MKDIR} ${RUBY_MODEXAMPLESDIR}
|
||||
.for f in ${EXAMPLES}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.if ${RUBY_VER} == 1.9
|
||||
BROKEN= does not build with ruby 1.9
|
||||
.endif
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (ruby/io-reactor-1.0.4.tar.gz) = efb9b23ac888de253ca40a80f4545805944833080226039cb2cea8cba21cab17
|
||||
SIZE (ruby/io-reactor-1.0.4.tar.gz) = 35828
|
|
@ -1,36 +0,0 @@
|
|||
--- Rakefile.orig 2008-08-19 20:14:31.000000000 +0000
|
||||
+++ Rakefile 2013-02-27 03:35:18.000000000 +0000
|
||||
@@ -25,9 +25,9 @@
|
||||
require 'rbconfig'
|
||||
require 'rubygems'
|
||||
require 'rake'
|
||||
-require 'rake/rdoctask'
|
||||
+require 'rdoc/task'
|
||||
require 'rake/testtask'
|
||||
-require 'rake/packagetask'
|
||||
+require 'rubygems/package_task'
|
||||
require 'rake/clean'
|
||||
|
||||
$dryrun = false
|
||||
--- ./rake/packaging.rb.orig 2013-02-27 03:38:49.000000000 +0000
|
||||
+++ ./rake/packaging.rb 2013-02-27 03:39:06.000000000 +0000
|
||||
@@ -5,7 +5,7 @@
|
||||
|
||||
require 'rbconfig'
|
||||
require 'rake/packagetask'
|
||||
-require 'rake/gempackagetask'
|
||||
+require 'rubygems/package_task'
|
||||
|
||||
include Config
|
||||
|
||||
--- rake/rdoc.rb.orig 2013-02-27 03:40:32.000000000 +0000
|
||||
+++ rake/rdoc.rb 2013-02-27 03:40:53.000000000 +0000
|
||||
@@ -3,7 +3,7 @@
|
||||
# $Id: rdoc.rb 35 2008-08-19 01:10:27Z deveiant $
|
||||
#
|
||||
|
||||
-require 'rake/rdoctask'
|
||||
+require 'rdoc/task'
|
||||
$have_darkfish = false
|
||||
|
||||
begin
|
|
@ -1,8 +0,0 @@
|
|||
This module is a pure-Ruby implementation of an asynchronous
|
||||
multiplexed IO Reactor which is based on the Reactor design pattern
|
||||
found in _Pattern-Oriented Software Architecture, Volume 2: Patterns
|
||||
for Concurrent and Networked Objects_. It allows a single thread to
|
||||
demultiplex and dispatch events from one or more IO objects to an
|
||||
appropriate handler.
|
||||
|
||||
WWW: http://www.deveiate.org/code/IO-Reactor.html
|
|
@ -1,9 +0,0 @@
|
|||
%%RUBY_SITELIBDIR%%/io/reactor.rb
|
||||
@dirrmtry %%RUBY_SITELIBDIR%%/io
|
||||
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
|
||||
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
|
||||
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/chatserver.rb
|
||||
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/simple.rb
|
||||
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/simpleserver.rb
|
||||
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
|
Loading…
Reference in a new issue