security/slurpie: fix build with clang
- Fix build with clang, main int arg - NOPORTDOCS -> PORT_OPTIONS:MDOCS - Trim Makefile header Approved by: culot / jpaetzel (mentors, implicit)
This commit is contained in:
parent
37a9666c75
commit
e2ee40fb24
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=321036
3 changed files with 30 additions and 7 deletions
|
@ -1,10 +1,5 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: slurpie
|
||||
# Date created: Sun Feb 12, 2000
|
||||
# Whom: David O'Brien (obrien@NUXI.com)
|
||||
#
|
||||
# Created by: David O'Brien (obrien@NUXI.com)
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= slurpie
|
||||
PORTVERSION= 2.0b
|
||||
|
@ -20,6 +15,8 @@ COMMENT= A passwd file cracker (supports distributed nodes)
|
|||
PLIST_FILES= sbin/slurp sbin/slurpie
|
||||
PORTDOCS= README
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-patch:
|
||||
# Fix for GCC 4.2
|
||||
@${REINPLACE_CMD} -e \
|
||||
|
@ -28,7 +25,7 @@ post-patch:
|
|||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/slurp* ${PREFIX}/sbin
|
||||
.if !defined(NOPORTDOCS)
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
|
|
13
security/slurpie/files/patch-src_mater.c
Normal file
13
security/slurpie/files/patch-src_mater.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git src/master.c src/master.c
|
||||
index 4b24f9b..683d9a6 100644
|
||||
--- src/master.c
|
||||
+++ src/master.c
|
||||
@@ -132,7 +132,7 @@ char *get_time_str( u_int seconds )
|
||||
return timestr;
|
||||
}
|
||||
|
||||
-int main( int argc, u_char **argv )
|
||||
+int main( int argc, char **argv )
|
||||
{
|
||||
static unsigned id, init_time;
|
||||
|
13
security/slurpie/files/patch-src_node.c
Normal file
13
security/slurpie/files/patch-src_node.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git src/node.c src/node.c
|
||||
index 28d5d8a..3135ea0 100644
|
||||
--- src/node.c
|
||||
+++ src/node.c
|
||||
@@ -102,7 +102,7 @@ void clean_up( int exit_status )
|
||||
|
||||
|
||||
/////////////////////////////
|
||||
-int main( int argc, u_char **argv )
|
||||
+int main( int argc, char **argv )
|
||||
{
|
||||
u_int exit_state = 0;
|
||||
global.self.addr.sin_port = 0;
|
Loading…
Reference in a new issue