www/py-requests: Chase dns/py-idna update
ports r552091 updated idna to 2.10, breaking www/py-requests, and its dependents, with: raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'idna<2.9,>=2.5' distribution was not found and is required by requests Backport an upstream commit [1] that kinda addresses "most" of the root cause problem of this for future dependency updates, by not pinning on minor versions. [1] https://github.com/psf/requests/pull/5342 PR: 245938 Reported by: lbartoletti, ohauer MFH: 2020Q3 X-MFH-With: 552091
This commit is contained in:
parent
0395c114f0
commit
e355f8e5dc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=552095
2 changed files with 28 additions and 10 deletions
|
@ -3,6 +3,7 @@
|
|||
|
||||
PORTNAME= requests
|
||||
PORTVERSION= 2.22.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= www python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -19,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>=2017.4.17:security/py-certifi@${PY_
|
|||
${PYTHON_PKGNAMEPREFIX}urllib3>=1.21.1:net/py-urllib3@${PY_FLAVOR}
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-mock>0:devel/py-pytest-mock@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pytest>=2.8.0:devel/py-pytest@${PY_FLAVOR}
|
||||
${PYTHON_PKGNAMEPREFIX}pytest>=2.8.0:devel/py-pytest@${PY_FLAVOR} \
|
||||
|
||||
# Actually 2.7,3.5+
|
||||
USES= python
|
||||
|
|
|
@ -1,12 +1,29 @@
|
|||
# pytest-cov and its dependencies are not compulsory
|
||||
#
|
||||
# Subject: [PATCH] Limit dependencies to major instead of minor (#5342
|
||||
# From c46f55bd48dabc02f033d252f8c64e2011f37361 Mon Sep 17 00:00:00 2001
|
||||
# From: Chris Withers <chris@withers.org>
|
||||
# Date: Tue, 18 Feb 2020 14:58:27 +0000
|
||||
|
||||
--- setup.py.orig 2019-01-22 02:52:54 UTC
|
||||
--- setup.py.orig 2019-05-16 14:22:45 UTC
|
||||
+++ setup.py
|
||||
@@ -50,7 +50,6 @@ requires = [
|
||||
]
|
||||
test_requirements = [
|
||||
'pytest-httpbin==0.0.7',
|
||||
- 'pytest-cov',
|
||||
'pytest-mock',
|
||||
'pytest-xdist',
|
||||
'PySocks>=1.5.6, !=1.5.7',
|
||||
@@ -42,8 +42,8 @@ if sys.argv[-1] == 'publish':
|
||||
packages = ['requests']
|
||||
|
||||
requires = [
|
||||
- 'chardet>=3.0.2,<3.1.0',
|
||||
- 'idna>=2.5,<2.9',
|
||||
+ 'chardet>=3.0.2,<4',
|
||||
+ 'idna>=2.5,<3',
|
||||
'urllib3>=1.21.1,<1.26,!=1.25.0,!=1.25.1',
|
||||
'certifi>=2017.4.17'
|
||||
|
||||
@@ -101,7 +101,7 @@ setup(
|
||||
cmdclass={'test': PyTest},
|
||||
tests_require=test_requirements,
|
||||
extras_require={
|
||||
- 'security': ['pyOpenSSL >= 0.14', 'cryptography>=1.3.4', 'idna>=2.0.0'],
|
||||
+ 'security': ['pyOpenSSL >= 0.14', 'cryptography>=1.3.4'],
|
||||
'socks': ['PySocks>=1.5.6, !=1.5.7'],
|
||||
'socks:sys_platform == "win32" and python_version == "2.7"': ['win_inet_pton'],
|
||||
},
|
||||
|
|
Loading…
Reference in a new issue