- Update to 0.6.17

PR:		ports/126345
Submitted by:	bf <bf2006a@yahoo.com>
Approved by:	maintainer timeout (1 month)
This commit is contained in:
Pav Lucistnik 2008-11-14 14:03:45 +00:00
parent 1b8b768f5e
commit e35ec6c5c5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=222840
11 changed files with 63 additions and 159 deletions

View file

@ -6,17 +6,42 @@
#
PORTNAME= libpst
PORTVERSION= 0.5.1
PORTVERSION= 0.6.17
CATEGORIES= mail converters
MASTER_SITES= http://alioth.debian.org/frs/download.php/844/
EXTRACT_SUFX= .tgz
MASTER_SITES= http://www.five-ten-sg.com/libpst/packages/
MAINTAINER= natey@natey.com
COMMENT= A tool for converting Outlook .pst files to Unix mbox format
COMMENT= A tool for converting Outlook .pst files to mbox and other formats
USE_GMAKE= YES
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_ICONV= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -liconv
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= readpst.1 readpstlog.1
PLIST_FILES= bin/readpst bin/readpstlog bin/lspst
.if exists(${LOCALBASE}/bin/convert) || defined(WITH_PST2DII)
BUILD_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
PLIST_SUB+= PST2DII=""
.else
PLIST_SUB+= PST2DII="@comment "
.endif
MAN1= lspst.1 pst2dii.1 pst2ldif.1 readpst.1 readpstlog.1
MAN5= outlook.pst.5
post-patch:
${FIND} -X ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e 's/malloc.h/stdlib.h/g'
${REINPLACE_CMD} -e 's;doc\/@PACKAGE@-@VERSION@;doc\/@PACKAGE@;g' ${WRKSRC}/Makefile.in \
${WRKSRC}/html/Makefile.in
.ifdef(NOPORTDOCS)
INSTALL_TARGET= install-exec
post-install:
@(cd ${WRKSRC}/man && ${GMAKE} ${MAKE_ARGS} install)
.endif
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (libpst-0.5.1.tgz) = 0a80562bf7c503f9d3fdd96e0de10408
SHA256 (libpst-0.5.1.tgz) = 1e4a0e7a8d1572e8fe77c62a0e747b832bb93814fd1df624077ad0f879477857
SIZE (libpst-0.5.1.tgz) = 89256
MD5 (libpst-0.6.17.tar.gz) = b2599f5d9b946ae4468188f413653e03
SHA256 (libpst-0.6.17.tar.gz) = 06ea3c9ebe88316efdafccf041014d44aabc9992fc14f5fc758a48ac52a6bd62
SIZE (libpst-0.6.17.tar.gz) = 718910

View file

@ -1,40 +0,0 @@
--- Makefile.orig Wed Nov 17 14:16:02 2004
+++ Makefile Mon Sep 26 17:34:36 2005
@@ -6,10 +6,10 @@
#---------------- Do not modify below this point ------------------
-INSTALL_DIR := $(INSTALL) -p -d -o root -g root -m 0755
-INSTALL_FILE := $(INSTALL) -p -o root -g root -m 0644
-INSTALL_PROGRAM := $(INSTALL) -p -o root -g root -m 0755 # -s
-INSTALL_SCRIPT := $(INSTALL) -p -o root -g root -m 0755
+INSTALL_DIR := $(INSTALL) -p -d -o root -g wheel -m 0755
+INSTALL_FILE := $(INSTALL) -p -o root -g wheel -m 0644
+INSTALL_PROGRAM := $(INSTALL) -p -o root -g wheel -m 0755 # -s
+INSTALL_SCRIPT := $(INSTALL) -p -o root -g wheel -m 0755
VERSION = $(shell cat VERSION)
@@ -53,11 +53,18 @@
distclean: clean
rm -f libpst-*.tar.gz
-install: all
+install: installbin
+
+installbin: all
$(INSTALL_DIR) $(DESTDIR)$(PREFIX)/bin
- $(INSTALL_PROGRAM) readpst{,log} $(DESTDIR)$(PREFIX)/bin
- $(INSTALL_DIR) $(DESTDIR)$(PREFIX)/share/man/man1
- $(INSTALL_FILE) readpst{,log}.1 $(DESTDIR)$(PREFIX)/share/man/man1/
+ $(INSTALL_PROGRAM) readpst $(DESTDIR)$(PREFIX)/bin
+ $(INSTALL_PROGRAM) readpstlog $(DESTDIR)$(PREFIX)/bin
+ $(INSTALL_PROGRAM) lspst $(DESTDIR)$(PREFIX)/bin
+ $(INSTALL_DIR) $(DESTDIR)$(PREFIX)/man/man1
+ $(INSTALL_FILE) readpst.1 $(DESTDIR)$(PREFIX)/man/man1/
+ $(INSTALL_FILE) readpstlog.1 $(DESTDIR)$(PREFIX)/man/man1/
+
+installdocs:
$(INSTALL_DIR) $(DESTDIR)$(PREFIX)/share/doc/libpst
$(INSTALL_FILE) $(DOCS) $(DESTDIR)$(PREFIX)/share/doc/libpst/

View file

@ -1,33 +0,0 @@
--- libpst.c.orig Sun Sep 25 14:38:16 2005
+++ libpst.c Sun Sep 25 14:39:04 2005
@@ -261,7 +261,7 @@
int32_t pst_attach_to_file(pst_file *pf, pst_item_attach *attach, FILE* fp) {
pst_index_ll *ptr;
struct holder h = {NULL, fp, 0, "", 0};
- int32_t size;
+ int32_t size = 0;
DEBUG_ENT("pst_attach_to_file");
if (attach->id_val != -1) {
ptr = _pst_getID(pf, attach->id_val);
@@ -283,7 +283,7 @@
int32_t pst_attach_to_file_base64(pst_file *pf, pst_item_attach *attach, FILE* fp) {
pst_index_ll *ptr;
struct holder h = {NULL, fp, 1, "", 0};
- int32_t size;
+ int32_t size = 0;
char *c;
DEBUG_ENT("pst_attach_to_file_base64");
if (attach->id_val != -1) {
@@ -373,10 +373,10 @@
pst_desc_ll *p;
pst_num_array *na;
// pst_index_ll *list;
- pst_index2_ll *list2;//, *t;
+ pst_index2_ll *list2 = NULL;//, *t;
unsigned char * buffer=NULL, *headerbuffer=NULL;//, *tc;
pst_x_attrib xattrib;
- int32_t bptr = 0, bsize, hsize, tint, err=0, x;
+ int32_t bptr = 0, bsize = 0, hsize = 0, tint, err=0, x;
pst_x_attrib_ll *ptr, *p_head=NULL, *p_sh=NULL, *p_sh2=NULL;
char *wt;

View file

@ -1,13 +0,0 @@
--- libpst.h.orig Sat Sep 24 23:28:03 2005
+++ libpst.h Sun Sep 25 14:23:06 2005
@@ -14,8 +14,9 @@
#ifndef FILETIME_DEFINED
#define FILETIME_DEFINED
+#include <sys/types.h>
//Win32 Filetime struct - copied from WINE
-typedef struct {
+typedef struct _FILETIME {
u_int32_t dwLowDateTime;
u_int32_t dwHighDateTime;
} FILETIME;

View file

@ -1,21 +0,0 @@
--- lspst.c.orig Sun Sep 25 13:39:52 2005
+++ lspst.c Sun Sep 25 14:24:31 2005
@@ -37,7 +37,9 @@
char *rfc2426_escape(char *str);
char *rfc2445_datetime_format(FILETIME *ft);
// }}}1
+#ifndef DEBUG_MAIN
#define DEBUG_MAIN(x) debug_print x;
+#endif // DEBUG_MAIN
// int main(int argc, char** argv) {{{1
int main(int argc, char** argv) {
@@ -47,7 +49,7 @@
pst_desc_ll *d_ptr;
char *temp = NULL; //temporary char pointer
int skip_child = 0;
- struct file_ll *f, *head;
+ struct file_ll *f = NULL, *head;
// }}}2
if (argc <= 1)

View file

@ -1,11 +0,0 @@
--- lzfu.c.orig Mon Sep 26 17:26:39 2005
+++ lzfu.c Mon Sep 26 17:26:58 2005
@@ -16,7 +16,7 @@
#include <stdio.h>
#ifndef _MSC_VER
-#include <stdint.h>
+#include <inttypes.h>
#endif
#ifdef _MSC_VER

View file

@ -1,11 +0,0 @@
--- readpst.c.orig Sun Sep 25 14:24:59 2005
+++ readpst.c Sun Sep 25 14:25:19 2005
@@ -144,7 +144,7 @@
int base64_body = 0;
// int encrypt = 0;
FILE *fp;
- char *enc; // base64 encoded attachment
+ char *enc = NULL; // base64 encoded attachment
char *boundary = NULL, *b1, *b2; // the boundary marker between multipart sections
char *temp = NULL; //temporary char pointer
int attach_num = 0;

View file

@ -1,16 +0,0 @@
--- readpstlog.c.orig Sun Sep 25 14:25:38 2005
+++ readpstlog.c Sun Sep 25 14:29:10 2005
@@ -21,11 +21,11 @@
int main(int argc, char** argv) {
int *i=NULL, x, ptr, stop=0, flag;
- char *fname, *buf, format, rec_type;
+ char *fname, *buf, format = ' ', rec_type;
unsigned char version;
int *show_type=NULL, show_size=0;
int *ex_type=NULL, ex_size=0;
- unsigned int funcname, filename, text, end, dtype, line, c;
+ unsigned int funcname=0, filename=0, text=0, end=0, dtype=0, line=0, c;
FILE *fp;
struct _debug_file_rec_m mfile_rec;
struct _debug_file_rec_l lfile_rec;

View file

@ -1,9 +1,14 @@
readpst: A tool for converting Outlook .pst files to Unix mbox format
readpst: A tool for converting Outlook .pst files to Unix mbox and
other formats.
The aim of this project is to provide libraries and applications for the
conversion of Outlook and Outlook Express data files to Linux MBOX format.
This version can now convert both 32-bit Outlook files (pre-2003),
and the 64-bit Outlook 2003 .pst files. Utilities are supplied to
convert email messages to both mbox and MH mailbox formats, and to
DII load file format for use with many of the CT Summation products.
Contacts can be converted to a simple list, to vcard format, or to
.ldif format for import to an LDAP server.
WWW: http://alioth.debian.org/projects/libpst/
WWW: http://www.five-ten-sg.com/libpst/
- Natey
natey@natey.com

19
mail/libpst/pkg-plist Normal file
View file

@ -0,0 +1,19 @@
bin/lspst
bin/pst2ldif
bin/readpst
bin/readpstlog
%%PST2DII%%bin/pst2dii
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/libpst.pdf
%%PORTDOCS%%%%DOCSDIR%%/rn01re01.html
%%PORTDOCS%%%%DOCSDIR%%/rn01re02.html
%%PORTDOCS%%%%DOCSDIR%%/rn01re03.html
%%PORTDOCS%%%%DOCSDIR%%/rn01re04.html
%%PORTDOCS%%%%DOCSDIR%%/rn01re05.html
%%PORTDOCS%%%%DOCSDIR%%/rn01re06.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%