foo2zjs is an open source printer driver for printers that use the Zenographics

ZjStream wire protocol for their print data, such as the Minolta/QMS magicolor
2300 DL or Konica Minolta magicolor 2430 DL. These printers are often
erroneously referred to as winprinters or GDI printers.

However, Microsoft GDI only mandates the API between an application and the
printer driver, not the protocol on the wire between the printer driver and the
printer. In fact, ZjStream printers are raster printers which happen to use a
very efficient wire protocol which was developed by Zenographics and licensed
by most major printer manufacturers for at least some of their product lines.

ZjStream is just one of many wire protocols that are in use today, such as
Postscript, PCL, Epson, etc.

WWW:	http://foo2zjs.rkkda.com/

PR:		ports/94592
Submitted by:	Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
This commit is contained in:
Pav Lucistnik 2006-05-07 11:38:51 +00:00
parent 1d0343d4be
commit e369d75deb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=161560
7 changed files with 193 additions and 0 deletions

View file

@ -71,6 +71,7 @@
SUBDIR += flpsed
SUBDIR += font2svg
SUBDIR += fontforge
SUBDIR += foo2zjs
SUBDIR += foomatic-db
SUBDIR += foomatic-db-engine
SUBDIR += foomatic-db-hpijs

43
print/foo2zjs/Makefile Normal file
View file

@ -0,0 +1,43 @@
# New ports collection makefile for: foo2zjs
# Date created: 2006-03-17
# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
#
# $FreeBSD$
#
PORTNAME= foo2zjs
PORTVERSION= 20060504
CATEGORIES= print
MASTER_SITES= http://foo2zjs.rkkda.com/
DISTNAME= ${PORTNAME}
MAINTAINER= acardenas@bsd.org.pe
COMMENT= Driver for printers that use the ZjStream wire protocol
LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
RUN_DEPENDS= ${LOCALBASE}/share/foomatic/db/oldprinterids:${PORTSDIR}/print/foomatic-db \
foomatic-rip:${PORTSDIR}/print/foomatic-filters
USE_GHOSTSCRIPT= yes
USE_GMAKE= yes
SUB_FILES= pkg-message
MAN1= foo2hp.1 foo2oak-wrapper.1 foo2zjs-wrapper.1 oakdecode.1 foo2hp2600-wrapper.1 foo2oak.1 foo2zjs.1 zjsdecode.1
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS|CFLAGS?|g' -e 's|^PREFIX|PREFIX?|g' ${WRKSRC}/icc2ps/Makefile
post-install:
@cd ${WRKSRC} && \
${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1/
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ChangeLog README manual.pdf
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

3
print/foo2zjs/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (foo2zjs.tar.gz) = c44f2de01457308cca690b2e5e9dfbc7
SHA256 (foo2zjs.tar.gz) = f517886d5b1062ac360feff856fd6eac9fa52b2a2278e92f235056541a156a74
SIZE (foo2zjs.tar.gz) = 2127249

View file

@ -0,0 +1,68 @@
--- Makefile.orig Mon May 1 22:35:49 2006
+++ Makefile Sat May 6 21:35:57 2006
@@ -6,8 +6,7 @@
VERSION=0.0
# Installation prefix...
-PREFIX=/usr/local
-PREFIX=/usr
+PREFIX?=
# Pathnames for this package...
BIN=$(PREFIX)/bin
@@ -18,7 +17,7 @@
DOCDIR=$(PREFIX)/share/doc/foo2zjs/
# Pathnames for referenced packages...
-FOODB=/usr/share/foomatic/db/source
+FOODB=$(PREFIX)/share/foomatic/db/source
# User ID's
LPuid=-olp
@@ -155,8 +154,8 @@
endif
# Compiler flags
-CFLAGS += -O2 -Wall
-
+CFLAGS?=
+CC?=
#
# Rules to create test documents
#
@@ -277,7 +276,7 @@
# Installation rules
#
install: all install-test install-prog install-icc2ps install-extra \
- install-crd install-foo install-ppd install-man install-doc
+ install-crd install-ppd
#
# If you use CUPS, then restart the spooler:
# make cups
@@ -335,8 +334,10 @@
#
# Install current database files
#
+ mkdir -p $(FOODB)
@if [ -d $(FOODB) ]; then \
for dir in driver printer opt; do \
+ install -d $(FOODB)/$$dir/; \
echo install -m 644 foomatic-db/$$dir/*.xml $(FOODB)/$$dir/; \
install -c -m 644 foomatic-db/$$dir/*.xml $(FOODB)/$$dir/; \
done \
@@ -421,12 +422,13 @@
fi; \
done
-MODEL=/usr/share/cups/model
-LOCALMODEL=/usr/local/share/cups/model
+MODEL=$(PREFIX)/share/cups/model
+LOCALMODEL=$(PREFIX)/share/cups/model
install-ppd:
#
# Install PPD files for CUPS
#
+ mkdir -p $(MODEL)
if [ -d $(MODEL) ]; then \
cd PPD; \
for ppd in *.ppd; do \

View file

@ -0,0 +1,7 @@
###############################################################################################
1) Please read the detailed installation instructions in the file:
* %%DOCSDIR%%/INSTALL
###############################################################################################

15
print/foo2zjs/pkg-descr Normal file
View file

@ -0,0 +1,15 @@
foo2zjs is an open source printer driver for printers that use the Zenographics
ZjStream wire protocol for their print data, such as the Minolta/QMS magicolor
2300 DL or Konica Minolta magicolor 2430 DL. These printers are often
erroneously referred to as winprinters or GDI printers.
However, Microsoft GDI only mandates the API between an application and the
printer driver, not the protocol on the wire between the printer driver and the
printer. In fact, ZjStream printers are raster printers which happen to use a
very efficient wire protocol which was developed by Zenographics and licensed
by most major printer manufacturers for at least some of their product lines.
ZjStream is just one of many wire protocols that are in use today, such as
Postscript, PCL, Epson, etc.
WWW: http://foo2zjs.rkkda.com/

56
print/foo2zjs/pkg-plist Normal file
View file

@ -0,0 +1,56 @@
bin/arm2hpdl
bin/foo2hp
bin/foo2hp2600-wrapper
bin/foo2oak-wrapper
bin/foo2zjs
bin/foo2zjs-icc2ps
bin/foo2zjs-wrapper
bin/okidecode
bin/zjsdecode
share/cups/model/Generic-OAKT_Printer.ppd.gz
share/cups/model/Generic-ZjStream_Printer.ppd.gz
share/cups/model/HP-Color_LaserJet_1500.ppd.gz
share/cups/model/HP-Color_LaserJet_1600.ppd.gz
share/cups/model/HP-Color_LaserJet_2600n.ppd.gz
share/cups/model/HP-LaserJet_1000.ppd.gz
share/cups/model/HP-LaserJet_1005.ppd.gz
share/cups/model/HP-LaserJet_1018.ppd.gz
share/cups/model/HP-LaserJet_1020.ppd.gz
share/cups/model/Minolta-Color_PageWorks_Pro_L.ppd.gz
share/cups/model/Minolta-magicolor_2200_DL.ppd.gz
share/cups/model/Minolta-magicolor_2300_DL.ppd.gz
share/cups/model/Minolta-magicolor_2430_DL.ppd.gz
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/manual.pdf
share/foo2hp/icm/hpclj2600n.icm
share/foo2hp/icm/km2430_0.icm
share/foo2hp/icm/km2430_1.icm
share/foo2hp/icm/km2430_2.icm
%%DATADIR%%/crd/2300w-1200@150-l250-kx,ucr100,0-per.crd
%%DATADIR%%/crd/2300w-1200@150-l250-kx,ucr100,50-per.crd
%%DATADIR%%/crd/2300w-1200@150-l250-kx,ucr100,75-per.crd
%%DATADIR%%/crd/2300w-1200@150-l250-kx,ucr125,75-per.crd
%%DATADIR%%/crd/kh.crd
%%DATADIR%%/crd/kx.crd
%%DATADIR%%/crd/prolog.ps
%%DATADIR%%/crd/screen1200.ps
%%DATADIR%%/crd/screen2400.ps
%%DATADIR%%/firmware/sihp1000.dl
%%DATADIR%%/firmware/sihp1005.dl
%%DATADIR%%/firmware/sihp1018.dl
%%DATADIR%%/firmware/sihp1020.dl
%%DATADIR%%/gamma-lookup.ps
%%DATADIR%%/gamma.ps
%%DATADIR%%/icm/km2430_0.icm
%%DATADIR%%/icm/km2430_1.icm
%%DATADIR%%/icm/km2430_2.icm
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/icm
@dirrm %%DATADIR%%/firmware
@dirrm %%DATADIR%%/crd
@dirrm %%DATADIR%%
@dirrm share/foo2oak/icm
@dirrm share/foo2oak
@dirrm share/foo2hp/icm
@dirrm share/foo2hp