Remove zh-ted, it's non I18N app.
Approved by: committers@tw
This commit is contained in:
parent
f20528e489
commit
e38ff5203a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38860
10 changed files with 0 additions and 313 deletions
|
@ -1,21 +0,0 @@
|
|||
# New ports collection makefile for: ted
|
||||
# Date Created: 18 Sep 1997
|
||||
# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ted
|
||||
PORTVERSION= 4.4d
|
||||
CATEGORIES= chinese editors
|
||||
MASTER_SITES= ftp://freebsd.ntu.edu.tw/FreeBSD/ntu/moon/X/ted/
|
||||
DISTFILES= ted4.4d.tgz
|
||||
|
||||
MAINTAINER= vanilla@FreeBSD.org
|
||||
|
||||
RUN_DEPENDS= ${X11BASE}/bin/xcin:${PORTSDIR}/chinese/xcin
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
WRKSRC= ${WRKDIR}/ted
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1 +0,0 @@
|
|||
MD5 (ted4.4d.tgz) = 96c2f9ba8297e5a46057219d62e81ceb
|
|
@ -1,59 +0,0 @@
|
|||
--- Makefile.orig Wed Feb 9 10:18:57 2000
|
||||
+++ Makefile Sun Apr 2 11:59:26 2000
|
||||
@@ -1,5 +1,5 @@
|
||||
-CHINESE=0
|
||||
-TEDDIR=/usr/local/lib/Ted
|
||||
+CHINESE=1
|
||||
+TEDDIR=/usr/X11R6/lib/X11/ted
|
||||
########## GCC/Linux ...... ############
|
||||
CC=gcc
|
||||
XINC=-I/usr/X11R6/include
|
||||
@@ -28,7 +28,7 @@
|
||||
#LDFLAGS=
|
||||
###########################
|
||||
########## Solaris and SunOS 4.x ############
|
||||
-CC=cc
|
||||
+#CC=cc
|
||||
#XINC=-I/usr/openwin/include
|
||||
#LDFLAGS= -L/usr/openwin/lib -lsocket
|
||||
#CC=cc
|
||||
@@ -37,14 +37,14 @@
|
||||
#SUNKBD=-DSUNKBD
|
||||
###########################
|
||||
|
||||
-CFLAGS = -O -DCHINESE=$(CHINESE) $(XINC) $(SUNKBD) -DTEDDIR=\"$(TEDDIR)\"
|
||||
+CFLAGS += -DCHINESE=$(CHINESE) $(XINC) $(SUNKBD) -DTEDDIR=\"$(TEDDIR)\"
|
||||
#CFLAGS = -g -DCHINESE=$(CHINESE) $(XINC) -DDEBUG $(SUNKBD) -DTEDDIR=\"$(TEDDIR)\"
|
||||
#CFLAGS = -g -DCHINESE=$(CHINESE) $(XINC) $(SUNKBD) -DTEDDIR=\"$(TEDDIR)\"
|
||||
|
||||
OBJS = e.o x.o m.o f.o b.o edln.o xcp.o s.o u.o misc.o twin.o dir.o xkey.o \
|
||||
- cwin.o filebrowse.o kwcomp.o
|
||||
+ cwin.o filebrowse.o kwcomp.o cli_xcin.o
|
||||
|
||||
-all: ted ref ctags tedrc
|
||||
+all: ted tedrc #ref ctags
|
||||
ted: $(OBJS)
|
||||
$(CC) $(OBJS) -o $@ $(LDFLAGS) -lX11
|
||||
pur: $(OBJS)
|
||||
@@ -63,11 +63,17 @@
|
||||
$(CC) $(CFLAGS) ctags.c -o $@
|
||||
strip $@
|
||||
install:
|
||||
- cp ted ref ctags /usr/local/bin
|
||||
+# cp ted ref ctags /usr/local/bin
|
||||
+ install -c -s -o root -g wheel -m 0555 ted /usr/X11R6/bin
|
||||
if [ ! -d $(TEDDIR) ]; then mkdir $(TEDDIR); fi
|
||||
- cp tedrc tedrc.vi tedrc.grep ted.help tedrc.filevisit $(TEDDIR)
|
||||
-cli_xcin.o:
|
||||
- ln -s ../big5-pack/xcin/cli_xcin.o .
|
||||
+# cp tedrc tedrc.vi tedrc.grep ted.help tedrc.filevisit $(TEDDIR)
|
||||
+#cli_xcin.o:
|
||||
+# ln -s ../big5-pack/xcin/cli_xcin.o .
|
||||
+ install -c -o root -g wheel -m 0444 tedrc $(TEDDIR)
|
||||
+ install -c -o root -g wheel -m 0444 tedrc.filevisit $(TEDDIR)
|
||||
+ install -c -o root -g wheel -m 0444 tedrc.grep $(TEDDIR)
|
||||
+ install -c -o root -g wheel -m 0444 tedrc.vi $(TEDDIR)
|
||||
+ install -c -o root -g wheel -m 0444 ted.help $(TEDDIR)
|
||||
clean:
|
||||
rm -f $(OBJS) ted core *~ *_
|
||||
clb5:
|
|
@ -1,11 +0,0 @@
|
|||
--- xkey.c.orig Mon Nov 3 16:52:47 1997
|
||||
+++ xkey.c Mon Nov 10 09:34:52 1997
|
||||
@@ -602,7 +602,7 @@
|
||||
if (fp=fopen(
|
||||
strcat(strcat(strcpy(tt,(char *)getenv("HOME")),"/.Ted/"),ftedrc), "r"
|
||||
)) return fp;
|
||||
-if (fp=fopen(strcat(strcat(strcpy(uu, TEDDIR),"/"),ftedrc),"r"))
|
||||
+if (fp=fopen(strcat(strcat(strcpy(uu, "/usr/X11R6/lib/X11/ted/"),"/"),ftedrc),"r"))
|
||||
return fp;
|
||||
if (!depth) {
|
||||
if (cdtedrc)
|
|
@ -1,13 +0,0 @@
|
|||
--- tedrc.vi.orig Sat Oct 11 13:37:55 1997
|
||||
+++ tedrc.vi Mon Nov 10 09:34:52 1997
|
||||
@@ -165,8 +165,8 @@
|
||||
f [s-f9] ExeCmdFnameExt("make",".o")
|
||||
## If the file is already open, switch to this file; otherwise
|
||||
## load the file
|
||||
-f [f1] RaiseOrLoad("/usr/local/lib/Ted/ted.help")
|
||||
-f [c-a][f1] RaiseOrLoad("/usr/local/lib/Ted/tedrc")
|
||||
+f [f1] RaiseOrLoad("/usr/X11R6/lib/X11/ted/ted.help")
|
||||
+f [c-a][f1] RaiseOrLoad("/usr/X11R6/lib/X11/ted/tedrc")
|
||||
## execute command and place the output in the current file
|
||||
#f [c-q][s] InsPipe("ls")
|
||||
# Excute command and and place output in a new file with name same as the command
|
|
@ -1,182 +0,0 @@
|
|||
*** cli_xcin.c.orig Fri Sep 19 01:19:33 1997
|
||||
--- cli_xcin.c Sat Sep 13 11:41:12 1997
|
||||
***************
|
||||
*** 0 ****
|
||||
--- 1,130 ----
|
||||
+ /*
|
||||
+ Copyright (C) 1994,1995 Edward Der-Hua Liu, Hsin-Chu, Taiwan
|
||||
+ */
|
||||
+
|
||||
+ #include <stdio.h>
|
||||
+ #include <stdarg.h>
|
||||
+ #include <sys/types.h>
|
||||
+ #include <X11/Xlib.h>
|
||||
+ #include <X11/Xatom.h>
|
||||
+ #include "state.h"
|
||||
+ #include "protocol.h"
|
||||
+
|
||||
+ static Atom xcin_atom=0;
|
||||
+ static Window xcin_win=None;
|
||||
+ static InmdState inmdstate;
|
||||
+ #define ENDIAN_TEST() (*(int *)"\x11\x22\x33\x44"==0x11223344)
|
||||
+ static char my_endian;
|
||||
+
|
||||
+ static connect_xcin(Display *display)
|
||||
+ {
|
||||
+ Window twin;
|
||||
+ xcin_atom=XInternAtom(display, XCIN_ATOM,False);
|
||||
+ my_endian=ENDIAN_TEST(); /* if == 11223344, it is big-endian */
|
||||
+
|
||||
+ xcin_win=XGetSelectionOwner(display,xcin_atom);
|
||||
+ return xcin_win;
|
||||
+ }
|
||||
+
|
||||
+ void send_FocusIn(Display *display, Window window)
|
||||
+ {
|
||||
+ XClientMessageEvent event;
|
||||
+ XEvent erreve;
|
||||
+ char *tmp=event.data.b;
|
||||
+
|
||||
+ if (connect_xcin(display)==None) return;
|
||||
+ /* Ensure xcin exists, or the process will be hanged */
|
||||
+ event.type=ClientMessage;
|
||||
+ event.window=window;
|
||||
+ event.message_type=xcin_atom;
|
||||
+ event.format=8;
|
||||
+
|
||||
+ tmp[0]=tmp[1]=tmp[2]=0xff;
|
||||
+ tmp[3]=CLI_FOCUS_IN;
|
||||
+ memcpy(&tmp[4],&inmdstate, sizeof(inmdstate));
|
||||
+ XSendEvent(display, xcin_win, False, 0, (XEvent *)&event);
|
||||
+ }
|
||||
+
|
||||
+ static void send_FocusOut(Display *display, Window window)
|
||||
+ {
|
||||
+ XClientMessageEvent event;
|
||||
+ XEvent erreve;
|
||||
+ char *tmp=event.data.b;
|
||||
+
|
||||
+ if (connect_xcin(display)==None) return;
|
||||
+ /* Ensure xcin exists, or the process will be hanged */
|
||||
+ event.type=ClientMessage;
|
||||
+ event.window=window;
|
||||
+ event.message_type=xcin_atom;
|
||||
+ event.format=8;
|
||||
+
|
||||
+ tmp[0]=tmp[1]=tmp[2]=0xff;
|
||||
+ tmp[3]=CLI_FOCUS_OUT;
|
||||
+ memcpy(&tmp[4],&inmdstate, sizeof(inmdstate));
|
||||
+ XSendEvent(display, xcin_win, False, 0, (XEvent *)&event);
|
||||
+ }
|
||||
+
|
||||
+ static void big_little(char *i)
|
||||
+ {
|
||||
+ char t;
|
||||
+ t=*i; *i=*(i+3); *(i+3)=t;
|
||||
+ t=*(i+1); *(i+1)=*(i+2); *(i+2)=t;
|
||||
+ }
|
||||
+ static read_keys(Display *display, char *buf)
|
||||
+ {
|
||||
+ Atom actual_type;
|
||||
+ int actual_format,i;
|
||||
+ u_long nitems,bytes_after;
|
||||
+ char *ttt, *cp;
|
||||
+ XCIN_RES res;
|
||||
+ int ofs;
|
||||
+ cp=(char *)&res;
|
||||
+ ofs=0;
|
||||
+ do {
|
||||
+ if (XGetWindowProperty(display,xcin_win,xcin_atom,
|
||||
+ ofs/4,(sizeof(XCIN_RES)+3)/4,
|
||||
+ True, AnyPropertyType, &actual_type,&actual_format,
|
||||
+ &nitems,&bytes_after,(unsigned char **)&ttt) != Success)
|
||||
+ puts("err property");
|
||||
+ memcpy((char *)(&res)+(ofs & ~0x3), ttt, nitems);
|
||||
+ XFree(ttt);
|
||||
+ ofs=(ofs & ~0x3) + nitems;
|
||||
+ } while ((!nitems && !ofs) || bytes_after>0);
|
||||
+ if (my_endian) {
|
||||
+ big_little((char *)&res.len);
|
||||
+ big_little((char *)&res.status);
|
||||
+ }
|
||||
+ memcpy(buf,res.tkey, res.len);
|
||||
+ inmdstate=res.inmdstate;
|
||||
+ buf[res.len]=0;
|
||||
+ return res.status;
|
||||
+ }
|
||||
+
|
||||
+ #include <X11/Xutil.h>
|
||||
+
|
||||
+ static XComposeStatus compose_status = {NULL, 0};
|
||||
+
|
||||
+ send_key(Display *display, Window win, XKeyEvent *eve, char *buf)
|
||||
+ {
|
||||
+ XClientMessageEvent event;
|
||||
+ XEvent erreve;
|
||||
+ char *tmp=event.data.b;
|
||||
+ u_char tttt[8];
|
||||
+ KeySym keysym;
|
||||
+ int count;
|
||||
+
|
||||
+ if (xcin_win==None && connect_xcin(display)==None)
|
||||
+ return K_REJECT;
|
||||
+ if ((xcin_win=XGetSelectionOwner(display,xcin_atom))==None)
|
||||
+ return K_REJECT;
|
||||
+
|
||||
+ event.type=ClientMessage;
|
||||
+ event.window=win;
|
||||
+ event.message_type=xcin_atom;
|
||||
+ event.format=32;
|
||||
+ count =XLookupString (eve, tttt, sizeof(tmp), (KeySym *)tmp, &compose_status);
|
||||
+ memcpy(&tmp[4],&eve->state,4);
|
||||
+ XSendEvent(display, xcin_win, False, 0, (XEvent *)&event);
|
||||
+ XSync(display,False);
|
||||
+ return (read_keys(display, buf));
|
||||
+ }
|
||||
*** protocol.h.orig Fri Sep 19 01:19:44 1997
|
||||
--- protocol.h Fri Sep 19 01:19:41 1997
|
||||
***************
|
||||
*** 0 ****
|
||||
--- 1,13 ----
|
||||
+ /*
|
||||
+ Copyright (C) 1994 Edward Der-Hua Liu, Hsin-Chu, Taiwan
|
||||
+ */
|
||||
+
|
||||
+ #define K_REJECT (0)
|
||||
+ #define K_ACCEPT (1)
|
||||
+
|
||||
+ #define CLI_FOCUS_IN (1)
|
||||
+ #define CLI_FOCUS_OUT (3)
|
||||
+
|
||||
+ #define LOAD_KEYWORD (2)
|
||||
+
|
||||
+ #define XCIN_ATOM "XCIN_A"
|
||||
*** state.h.orig Fri Sep 19 01:20:14 1997
|
||||
--- state.h Fri Sep 19 01:20:05 1997
|
||||
***************
|
||||
*** 0 ****
|
||||
--- 1,24 ----
|
||||
+ /*
|
||||
+ Copyright (C) 1994 Edward Der-Hua Liu, Hsin-Chu, Taiwan
|
||||
+ */
|
||||
+
|
||||
+ typedef struct {
|
||||
+ char kb_state;
|
||||
+ char _CurInMethod;
|
||||
+ } InmdState;
|
||||
+
|
||||
+ #define EngChiMask (1)
|
||||
+ #define HalfFullMask (2)
|
||||
+
|
||||
+ typedef struct {
|
||||
+ int len;
|
||||
+ int status;
|
||||
+ InmdState inmdstate;
|
||||
+ char tkey[512];
|
||||
+ } XCIN_RES;
|
||||
+
|
||||
+ #define EngChi ((inmdstate.kb_state & EngChiMask) ? 1:0)
|
||||
+ #define HalfFull ((inmdstate.kb_state & HalfFullMask) ? 1:0)
|
||||
+ #define CurInMethod (inmdstate._CurInMethod)
|
||||
+ /*extern InmdState inmdstate;
|
||||
+ */
|
|
@ -1,13 +0,0 @@
|
|||
--- x.c.orig Wed May 13 09:39:26 1998
|
||||
+++ x.c Thu May 28 03:09:27 1998
|
||||
@@ -80,8 +80,8 @@
|
||||
}
|
||||
|
||||
#if CHINESE
|
||||
-char *Big5FontName="et24m";
|
||||
-char *AscFontName="vga12x24";
|
||||
+char *Big5FontName="kc24f";
|
||||
+char *AscFontName="12x24";
|
||||
#else
|
||||
char *AscFontName="10x20";
|
||||
#endif
|
|
@ -1 +0,0 @@
|
|||
A Small and Powerful Text Editor for X Window with big5 support
|
|
@ -1,5 +0,0 @@
|
|||
Ted is a small and powerful Text editor for the X Window System.
|
||||
The interface is like PE2 on DOS.
|
||||
|
||||
- Vanilla
|
||||
vanilla@MinJe.com.TW
|
|
@ -1,7 +0,0 @@
|
|||
bin/ted
|
||||
lib/X11/ted/ted.help
|
||||
lib/X11/ted/tedrc
|
||||
lib/X11/ted/tedrc.filevisit
|
||||
lib/X11/ted/tedrc.grep
|
||||
lib/X11/ted/tedrc.vi
|
||||
@dirrm lib/X11/ted
|
Loading…
Reference in a new issue