Fix compile on 64bit platforms
This commit is contained in:
parent
e76c1a14ce
commit
e391e994ad
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=219321
2 changed files with 11 additions and 6 deletions
|
@ -27,10 +27,6 @@ USE_LDCONFIG= yes
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} != "i386"
|
||||
BROKEN= Does not compile on !i386
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
${CP} ${LTMAIN} ${WRKSRC}
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- src/ixlib_garbage.hh.orig Tue Jun 19 16:16:29 2001
|
||||
+++ src/ixlib_garbage.hh Fri Dec 1 19:56:04 2006
|
||||
--- src/ixlib_garbage.hh.orig 2001-06-20 01:16:29.000000000 +0200
|
||||
+++ src/ixlib_garbage.hh 2008-08-27 17:54:47.000000000 +0200
|
||||
@@ -126,24 +126,24 @@
|
||||
// compiler generates one, which is *ahem* - fatal
|
||||
ref(ref const &src)
|
||||
|
@ -216,6 +216,15 @@
|
|||
return oldinst;
|
||||
}
|
||||
};
|
||||
@@ -440,7 +440,7 @@
|
||||
|
||||
private:
|
||||
hash_value hash(T const *ptr) const {
|
||||
- unsigned u = reinterpret_cast<unsigned>(ptr);
|
||||
+ uintptr_t u = reinterpret_cast<uintptr_t>(ptr);
|
||||
return (u ^ (u >> 8) ^ (u >> 16) ^ (u >> 24)) & HASH_MAX;
|
||||
}
|
||||
instance_data *getHashEntry(T const *instance) {
|
||||
@@ -482,7 +482,7 @@
|
||||
|
||||
|
||||
|
|
Loading…
Reference in a new issue