Add new port wmtunlo: A dockapp that displays a zooming 2D tunnel
PR: ports/41223 Submitted by: Adam Weinberger <adam@vectors.cx>
This commit is contained in:
parent
e231b42d6a
commit
e391fbaf7c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=64072
7 changed files with 71 additions and 0 deletions
|
@ -305,6 +305,7 @@
|
|||
SUBDIR += wmpal
|
||||
SUBDIR += wmproxyper
|
||||
SUBDIR += wmstock
|
||||
SUBDIR += wmtunlo
|
||||
SUBDIR += wmweather
|
||||
SUBDIR += wmwork
|
||||
SUBDIR += wmx10
|
||||
|
|
33
misc/wmtunlo/Makefile
Normal file
33
misc/wmtunlo/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# New ports collection makefile for: wmtunlo
|
||||
# Date created: 27 July 2002
|
||||
# Whom: Adam Weinberger <adam@vectors.cx>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= wmtunlo
|
||||
PORTVERSION= 0.1.1
|
||||
CATEGORIES= misc windowmaker
|
||||
MASTER_SITES= http://clay.ll.pl/download/
|
||||
|
||||
MAINTAINER= adam@vectors.cx
|
||||
|
||||
USE_REINPLACE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
|
||||
post-patch:
|
||||
.for i in 1 2 3 4 5
|
||||
@${REINPLACE_CMD} -e 's|./wmtunlo|${PREFIX}/bin/wmtunlo|g' \
|
||||
${WRKSRC}/example${i}
|
||||
.endfor
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/wmtunlo ${PREFIX}/bin
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
.for i in 1 2 3 4 5
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/example${i} \
|
||||
${EXAMPLESDIR}/wmtunlo.example${i}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
1
misc/wmtunlo/distinfo
Normal file
1
misc/wmtunlo/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (wmtunlo-0.1.1.tar.gz) = b42e51207da0d483dec02e2b7a7ba117
|
22
misc/wmtunlo/files/patch-Makefile
Normal file
22
misc/wmtunlo/files/patch-Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- Makefile.orig Sat Jul 20 04:32:12 2002
|
||||
+++ Makefile Sat Jul 27 02:18:29 2002
|
||||
@@ -1,14 +1,15 @@
|
||||
|
||||
wmTunlo: wmtunlo.o wmgeneral.o
|
||||
- gcc wmgeneral.o wmtunlo.o -o wmtunlo -L/usr/X11R6/lib -lXpm -lX11 -lXext -lm
|
||||
+ ${CC} wmgeneral.o wmtunlo.o -o wmtunlo \
|
||||
+ -L${X11BASE}/lib -lXpm -lX11 -lXext -lm
|
||||
|
||||
wmtunlo.o: wmtunlo.c wmgeneral.c wmgeneral.h dock-master.xpm dock-mask.xbm
|
||||
- gcc -O3 -Wall -c wmtunlo.c
|
||||
+ ${CC} $(CFLAGS) -c wmtunlo.c -I${X11BASE}/include
|
||||
|
||||
wmgeneral.o: wmgeneral.c wmgeneral.h
|
||||
- gcc -O3 -Wall -c wmgeneral.c -I/usr/X11R6/include/X11
|
||||
+ ${CC} $(CFLAGS) -c wmgeneral.c -I${X11BASE}/include
|
||||
|
||||
clean:
|
||||
rm -f *~ *.o wmtunlo
|
||||
|
||||
-
|
||||
+all: wmTunlo
|
1
misc/wmtunlo/pkg-comment
Normal file
1
misc/wmtunlo/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A bo(O)oooring 2d tunnel in wmaker dock
|
6
misc/wmtunlo/pkg-descr
Normal file
6
misc/wmtunlo/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
This is a WindowMaker dockapp that displays a zooming 2-D tunnel.
|
||||
The visualization is highly customizable, using 14 arguments. 5
|
||||
example customizations are provided as shell scripts, named
|
||||
wmtunlo.example1 through wmtunlo.example5.
|
||||
|
||||
- Adam Weinberger adam@vectors.cx
|
7
misc/wmtunlo/pkg-plist
Normal file
7
misc/wmtunlo/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
bin/wmtunlo
|
||||
share/examples/wmtunlo/wmtunlo.example1
|
||||
share/examples/wmtunlo/wmtunlo.example2
|
||||
share/examples/wmtunlo/wmtunlo.example3
|
||||
share/examples/wmtunlo/wmtunlo.example4
|
||||
share/examples/wmtunlo/wmtunlo.example5
|
||||
@dirrm share/examples/wmtunlo
|
Loading…
Reference in a new issue