- Remove lang/libobjc2, it's duplicate of gnustep-libobjc
Submitted by: Pete French <pete@twisted.org.uk> (maintainer)
This commit is contained in:
parent
7e5d5230b6
commit
e3cabba08b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=274990
7 changed files with 1 additions and 138 deletions
1
MOVED
1
MOVED
|
@ -2207,3 +2207,4 @@ www/py-django11||2011-06-01|Has expired: Unsupported (no longer receive security
|
|||
x11-toolkits/rep-gtk||2011-06-01|Has expired: missing rep-config from librep port broke the build.
|
||||
games/tnl||2011-06-01|Has expired: Upstream development has ceased, it doesn't work with newer CEGUI and is generally broken
|
||||
net/vnc2swf|deskutils/vnc2flv|2011-06-01|Has expired: Development is now superseded by deskutils/vnc2flv
|
||||
lang/libobjc2||2011-06-02|Redundant with lang/gnustep-libobjc
|
||||
|
|
|
@ -141,7 +141,6 @@
|
|||
SUBDIR += ldc-devel
|
||||
SUBDIR += libhx
|
||||
SUBDIR += libjit
|
||||
SUBDIR += libobjc2
|
||||
SUBDIR += librep
|
||||
SUBDIR += libstdc++_stldoc_3.4.0
|
||||
SUBDIR += libstdc++_stldoc_4.2.2
|
||||
|
|
|
@ -1,45 +0,0 @@
|
|||
# New ports collection makefile for: libobjc2
|
||||
# Date created: 7 October 2010
|
||||
# Whom: Pete French <pete@twisted.org.uk>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libobjc2
|
||||
PORTVERSION= 1.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= lang devel gnustep
|
||||
MASTER_SITES= http://download.gna.org/gnustep/
|
||||
|
||||
MAINTAINER= pete@twisted.org.uk
|
||||
COMMENT= Replacement Objective-C runtime supporting Obj-C 2 features
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
USE_BZIP2= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
OPTIONS= NSOBJECT_ROOT "Root class is NSObject not Object" On \
|
||||
LIBDISPATCH "Build with libdispatch from ports" Off
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if defined(WITH_LIBDISPATCH)
|
||||
LIB_DEPENDS+= dispatch.0:${PORTSDIR}/devel/libdispatch
|
||||
MAKE_ARGS+= -DWITHOUT_TOYDISPATCH
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_NSOBJECT_ROOT)
|
||||
MAKE_ARGS+= -DWITH_NSOBJECT_ROOT
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 900000
|
||||
BROKEN= does not compile on 9.X
|
||||
.endif
|
||||
|
||||
.if (${ARCH} == i386) || (${ARCH} == i486)
|
||||
CFLAGS+= -march=i586
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (libobjc2-1.0.tar.bz2) = 0d6c683f765c43721f3d6f83d7df4921
|
||||
SHA256 (libobjc2-1.0.tar.bz2) = 8903157a6fe6b82b4571a33855f98e0da0fe92a94f69a9a5edd1af94310f0566
|
||||
SIZE (libobjc2-1.0.tar.bz2) = 66560
|
|
@ -1,66 +0,0 @@
|
|||
--- Makefile.orig 2010-09-14 17:02:29.000000000 +0100
|
||||
+++ Makefile 2010-11-12 14:03:01.589695176 +0000
|
||||
@@ -4,13 +4,20 @@
|
||||
|
||||
#CC=clang
|
||||
|
||||
-CFLAGS += -std=c99
|
||||
+CFLAGS += -std=c99 -fPIC
|
||||
CPPFLAGS += -DTYPE_DEPENDENT_DISPATCH
|
||||
+CPPFLAGS += -D__OBJC_RUNTIME_INTERNAL__=1 -D_XOPEN_SOURCE=500
|
||||
+
|
||||
+.if defined(WITH_NSOBJECT_ROOT)
|
||||
+CPPFLAGS += -DGNUSTEP
|
||||
+.endif
|
||||
|
||||
#LIB_DIR=/usr/local/GNUstep/Local/Library/Libraries/
|
||||
#HEADER_DIR=/usr/local/GNUstep/Local/Library/Headers
|
||||
-LIB_DIR=/tmp/usr/lib/
|
||||
-HEADER_DIR=/tmp/usr/include/
|
||||
+
|
||||
+PREFIX?= /tmp/usr
|
||||
+LIB_DIR= ${PREFIX}/lib
|
||||
+HEADER_DIR= ${PREFIX}/include
|
||||
|
||||
OBJECTS = \
|
||||
NSBlocks.o\
|
||||
@@ -38,11 +45,19 @@
|
||||
statics_loader.o\
|
||||
sync.o
|
||||
|
||||
-all: libobjc.so.$(VERSION)
|
||||
+.if !defined(WITHOUT_TOYDISPATCH)
|
||||
+OBJECTS+= toydispatch.o
|
||||
+.endif
|
||||
+
|
||||
+all: libobjc.so.$(VERSION) libobjc.a
|
||||
|
||||
libobjc.so.$(VERSION): $(OBJECTS)
|
||||
@echo Linking shared library...
|
||||
- ld -shared -o $@ $(OBJECTS)
|
||||
+ @ld -shared -o $@ $(OBJECTS)
|
||||
+
|
||||
+libobjc.a: $(OBJECTS)
|
||||
+ @echo Linking static library...
|
||||
+ @ld -r -s -o $@ $(OBJECTS)
|
||||
|
||||
.c.o:
|
||||
$(CC) $(CPPFLAGS) $(CFLAGS) -c $< -o $@
|
||||
@@ -50,8 +65,12 @@
|
||||
.m.o:
|
||||
$(CC) $(CPPFLAGS) $(CFLAGS) -c $< -o $@
|
||||
|
||||
+toydispatch.o: toydispatch/toydispatch.c
|
||||
+ $(CC) $(CPPFLAGS) $(CFLAGS) -I toydispatch -c $< -o $@
|
||||
+
|
||||
install: all
|
||||
install -m 444 libobjc.so.$(VERSION) $(LIB_DIR)
|
||||
+ install -m 444 libobjc.a $(LIB_DIR)
|
||||
ln -sf $(LIB_DIR)/libobjc.so.$(VERSION) $(LIB_DIR)/libobjc.so
|
||||
install -d $(HEADER_DIR)/objc
|
||||
install -m 444 objc/*.h $(HEADER_DIR)/objc
|
||||
@@ -59,3 +78,4 @@
|
||||
clean:
|
||||
rm -f $(OBJECTS)
|
||||
rm -f libobjc.so.$(VERSION)
|
||||
+ rm -f libobjc.a
|
|
@ -1,8 +0,0 @@
|
|||
Replacement for the GNU Objective-C runtime supporting the features
|
||||
of Objective-C 2 for use with GNUstep and other Objective-C programs.
|
||||
This runtime is based on the Etoile Objective-C Runtime, an earlier
|
||||
research prototype, and includes support for non-fragile instance
|
||||
variables, type-dependent dispatch, and object planes. It is fully
|
||||
compatible with the FSF's GCC Objective-C ABI and also implements
|
||||
a new ABI that is supported by Clang and is required for some of
|
||||
the newer features.
|
|
@ -1,15 +0,0 @@
|
|||
include/objc/Availability.h
|
||||
include/objc/Object.h
|
||||
include/objc/Protocol.h
|
||||
include/objc/blocks_runtime.h
|
||||
include/objc/capabilities.h
|
||||
include/objc/encoding.h
|
||||
include/objc/hooks.h
|
||||
include/objc/objc-api.h
|
||||
include/objc/objc.h
|
||||
include/objc/runtime.h
|
||||
include/objc/slot.h
|
||||
lib/libobjc.a
|
||||
lib/libobjc.so
|
||||
lib/libobjc.so.4
|
||||
@dirrm include/objc
|
Loading…
Reference in a new issue