- update to 2.09
- drop autoconf - use external libpcd - fix errors in Makefiles
This commit is contained in:
parent
dbd41a2fcb
commit
e43be691e0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=134266
4 changed files with 43 additions and 7 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= xpcd
|
||||
PORTVERSION= 2.08
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 2.09
|
||||
CATEGORIES+= graphics
|
||||
MASTER_SITES= http://dl.bytesex.org/releases/xpcd/
|
||||
|
||||
|
@ -15,13 +14,15 @@ MAINTAINER?= ports@FreeBSD.org
|
|||
COMMENT?= PhotoCD tool collection
|
||||
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff
|
||||
tiff.4:${PORTSDIR}/graphics/tiff \
|
||||
pcd.2:${PORTSDIR}/graphics/libpcd
|
||||
|
||||
# USE_IMAKE= yes
|
||||
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
|
||||
LDFLAGS= -L${LOCALBASE}/lib
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOCONF_VER= 213
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GETOPT_LONG= yes
|
||||
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
MAKE_ENV+= LDFLAGS="${LDFLAGS}"
|
||||
USE_X_PREFIX= yes
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (xpcd-2.08.tar.gz) = 23881054e9c469197fc7cc806255754e
|
||||
SIZE (xpcd-2.08.tar.gz) = 103069
|
||||
MD5 (xpcd-2.09.tar.gz) = 7159ba4935781fd6a21c64f750ebf27d
|
||||
SIZE (xpcd-2.09.tar.gz) = 103663
|
||||
|
|
11
graphics/xpcd/files/patch-Makefile.in
Normal file
11
graphics/xpcd/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.in.orig Mon Jul 21 14:22:47 2003
|
||||
+++ Makefile.in Wed Apr 27 17:34:12 2005
|
||||
@@ -11,7 +11,7 @@
|
||||
|
||||
##########################################################################
|
||||
|
||||
-SUBDIRS=libpcd xpcd test
|
||||
+SUBDIRS=xpcd test
|
||||
|
||||
all dep depend clean install:
|
||||
set -e; for dir in $(SUBDIRS); do (cd $$dir; make $@); done
|
24
graphics/xpcd/files/patch-test-Makefile.in
Normal file
24
graphics/xpcd/files/patch-test-Makefile.in
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- test/Makefile.in.orig Mon Jul 21 15:02:26 2003
|
||||
+++ test/Makefile.in Wed Apr 27 17:43:23 2005
|
||||
@@ -18,7 +18,7 @@
|
||||
|
||||
pcdview: view.o dither.o svga.o
|
||||
rm -f $@
|
||||
- $(CC) $(CFLAGS) -o $@ view.o dither.o svga.o $(LDLIBS) @LIBVGA@
|
||||
+ $(CC) $(LDFLAGS) -o $@ view.o dither.o svga.o $(LDLIBS) @LIBVGA@
|
||||
|
||||
suid:
|
||||
su -c "chown root.root pcdview;chmod 4711 pcdview"
|
||||
@@ -32,10 +32,10 @@
|
||||
$(INSTALL_PROGRAM) $(SUID_ROOT) pcdview $(bindir) || true
|
||||
|
||||
pcdtoppm: ppm.o
|
||||
- $(CC) $(CFLAGS) -o $@ ppm.o $(LDLIBS) @LIBJPEG@
|
||||
+ $(CC) $(LDFLAGS) -o $@ ppm.o $(LDLIBS) @LIBJPEG@
|
||||
|
||||
plug-0.54: plug-0.54.o
|
||||
- $(CC) $(CFLAGS) -o $@ plug.o $(LDLIBS) @LIBGIMP54@
|
||||
+ $(CC) $(LDFLAGS) -o $@ plug.o $(LDLIBS) @LIBGIMP54@
|
||||
|
||||
|
||||
depend dep:
|
Loading…
Reference in a new issue