parent
8bbb5610da
commit
e44b020d61
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=400454
5 changed files with 8 additions and 130 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= volatility
|
||||
PORTVERSION= 2.4
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 2.5
|
||||
CATEGORIES= security python
|
||||
MASTER_SITES= http://downloads.volatilityfoundation.org/releases/${PORTVERSION}/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -14,17 +13,19 @@ COMMENT= Advanced memory forensics framework
|
|||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}distorm>=0:${PORTSDIR}/devel/py-distorm \
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3 \
|
||||
${PYTHON_PKGNAMEPREFIX}distorm>=0:${PORTSDIR}/devel/py-distorm \
|
||||
${PYTHON_PKGNAMEPREFIX}pillow>=0:${PORTSDIR}/graphics/py-pillow \
|
||||
${PYTHON_PKGNAMEPREFIX}pycrypto>=0:${PORTSDIR}/security/py-pycrypto \
|
||||
${PYTHON_PKGNAMEPREFIX}yara>=0:${PORTSDIR}/security/py-yara \
|
||||
${PYTHON_PKGNAMEPREFIX}openpyxl>=0:${PORTSDIR}/textproc/py-openpyxl
|
||||
|
||||
USES= python:2
|
||||
USES= python:2 zip
|
||||
USE_PYTHON= distutils autoplist
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
WRKSRC= ${WRKDIR}/volatility-master
|
||||
DATADIR= ${PREFIX}/share/py-${PORTNAME}
|
||||
PORTDOCS= AUTHORS.txt CHANGELOG.txt CREDITS.txt LEGAL.txt README.txt
|
||||
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (volatility-2.4.tar.gz) = 684fdffd79ca4453298ee2eb001137cff802bc4b3dfaaa38c4335321f7cccef1
|
||||
SIZE (volatility-2.4.tar.gz) = 2327513
|
||||
SHA256 (volatility-2.5.zip) = b90dfd18b6a99e1b35ef0f92f28422cca03bea0b7b8ec411cfbc603e72aa594b
|
||||
SIZE (volatility-2.5.zip) = 3276052
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- setup.py.orig 2014-08-03 18:09:32 UTC
|
||||
--- setup.py.orig 2015-10-21 20:39:22 UTC
|
||||
+++ setup.py
|
||||
@@ -44,7 +44,10 @@ def find_files(topdirs, py = False):
|
||||
ret = []
|
||||
|
|
|
@ -1,88 +0,0 @@
|
|||
--- volatility/plugins/malware/psxview.py.orig 2014-08-03 18:09:34 UTC
|
||||
+++ volatility/plugins/malware/psxview.py
|
||||
@@ -32,7 +32,7 @@ try:
|
||||
from openpyxl.workbook import Workbook
|
||||
from openpyxl.writer.excel import ExcelWriter
|
||||
from openpyxl.cell import get_column_letter
|
||||
- from openpyxl.style import Color, Fill
|
||||
+ from openpyxl.styles import Color, Fill, Style, PatternFill, Border, Side, Alignment, Protection, Font
|
||||
from openpyxl.cell import Cell
|
||||
from openpyxl import load_workbook
|
||||
has_openpyxl = True
|
||||
@@ -208,6 +208,57 @@ class PsXview(common.AbstractWindowsComm
|
||||
yield offset, source[offset], ps_sources
|
||||
|
||||
def render_xlsx(self, outfd, data):
|
||||
+ BoldStyle = Style(font=Font(name='Calibri',
|
||||
+ size=11,
|
||||
+ bold=True,
|
||||
+ italic=False,
|
||||
+ vertAlign=None,
|
||||
+ underline='none',
|
||||
+ strike=False,
|
||||
+ color='FFFFFFFF'),
|
||||
+ fill=PatternFill(fill_type="solid",
|
||||
+ start_color='FF000000',
|
||||
+ end_color='FF000000'))
|
||||
+ RedStyle = Style(font=Font(name='Calibri',
|
||||
+ size=11,
|
||||
+ bold=False,
|
||||
+ italic=False,
|
||||
+ vertAlign=None,
|
||||
+ underline='none',
|
||||
+ strike=False,
|
||||
+ color='FF000000'),
|
||||
+ border=Border(left=Side(border_style="thick",
|
||||
+ color='FF000000'),
|
||||
+ right=Side(border_style="thick",
|
||||
+ color='FF000000'),
|
||||
+ top=Side(border_style="thick",
|
||||
+ color='FF000000'),
|
||||
+ bottom=Side(border_style="thick",
|
||||
+ color='FF000000'),
|
||||
+ diagonal=Side(border_style="thick",
|
||||
+ color='FF000000'),
|
||||
+ diagonal_direction=0,
|
||||
+ outline=Side(border_style="thick",
|
||||
+ color='FF000000'),
|
||||
+ vertical=Side(border_style="thick",
|
||||
+ color='FF000000'),
|
||||
+ horizontal=Side(border_style="thick",
|
||||
+ color='FF000000')),
|
||||
+ fill=PatternFill(start_color = 'FFFF0000',
|
||||
+ end_color = 'FFFF0000',
|
||||
+ fill_type = 'solid'))
|
||||
+ GreenStyle = Style(font=Font(name='Calibri',
|
||||
+ size=11,
|
||||
+ bold=False,
|
||||
+ italic=False,
|
||||
+ vertAlign=None,
|
||||
+ underline='none',
|
||||
+ strike=False,
|
||||
+ color='FF000000'),
|
||||
+ fill=PatternFill(start_color = "FF00FF00",
|
||||
+ end_color = "FF00FF00",
|
||||
+ fill_type = "solid"))
|
||||
+
|
||||
wb = Workbook(optimized_write = True)
|
||||
ws = wb.create_sheet()
|
||||
ws.title = "Psxview Output"
|
||||
@@ -274,15 +325,13 @@ class PsXview(common.AbstractWindowsComm
|
||||
wb = load_workbook(filename = self._config.OUTPUT_FILE)
|
||||
ws = wb.get_sheet_by_name(name = "Psxview Output")
|
||||
for col in xrange(1, 12):
|
||||
- ws.cell("{0}{1}".format(get_column_letter(col), 1)).style.font.bold = True
|
||||
+ ws.cell("{0}{1}".format(get_column_letter(col), 1)).style = BoldStyle
|
||||
for row in xrange(2, total + 1):
|
||||
for col in xrange(4, 11):
|
||||
if ws.cell("{0}{1}".format(get_column_letter(col), row)).value == "False":
|
||||
- ws.cell("{0}{1}".format(get_column_letter(col), row)).style.fill.fill_type = Fill.FILL_SOLID
|
||||
- ws.cell("{0}{1}".format(get_column_letter(col), row)).style.fill.start_color.index = "FFFF0000"
|
||||
+ ws.cell("{0}{1}".format(get_column_letter(col), row)).style = RedStyle
|
||||
else:
|
||||
- ws.cell("{0}{1}".format(get_column_letter(col), row)).style.fill.fill_type = Fill.FILL_SOLID
|
||||
- ws.cell("{0}{1}".format(get_column_letter(col), row)).style.fill.start_color.index = "FF00FF00"
|
||||
+ ws.cell("{0}{1}".format(get_column_letter(col), row)).style = GreenStyle
|
||||
wb.save(filename = self._config.OUTPUT_FILE)
|
||||
|
||||
def render_text(self, outfd, data):
|
|
@ -1,35 +0,0 @@
|
|||
--- volatility/plugins/timeliner.py.orig 2014-08-03 18:49:58 UTC
|
||||
+++ volatility/plugins/timeliner.py
|
||||
@@ -56,7 +56,6 @@ try:
|
||||
from openpyxl.workbook import Workbook
|
||||
from openpyxl.writer.excel import ExcelWriter
|
||||
from openpyxl.cell import get_column_letter
|
||||
- from openpyxl.style import Color, Fill
|
||||
from openpyxl.cell import Cell
|
||||
from openpyxl import load_workbook
|
||||
has_openpyxl = True
|
||||
@@ -193,11 +192,6 @@ class TimeLiner(common.AbstractWindowsCo
|
||||
if line != None:
|
||||
outfd.write(line)
|
||||
|
||||
- def fill(self, ws, row, max = 6, color = "RED"):
|
||||
- for col in xrange(1, max):
|
||||
- ws.cell("{0}{1}".format(get_column_letter(col), row)).style.fill.fill_type = Fill.FILL_SOLID
|
||||
- ws.cell("{0}{1}".format(get_column_letter(col), row)).style.fill.start_color.index = colors.get(color, "RED")
|
||||
-
|
||||
def render_xlsx(self, outfd, data):
|
||||
wb = Workbook(optimized_write = True)
|
||||
ws = wb.create_sheet()
|
||||
@@ -214,12 +208,9 @@ class TimeLiner(common.AbstractWindowsCo
|
||||
if self._config.HIGHLIGHT != None:
|
||||
wb = load_workbook(filename = self._config.OUTPUT_FILE)
|
||||
ws = wb.get_sheet_by_name(name = "Timeline Output")
|
||||
- for col in xrange(1, len(header) + 1):
|
||||
- ws.cell("{0}{1}".format(get_column_letter(col), 1)).style.font.bold = True
|
||||
for row in xrange(2, total + 1):
|
||||
for col in xrange(2, len(header)):
|
||||
if ws.cell("{0}{1}".format(get_column_letter(col), row)).value in self.suspicious.keys():
|
||||
- self.fill(ws, row, len(header) + 1, self.suspicious[ws.cell("{0}{1}".format(get_column_letter(col), row)).value]["color"])
|
||||
ws.cell("{0}{1}".format(get_column_letter(col + 1), row)).value = self.suspicious[ws.cell("{0}{1}".format(get_column_letter(col), row)).value]["reason"]
|
||||
|
||||
wb.save(filename = self._config.OUTPUT_FILE)
|
Loading…
Reference in a new issue