- Add CONFLICT with virtualbox-ose.
- Removed inclusion of utmp.h to fix build on recent CURRENT. [1] - Add OPTION to install HAL policy file. [2] - Add kldxref to plist. [3] - Bump PORTREVISION. PR: ports/142855 [1] Submitted by: YAMAMOTO Shigeru <shigeru AT iij.ad.jp> [1], ed@ [1] Reported by: Alexander Kabaev <kabaev AT gmail.com> [2], Rainer Hurling <rhurlin AT gwdg.de> [3], Nakata Maho <chat95 AT mac.com> [3], Andrzej Tobola <ato AT iem.pw.edu.pl> [3] On behalf of: vbox@ (decke, dhn, itetcu, miwi, nox)
This commit is contained in:
parent
fa348b7ce8
commit
e472a1d51d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=248492
3 changed files with 31 additions and 1 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= virtualbox-ose
|
||||
DISTVERSION= 3.1.51r25618
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= emulators kld
|
||||
MASTER_SITES= http://tmp.chruetertee.ch/ \
|
||||
http://freebsd.unixfreunde.de/sources/ \
|
||||
|
@ -33,10 +34,11 @@ CONFIGURE_ARGS+=--with-gcc="${CC}" --with-g++="${CXX}" --nofatal \
|
|||
--disable-alsa --disable-dbus --disable-python \
|
||||
--build-headless
|
||||
|
||||
CONFLICTS= bcc-[0-9]*
|
||||
CONFLICTS= bcc-[0-9]* virtualbox-ose-3.*
|
||||
|
||||
OPTIONS= DEBUG "Build with debugging symbols" off \
|
||||
X11 "Build with X11 support" on \
|
||||
HAL "Install HAL policy file for additions" on \
|
||||
OPENGL "Build with OpenGL support" off
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
@ -63,10 +65,20 @@ VBOX_WITH_X11= 1
|
|||
USE_XORG= xcursor xmu inputproto
|
||||
PLIST_SUB+= X11=""
|
||||
.else
|
||||
.if !defined(WITHOUT_HAL)
|
||||
BROKEN= HAL requires X11 support. Run 'make config' again!
|
||||
.endif
|
||||
VBOX_WITH_X11=
|
||||
PLIST_SUB+= X11="@comment "
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_HAL)
|
||||
LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
|
||||
PLIST_SUB+= HAL=""
|
||||
.else
|
||||
PLIST_SUB+= HAL="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_OPENGL)
|
||||
CONFIGURE_ARGS+=--disable-opengl
|
||||
.else
|
||||
|
@ -137,4 +149,9 @@ do-install:
|
|||
${INSTALL_DATA} ${VBOX_BIN}/vboxmouse_drv_16.so ${INPUTDIR}/vboxmouse_drv.so
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_HAL)
|
||||
${INSTALL_DATA} ${WRKSRC}/src/VBox/Additions/linux/installer/90-vboxguest.fdi \
|
||||
${PREFIX}/share/hal/fdi/policy/10osvendor/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -0,0 +1,10 @@
|
|||
--- src/VBox/Additions/common/VBoxService/VBoxServiceVMInfo.cpp.orig 2010-01-18 10:53:11.000000000 +0100
|
||||
+++ src/VBox/Additions/common/VBoxService/VBoxServiceVMInfo.cpp 2010-01-18 10:53:18.000000000 +0100
|
||||
@@ -38,7 +38,6 @@
|
||||
# include <sys/socket.h>
|
||||
# include <net/if.h>
|
||||
# include <unistd.h>
|
||||
-# include <utmp.h>
|
||||
# ifdef RT_OS_SOLARIS
|
||||
# include <sys/sockio.h>
|
||||
# endif
|
|
@ -4,6 +4,7 @@ sbin/VBoxControl
|
|||
sbin/VBoxService
|
||||
%%X11%%lib/xorg/modules/drivers/vboxvideo_drv.so
|
||||
%%X11%%lib/xorg/modules/input/vboxmouse_drv.so
|
||||
%%HAL%%share/hal/fdi/policy/10osvendor/90-vboxguest.fdi
|
||||
%%X11%%@dirrmtry lib/xorg/modules/drivers
|
||||
%%X11%%@dirrmtry lib/xorg/modules/input
|
||||
%%X11%%@dirrmtry lib/xorg/modules
|
||||
|
@ -11,3 +12,5 @@ sbin/VBoxService
|
|||
%%X11%%@dirrmtry lib
|
||||
@cwd /
|
||||
%%KMODDIR%%/vboxguest.ko
|
||||
@exec /usr/sbin/kldxref %%KMODDIR%%
|
||||
@unexec /usr/sbin/kldxref %%KMODDIR%%
|
||||
|
|
Loading…
Reference in a new issue