Add rast 0.3.1, full-text search system using N-gram.
This commit is contained in:
parent
c4a3f34638
commit
e480c1064c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=154807
6 changed files with 192 additions and 0 deletions
|
@ -634,6 +634,7 @@
|
|||
SUBDIR += queequeg
|
||||
SUBDIR += rand
|
||||
SUBDIR += raptor
|
||||
SUBDIR += rast
|
||||
SUBDIR += re_graph
|
||||
SUBDIR += redet
|
||||
SUBDIR += redland
|
||||
|
|
74
textproc/rast/Makefile
Normal file
74
textproc/rast/Makefile
Normal file
|
@ -0,0 +1,74 @@
|
|||
# New ports collection makefile for: rast
|
||||
# Date created: Jan 2 2006
|
||||
# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= rast
|
||||
PORTVERSION= 0.3.1
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://projects.netlab.jp/rast/archives/ \
|
||||
http://dist.bsdlab.org/
|
||||
|
||||
MAINTAINER= kuriyama@FreeBSD.org
|
||||
COMMENT= Full-text search system using N-gram
|
||||
|
||||
BUILD_DEPENDS= nkf:${PORTSDIR}/japanese/nkf
|
||||
LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr
|
||||
|
||||
USE_BZIP2= YES
|
||||
USE_BDB= 42
|
||||
GNU_CONFIGURE= YES
|
||||
USE_GMAKE= YES
|
||||
USE_RUBY= YES
|
||||
CONFIGURE_ARGS= --with-apr-config=${LOCALBASE}/bin/apr-1-config \
|
||||
--with-apu-config=${LOCALBASE}/bin/apu-1-config \
|
||||
--with-db-includes="-I${LOCALBASE}/include/db42" \
|
||||
--with-db-libs="-L${LOCALBASE}/lib/db42 -ldb-4.2" \
|
||||
--with-ruby=${LOCALBASE}/bin/ruby \
|
||||
--with-default-encoding=${DEFAULT_ENCODING} \
|
||||
--with-filter-moduledir=${PREFIX}/lib/rast/filters
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" LDFLAGS="-lz"
|
||||
INSTALLS_SHLIB= YES
|
||||
|
||||
MAN1= rast-config.1 rast-create.1 rast-delete.1 rast-optimize.1 \
|
||||
rast-register.1 rast-search.1
|
||||
|
||||
.if defined(WITH_ICU)
|
||||
CONFIGURE_ARGS+= --with-icu-config=${LOCALBASE}/bin/icu-config
|
||||
BUILD_DEPENDS+= icu-config:${PORTSDIR}/devel/icu
|
||||
DEFAULT_ENCODING= utf8
|
||||
PLIST_SUB+= WITH_UTF8=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-icu-config
|
||||
PLIST_SUB+= WITH_UTF8="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MECAB)
|
||||
CONFIGURE_ARGS+= --with-mecab-config=${LOCALBASE}/bin/mecab-config
|
||||
BUILD_DEPENDS+= mecab-config:${PORTSDIR}/japanese/mecab
|
||||
PLIST_SUB+= WITH_MECAB_EUC_JP=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-mecab-config
|
||||
PLIST_SUB+= WITH_MECAB_EUC_JP="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_XMLRPC_C)
|
||||
CONFIGURE_ARGS+= --with-xmlrpc-c-config=${LOCALBASE}/bin/xmlrpc-c-config
|
||||
BUILD_DEPENDS+= xmlrpc-c-config:${PORTSDIR}/net/xmlrpc-c
|
||||
PLIST_SUB+= WITH_XMLRPC_C=""
|
||||
MAN1+= rast_xmlrpc_server_abyss.1
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-xmlrpc-c-config
|
||||
PLIST_SUB+= WITH_XMLRPC_C="@comment "
|
||||
.endif
|
||||
|
||||
# For 4.x systems.
|
||||
.if !exists(/usr/include/magic.h)
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/include/magic.h:${PORTSDIR}/sysutils/file
|
||||
.endif
|
||||
|
||||
DEFAULT_ENCODING?= euc_jp
|
||||
|
||||
.include <bsd.port.mk>
|
3
textproc/rast/distinfo
Normal file
3
textproc/rast/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (rast-0.3.1.tar.bz2) = baa52511e6c9eb838ed80bcc22bf7323
|
||||
SHA256 (rast-0.3.1.tar.bz2) = 4330b3cae5a75d122dcdc9af84471ae2694bc6b78ac8cf5954216b4153aa534a
|
||||
SIZE (rast-0.3.1.tar.bz2) = 719583
|
18
textproc/rast/files/patch-merger.c
Normal file
18
textproc/rast/files/patch-merger.c
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- src/merger.c.orig Wed Jan 4 21:41:15 2006
|
||||
+++ src/merger.c Wed Jan 4 21:41:34 2006
|
||||
@@ -48,6 +48,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
+ {
|
||||
rast_merger_t *db = (rast_merger_t *)
|
||||
apr_palloc(pool, sizeof(rast_merger_t));
|
||||
*base = (rast_db_t *) db;
|
||||
@@ -58,6 +59,7 @@
|
||||
db->merged_dbs = merge_dbs;
|
||||
db->properties = NULL;
|
||||
db->num_properties = 0;
|
||||
+ }
|
||||
return RAST_OK;
|
||||
}
|
||||
|
3
textproc/rast/pkg-descr
Normal file
3
textproc/rast/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
Rast is a full-text search system.
|
||||
|
||||
WWW: http://projects.netlab.jp/rast/
|
93
textproc/rast/pkg-plist
Normal file
93
textproc/rast/pkg-plist
Normal file
|
@ -0,0 +1,93 @@
|
|||
bin/rast
|
||||
bin/rast-cmd
|
||||
bin/rast-config
|
||||
bin/rast-create
|
||||
bin/rast-delete
|
||||
bin/rast-optimize
|
||||
bin/rast-register
|
||||
bin/rast-search
|
||||
bin/rast-stat
|
||||
%%WITH_XMLRPC_C%%bin/rast-xmlrpc-server-abyss
|
||||
%%WITH_XMLRPC_C%%bin/rast-xmlrpc-server.cgi
|
||||
include/rast/config.h
|
||||
include/rast/db.h
|
||||
include/rast/encoding.h
|
||||
include/rast/error.h
|
||||
include/rast/filter.h
|
||||
include/rast/local_db.h
|
||||
include/rast/macros.h
|
||||
include/rast/merger.h
|
||||
include/rast/pack.h
|
||||
include/rast/property.h
|
||||
include/rast/query.h
|
||||
include/rast/rast.h
|
||||
include/rast/result.h
|
||||
include/rast/string.h
|
||||
include/rast/text_index.h
|
||||
include/rast/types.h
|
||||
include/rast/util.h
|
||||
%%WITH_XMLRPC_C%%include/rast/xmlrpc_client.h
|
||||
lib/librast.a
|
||||
lib/librast.la
|
||||
lib/librast.so
|
||||
lib/librast.so.1
|
||||
lib/librast_ruby.a
|
||||
lib/librast_ruby.la
|
||||
lib/librast_ruby.so
|
||||
lib/librast_ruby.so.0
|
||||
%%WITH_XMLRPC_C%%lib/librast_xmlrpc_client.a
|
||||
%%WITH_XMLRPC_C%%lib/librast_xmlrpc_client.la
|
||||
%%WITH_XMLRPC_C%%lib/librast_xmlrpc_client.so
|
||||
%%WITH_XMLRPC_C%%lib/librast_xmlrpc_client.so.1
|
||||
%%WITH_XMLRPC_C%%lib/librast_xmlrpc_server.a
|
||||
%%WITH_XMLRPC_C%%lib/librast_xmlrpc_server.la
|
||||
%%WITH_XMLRPC_C%%lib/librast_xmlrpc_server.so
|
||||
%%WITH_XMLRPC_C%%lib/librast_xmlrpc_server.so.1
|
||||
lib/rast/encodings/euc_jp.a
|
||||
lib/rast/encodings/euc_jp.la
|
||||
lib/rast/encodings/euc_jp.so
|
||||
%%WITH_MECAB_EUC_JP%%lib/rast/encodings/mecab_euc_jp.a
|
||||
%%WITH_MECAB_EUC_JP%%lib/rast/encodings/mecab_euc_jp.la
|
||||
%%WITH_MECAB_EUC_JP%%lib/rast/encodings/mecab_euc_jp.so
|
||||
%%WITH_UTF8%%lib/rast/encodings/utf8.a
|
||||
%%WITH_UTF8%%lib/rast/encodings/utf8.la
|
||||
%%WITH_UTF8%%lib/rast/encodings/utf8.so
|
||||
lib/rast/filters/bzip2.a
|
||||
lib/rast/filters/bzip2.la
|
||||
lib/rast/filters/bzip2.so
|
||||
lib/rast/filters/combine_lineend_hyphen.a
|
||||
lib/rast/filters/combine_lineend_hyphen.la
|
||||
lib/rast/filters/combine_lineend_hyphen.so
|
||||
lib/rast/filters/gzip.a
|
||||
lib/rast/filters/gzip.la
|
||||
lib/rast/filters/gzip.so
|
||||
lib/rast/filters/html.a
|
||||
lib/rast/filters/html.la
|
||||
lib/rast/filters/html.so
|
||||
lib/rast/filters/ruby/calc.rb
|
||||
lib/rast/filters/ruby/combine-lineend-japanese.rb
|
||||
lib/rast/filters/ruby/excel.rb
|
||||
lib/rast/filters/ruby/html.rb
|
||||
lib/rast/filters/ruby/impress.rb
|
||||
lib/rast/filters/ruby/mp3.rb
|
||||
lib/rast/filters/ruby/msoffice-property.rb
|
||||
lib/rast/filters/ruby/msword.rb
|
||||
lib/rast/filters/ruby/pdf.rb
|
||||
lib/rast/filters/ruby/postscript.rb
|
||||
lib/rast/filters/ruby/powerpoint.rb
|
||||
lib/rast/filters/ruby/read-buckets-to-buffer.rb
|
||||
lib/rast/filters/ruby/read-buckets-to-file.rb
|
||||
lib/rast/filters/ruby/rfc822.rb
|
||||
lib/rast/filters/ruby/tar.rb
|
||||
lib/rast/filters/ruby/writer.rb
|
||||
lib/rast/filters/ruby/zip.rb
|
||||
lib/rast/filters/ruby_wrapper.a
|
||||
lib/rast/filters/ruby_wrapper.la
|
||||
lib/rast/filters/ruby_wrapper.so
|
||||
%%RUBY_SITEARCHLIBDIR%%/rast.so
|
||||
share/aclocal/rast.m4
|
||||
@dirrm include/rast
|
||||
@dirrm lib/rast/encodings
|
||||
@dirrm lib/rast/filters/ruby
|
||||
@dirrm lib/rast/filters
|
||||
@dirrm lib/rast
|
Loading…
Reference in a new issue