- Update to version 1.92f

- Add automatic track length calculation with -a option.
- Add -i (info) and -l <len> (only play <len> length) options.
- Show enabled and persistent channels.

PR:		57200
Submitted by:	maintainer
This commit is contained in:
Kirill Ponomarev 2003-09-25 09:24:10 +00:00
parent e8508cf75b
commit e4a8648341
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=89333
4 changed files with 55 additions and 71 deletions

View file

@ -6,20 +6,23 @@
#
PORTNAME= nosefart
PORTVERSION= 1.92
PORTREVISION= 1
PORTVERSION= 1.92f
CATEGORIES= audio emulators
MASTER_SITES= http://www.meowfishies.com/code/
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION}-mls
MAINTAINER= sethk@meowfishies.com
COMMENT= A player for NES Sound Format (NSF)
USE_GETOPT_LONG=yes
USE_ZIP= yes
USE_GMAKE= yes
MAKEFILE= Makefile.linux
MAKE_ENV= INSTALL="${INSTALL}" BINGRP=${BINGRP} BINMODE=${BINMODE} \
BINOWN=${BINOWN} LDFLAGS="${LDFLAGS}"
MAKE_ENV= INSTALL="${INSTALL}" COPY="${COPY}" STRIP="${STRIP}"\
BINGRP="${BINGRP}" BINMODE="${BINMODE}" BINOWN="${BINOWN}"\
LDFLAGS="${LDFLAGS}"
post-extract:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} clean)
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (nosefart-1.92.zip) = 88d03f2c8feeb452c043e93eec62b866
MD5 (nosefart-1.92f-mls.tar.gz) = 2aa162069a44a7d2b299ed06eded6de6

View file

@ -1,86 +1,67 @@
--- Makefile.linux.orig Wed Oct 11 13:05:18 2000
+++ Makefile.linux Thu Oct 12 14:07:05 2000
@@ -3,12 +3,6 @@
--- Makefile.orig Wed Sep 24 11:02:34 2003
+++ Makefile Wed Sep 24 19:43:19 2003
@@ -1,12 +1,6 @@
################################
# Configuration
-CC = gcc
-CFLAGS =
-LDFLAGS =
-LDFLAGS = -lm
-PREFIX = /usr/local
-# WANT_DEBUG = TRUE
-WANT_DEBUG=TRUE
-
# nothing below here should need to be changed
################################
@@ -25,14 +19,10 @@
-I$(SRCDIR)/sndhrdw\
-I$(SRCDIR)/machine\
-I$(SRCDIR)/cpu/nes6502\
+ -I$(LOCALBASE)/include\
-I$(BUILDDIR)
@@ -21,19 +15,13 @@
CFLAGS += -DNSF_PLAYER
-ifeq "$(WANT_DEBUG)" "TRUE"
- CFLAGS += -ggdb -DNSF_PLAYER
- CFLAGS += -ggdb
-else
- CFLAGS += -O2 -fomit-frame-pointer -ffast-math -funroll-loops -DNSF_PLAYER
- CFLAGS += -O2 -fomit-frame-pointer -ffast-math -funroll-loops
- DEBUG_OBJECTS =
-endif
+CFLAGS += -DNSF_PLAYER
-
CFLAGS +=\
-I$(SRCDIR)\
-I$(SRCDIR)/linux\
-I$(SRCDIR)/sndhrdw\
-I$(SRCDIR)/machine\
-I$(SRCDIR)/cpu/nes6502\
+ -I$(LOCALBASE)/include\
-I$(BUILDTOP)\
-I/usr/local/include/
################################
# Here's where the directory tree gets ugly
@@ -55,36 +45,26 @@
OBJS = $(addsuffix .o, $(FILES))
OBJECTS = $(addprefix $(BUILDDIR)/, $(OBJS))
@@ -59,9 +47,11 @@
SOURCES = $(addprefix $(SRCDIR)/, $(SRCS))
OBJECTS = $(patsubst $(SRCDIR)/%.c,$(BUILDDIR)/%.o,$(SOURCES))
+LDLIBS = -lm
+
ALL_OBJECTS = $(OBJECTS)
-ALL_TARGETS = $(BUILDTOP)/$(NAME)
+ALL_TARGETS = $(BUILDTOP)/config.h $(BUILDTOP)/$(NAME)
################################
# Rules
@@ -87,7 +77,7 @@
-all: $(BUILDDIR)/$(NAME)
+all: $(BUILDDIR)/config.h $(BUILDDIR)/$(NAME)
################################
# Support
-$(BUILDDIR):
+$(BUILDDIR)/config.h: Makefile.linux
+ [ -d $(BUILDDIR) ] || mkdir -p $(BUILDDIR)
-mkdir -p $(BUILDDIR)/cpu/nes6502 $(BUILDDIR)/machine $(BUILDDIR)/sndhrdw $(BUILDDIR)/linux
-
-$(BUILDDIR)/config.h: $(BUILDDIR) Makefile.linux
echo "#define VERSION \"$(VERSION)\"" > $(BUILDDIR)/config.h
echo "#define NAME \"$(NAME)\"" >> $(BUILDDIR)/config.h
-$(BUILDDIR)/dep: $(BUILDDIR)/config.h
- $(CC) $(CFLAGS) -M $(SOURCES) > $@
-
-include $(BUILDDIR)/dep
-
install: $(BUILDDIR)/$(NAME)
- mkdir -p $(PREFIX)/bin
- cp $(BUILDDIR)/$(NAME) $(PREFIX)/bin
- @echo "-----------------------------------------------"
- @echo "Be sure to run chmod +s $(PREFIX)/bin/$(NAME) if you want ordinary users"
- @echo "to be able to use /dev/dsp. SUID isn't necessary, though, if you want to"
- @echo "run $(NAME) with a wrapper, like artsdsp from arts or esddsp from esound."
- @echo "-----------------------------------------------"
- @echo "Also, make sure that $(PREFIX)/bin is in your PATH."
-
+ [ -d $(PREFIX)/bin ] || mkdir -p $(PREFIX)/bin
+ $(INSTALL) -cs -g $(BINGRP) -m $(BINMODE) -o $(BINOWN) $(BUILDDIR)/$(NAME) $(PREFIX)/bin
+
uninstall:
rm -f $(PREFIX)/bin/$(NAME)
@@ -92,7 +72,7 @@
install: all
mkdir -p $(PREFIX)/bin
- cp $(ALL_TARGETS) $(PREFIX)/bin
+ $(INSTALL) $(COPY) $(STRIP) -g $(BINGRP) -m $(BINMODE) -o $(BINOWN) $(BUILDTOP)/$(NAME) $(PREFIX)/bin
@echo "-----------------------------------------------"
@echo "Be sure to run chmod +s $(PREFIX)/bin/$(NAME) if you want ordinary users"
@echo "to be able to use /dev/dsp. SUID isn't necessary, though, if you want to"
@@ -105,7 +95,7 @@
# The real heavy lifting
$(BUILDDIR)/$(NAME): $(OBJECTS)
- $(CC) $(LDFLAGS) -o $@ $(OBJECTS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJECTS) $(LDLIBS)
$(BUILDTOP)/$(NAME): $(OBJECTS)
- $(CC) $(NSFINFO_CFLAGS) $(LDFLAGS) -o $@ $^
+ $(CC) $(NSFINFO_CFLAGS) $(LDFLAGS) -o $@ $^ $(LDLIBS)
$(BUILDDIR)/%.o: $(SRCDIR)/%.c
$(CC) $(CFLAGS) -o $@ -c $<
$(BUILDDIR)/%.o: $(SRCDIR)/%.c
$(CC) $(NSFINFO_CFLAGS) -o $@ -c $<

View file

@ -2,7 +2,7 @@ This is a port of Nosefart, a player for the NSF sound format, which
describes music taken from Nintendo Entertainment System game cartriges
in a compact form.
WWW: http://www.nofrendo.org/nosefart/
WWW: http://sourceforge.net/projects/nosefart
- Seth
sethk@osd.bsdi.com
sethk@meowfishies.com