Repocopy math/netcdf to science/netcdf, along with cdf, hdf and hdf5.
PR: 92497 Submitted by: /me Repocopied by: marcus
This commit is contained in:
parent
fbab09fee3
commit
e4bf1fcd30
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=154853
23 changed files with 17 additions and 114 deletions
1
MOVED
1
MOVED
|
@ -2156,3 +2156,4 @@ net/xnap|net-p2p/xnap|2006-01-30|Moved to new category
|
|||
misc/ed2k|net-p2p/ed2k|2006-01-30|Moved to new category
|
||||
misc/edonkey-tool-hash|net-p2p/edonkey-tool-hash|2006-01-30|Moved to new category
|
||||
misc/linux-edonkey-tool-recovermet|net-p2p/linux-edonkey-tool-recovermet|2006-01-30|Moved to new category
|
||||
math/netcdf|science/netcdf|2006-01-30|Moved to a better category
|
||||
|
|
|
@ -23,7 +23,7 @@ EXTRACT_ONLY= ${DISTNAME}_progs${EXTRACT_SUFX} \
|
|||
MAINTAINER= sec@42.org
|
||||
COMMENT= The Generic Mapping Tools data processing and display software package
|
||||
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
|
||||
EXTRACT_SUB= GMT_share${EXTRACT_SUFX}
|
||||
|
||||
|
|
|
@ -45,7 +45,7 @@ PLIST_SUB+= NETCDF="@comment " HDF=""
|
|||
.endif
|
||||
|
||||
.if defined(WITH_NETCDF)
|
||||
LIB_DEPENDS+= netcdf.1:${PORTSDIR}/math/netcdf
|
||||
LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
CONFIGURE_ARGS+= --with-nc
|
||||
PLIST_SUB+= NETCDF="" HDF="@comment "
|
||||
.endif
|
||||
|
|
|
@ -45,7 +45,7 @@ CONFIGURE_ARGS+= --without-hdf
|
|||
.endif
|
||||
|
||||
.if defined(WITH_NETCDF)
|
||||
LIB_DEPENDS+= netcdf.1:${PORTSDIR}/math/netcdf
|
||||
LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-netcdf
|
||||
.endif
|
||||
|
|
|
@ -133,7 +133,6 @@
|
|||
SUBDIR += naturalmath
|
||||
SUBDIR += nauty
|
||||
SUBDIR += ndiff
|
||||
SUBDIR += netcdf
|
||||
SUBDIR += newmat
|
||||
SUBDIR += ngraph
|
||||
SUBDIR += nsc2ke
|
||||
|
|
|
@ -20,7 +20,7 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= A powerful plotting tool (successor of xmgr)
|
||||
|
||||
LIB_DEPENDS= Xbae:${PORTSDIR}/x11-toolkits/xbae \
|
||||
netcdf.1:${PORTSDIR}/math/netcdf \
|
||||
netcdf.1:${PORTSDIR}/science/netcdf \
|
||||
fftw.2:${PORTSDIR}/math/fftw \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
|
|
|
@ -15,7 +15,7 @@ DISTNAME= gri-${PORTVERSION}-arch-indep
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= An extensible plotting language for producing scientific graphs
|
||||
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
|
|
@ -21,7 +21,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
|
|||
gsl.7:${PORTSDIR}/math/gsl \
|
||||
jasper.4:${PORTSDIR}/graphics/jasper \
|
||||
fftw3.3:${PORTSDIR}/math/fftw3 \
|
||||
netcdf:${PORTSDIR}/math/netcdf \
|
||||
netcdf:${PORTSDIR}/science/netcdf \
|
||||
qwtplot3d.0:${PORTSDIR}/math/qwtplot3d
|
||||
RUN_DEPENDS= pstoedit:${PORTSDIR}/graphics/pstoedit
|
||||
|
||||
|
|
|
@ -1,50 +0,0 @@
|
|||
# New ports collection makefile for: netcdf
|
||||
# Date created: 29 July 1999
|
||||
# Whom: Thomas Gellekum <tg@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= netcdf
|
||||
PORTVERSION= 3.6.0p1
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/
|
||||
MASTER_SITE_SUBDIR= . old
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/-p/}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Library for machine-independent, array-oriented data access
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/src
|
||||
|
||||
CONFLICTS= hdf-4.*
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-fPIC -DPIC -Df2cFortran"
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= ncdump.1 ncgen.1
|
||||
MAN3= netcdf.3 netcdf.3f
|
||||
|
||||
post-build:
|
||||
@(cd ${WRKSRC}/libsrc && \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
|
||||
@(cd ${WRKSRC}/cxx && \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${PREFIX}/bin/ncdump
|
||||
@${STRIP_CMD} ${PREFIX}/bin/ncgen
|
||||
${INSTALL_DATA} ${WRKSRC}/libsrc/libnetcdf.so ${PREFIX}/lib/libnetcdf.so.1
|
||||
${LN} -sf libnetcdf.so.1 ${PREFIX}/lib/libnetcdf.so
|
||||
${INSTALL_DATA} ${WRKSRC}/cxx/libnetcdf_c++.so ${PREFIX}/lib/libnetcdf_c++.so.1
|
||||
${LN} -sf libnetcdf_c++.so.1 ${PREFIX}/lib/libnetcdf_c++.so
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for file in COPYRIGHT README RELEASE_NOTES
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (netcdf-3.6.0-p1.tar.gz) = 27c193e0462d9979406d167a01a5ee95
|
||||
SHA256 (netcdf-3.6.0-p1.tar.gz) = a9e6105ed89ce6cfd2edc78e8184232a2f950e674c5241c28cae361a1fe1adfe
|
||||
SIZE (netcdf-3.6.0-p1.tar.gz) = 842025
|
|
@ -1,19 +0,0 @@
|
|||
--- rules.make.orig Sat Dec 18 05:34:48 2004
|
||||
+++ rules.make Thu Jan 6 15:12:59 2005
|
||||
@@ -145,14 +145,8 @@
|
||||
$(INSTALL) $(MANUAL) $@
|
||||
$(MANDIR)/man3/$(MANUAL): $(MANDIR)/man3 $(MANUAL)
|
||||
$(INSTALL) $(MANUAL) $@
|
||||
-$(MANDIR)/man3f/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL) \
|
||||
- $(MANDIR)/man3f
|
||||
- rm -f $@
|
||||
- ln -s $(MANDIR)/man3/$(MANUAL) $@
|
||||
-$(MANDIR)/man3f90/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL) \
|
||||
- $(MANDIR)/man3f90
|
||||
- rm -f $@
|
||||
- ln -s $(MANDIR)/man3/$(MANUAL) $@
|
||||
+$(MANDIR)/man3f/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL)
|
||||
+$(MANDIR)/man3f90/$(MANUAL): $(MANDIR)/man3 $(MANDIR)/man3/$(MANUAL)
|
||||
|
||||
################################################################################
|
||||
# Cleanup:
|
|
@ -1,9 +0,0 @@
|
|||
NetCDF (network Common Data Form) is an interface for array-oriented
|
||||
data access and a library that provides an implementation of the
|
||||
interface. The netCDF library also defines a machine-independent
|
||||
format for representing scientific data. Together, the interface,
|
||||
library, and format support the creation, access, and sharing of
|
||||
scientific data. The netCDF software was developed at the Unidata
|
||||
Program Center in Boulder, Colorado.
|
||||
|
||||
WWW: http://www.unidata.ucar.edu/packages/netcdf/
|
|
@ -1,17 +0,0 @@
|
|||
bin/ncdump
|
||||
bin/ncgen
|
||||
include/ncvalues.h
|
||||
include/netcdf.h
|
||||
include/netcdf.hh
|
||||
include/netcdf.inc
|
||||
include/netcdfcpp.h
|
||||
lib/libnetcdf.a
|
||||
lib/libnetcdf.so
|
||||
lib/libnetcdf.so.1
|
||||
lib/libnetcdf_c++.a
|
||||
lib/libnetcdf_c++.so
|
||||
lib/libnetcdf_c++.so.1
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
|
@ -16,7 +16,7 @@ EXTRACT_SUFX= .tar.Z
|
|||
MAINTAINER= rand@meridian-enviro.com
|
||||
COMMENT= Perl5 module to read and write netCDF files
|
||||
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
|
||||
USE_PERL5= yes
|
||||
|
||||
|
|
|
@ -143,7 +143,7 @@ CONFIGURE_ARGS+= --with-parmetis=1 \
|
|||
#WITH_NETCDF= yes
|
||||
#.endif
|
||||
#.if defined(WITH_NETCDF)
|
||||
#LIB_DEPENDS+= netcdf.1:${PORTSDIR}/math/netcdf
|
||||
#LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
#CONFIGURE_ENV+= NETCDF_INCLUDE=${LOCALBASE}/include \
|
||||
# NETCDF_LIB=${LOCALBASE}/lib
|
||||
#.endif
|
||||
|
|
|
@ -17,7 +17,7 @@ MAINTAINER= tg@FreeBSD.org
|
|||
COMMENT= Collection of Python modules for scientific computing
|
||||
|
||||
BUILD_DEPENDS= ${PYNUMERIC}
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
RUN_DEPENDS= ${PYNUMERIC}
|
||||
|
||||
USE_PYTHON= yes
|
||||
|
|
|
@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= A Ruby interface to the NetCDF scientific IO library
|
||||
|
||||
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
|
||||
|
||||
USE_RUBY= yes
|
||||
|
|
|
@ -48,6 +48,7 @@
|
|||
SUBDIR += mpb
|
||||
SUBDIR += mpqc
|
||||
SUBDIR += mpqc-mpich
|
||||
SUBDIR += netcdf
|
||||
SUBDIR += oases
|
||||
SUBDIR += omnetpp
|
||||
SUBDIR += openbabel
|
||||
|
|
|
@ -69,7 +69,7 @@ CONFIGURE_ARGS+=--with-hdf5=no
|
|||
.endif
|
||||
|
||||
.if !defined(WITHOUT_NETCDF)
|
||||
LIB_DEPENDS+= netcdf.1:${PORTSDIR}/math/netcdf
|
||||
LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
CONFIGURE_ARGS+=--with-netcdf=${LOCALBASE} --with-hdf=no
|
||||
.else
|
||||
CONFIGURE_ARGS+=--with-netcdf=no
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= netcdf
|
||||
PORTVERSION= 3.6.0p1
|
||||
CATEGORIES= math
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/
|
||||
MASTER_SITE_SUBDIR= . old
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/-p/}
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= netcdf
|
||||
PORTVERSION= 3.6.0p1
|
||||
CATEGORIES= math
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/
|
||||
MASTER_SITE_SUBDIR= . old
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/-p/}
|
||||
|
|
|
@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= A Ruby interface to the NetCDF scientific IO library
|
||||
|
||||
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf
|
||||
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
|
||||
|
||||
USE_RUBY= yes
|
||||
|
|
|
@ -18,7 +18,7 @@ COMMENT= An OpenGL-based volumetric visualization program for scientific dataset
|
|||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libmix.a:${PORTSDIR}/graphics/qslim \
|
||||
convert:${PORTSDIR}/graphics/ImageMagick
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf \
|
||||
LIB_DEPENDS= netcdf.1:${PORTSDIR}/science/netcdf \
|
||||
gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
|
||||
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
|
||||
|
||||
|
|
Loading…
Reference in a new issue